This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 206930 - grep-2.5.1 core dumps in RHEL4-U4 when searching for a case insensitive string containing a full stop, in a particular file
grep-2.5.1 core dumps in RHEL4-U4 when searching for a case insensitive strin...
Status: CLOSED DUPLICATE of bug 202991
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: grep (Show other bugs)
4.4
i686 Linux
high Severity high
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 05:30 EDT by Stuart Winter
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-18 06:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Contains mod_python.so and a core dump (440.42 KB, application/x-gzip)
2006-09-18 05:30 EDT, Stuart Winter
no flags Details

  None (edit)
Description Stuart Winter 2006-09-18 05:30:12 EDT
Description of problem:

grep-2.5.1 core dumps when you specify grep -i and search for a string
containing a full stop in mod_python.so

Version-Release number of selected component (if applicable):

Name        : grep                         Relocations: (not relocatable)
Version     : 2.5.1                             Vendor: Red Hat, Inc.
Release     : 32.2                          Build Date: Mon 20 Feb 2006 11:57:24
PM KST

RHEL4 update 4 -- fully updated machine.

How reproducible:

Always

Steps to Reproduce:
1. up2date mod_python
2. cd /etc/httpd/modules
3. grep -i foo.bar mod_python.so
  
Actual results:

[/etc/httpd/modules] $ grep -ir foo.bar mod_python.so
*** glibc detected *** free(): invalid next size (fast): 0x08d41ae8 ***
Aborted (core dumped)

This crash only occurs if:
 1. You search for a string containing a period (full stop)
 2. You use -i -- case insensitive searching


Expected results:

Not core dump.

Additional info:

I compiled grep-2.5.1 proper with ./configure && make on the same machine.

[/etc/httpd/modules] $ /tmp/grep --version|head -n1
grep (GNU grep) 2.5.1

[root@ns1] [06:22:49]
[/etc/httpd/modules] $ /tmp/grep -ri foo.bar mod_python.so

Works fine.
Comment 1 Stuart Winter 2006-09-18 05:30:12 EDT
Created attachment 136524 [details]
Contains mod_python.so and a core dump
Comment 2 Tim Waugh 2006-09-18 06:23:03 EDT

*** This bug has been marked as a duplicate of 202991 ***

Note You need to log in before you can comment on or make changes to this bug.