Bug 206949 - Anaconda blows up early in install
Anaconda blows up early in install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 09:19 EDT by Alan Cox
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 07:00:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2006-09-18 09:19:39 EDT
Description of problem:

Anaconda goes through the early parts of the process and then produces four
dialogs aobut /dev/sda,b,c,d having no medium installed (which is believable as
it's a USB card reader widget). It then prints up

"No handlers could be found for logger yum.YumBase"

and aborts.

Box is a generic AMD64 whitebox with VIA and SI680 IDE on it (4 disks on the
SI680 in /dev/md). CD-ROM on the via. 

Version-Release number of selected component (if applicable):


How reproducible: 100%
Comment 1 Chris Lumens 2006-09-18 11:59:22 EDT
I don't think the yum message should be causing the installer to abort.  Are you
getting any suspect kernel messages on tty4?  When it aborts, are you just
getting the "installer exited abnormally [1/1]" message, or is it more useful
than that?
Comment 2 Alan Cox 2006-09-18 12:08:05 EDT
There are no kernel messages indicating failure, just the installer message. I
could reproduce it (I've blown away that environment now doing an install test).
It happened on upgrade attempts but not on install. On install attempts the
system crashes part way through the install as seems to be the case for other
boxes I've tried (thats got its own kernel bug assigned).
Comment 3 Alan Cox 2006-09-18 12:09:31 EDT
Should add btw FC6t2 is fine on this box, and has been running stably for some
time with nothing but the expected application bugs and unfixed things.
Comment 4 Alan Cox 2006-10-02 07:00:18 EDT
Fc6Pre works correctly

Note You need to log in before you can comment on or make changes to this bug.