Bug 206951 - Kernel hangs during install
Kernel hangs during install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 09:24 EDT by Alan Cox
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 07:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2006-09-18 09:24:03 EDT
AMD64 box with Jmicron SATA (AHCI). Nvidia chipset (onboard video), DVD drive on
the Nvidia built in IDE disks on the two SATA ports of the Jmicron card.

During the install the system will hang. The one time I got a partial trace of a
crash setting an xattr from selinux but trying to repeat it always got me solid
hangs including much earlier during the disk formatting process. The box in
question has been running other kernels ok although only used for testing work.
 test2 crashed on boot on it owing to another (fixed) bug so I don't know how
old the problem is.

I'll try and find time to memtest86 the box as a double check but it has been
behaving up until now.
Comment 1 Alan Cox 2006-09-18 10:03:35 EDT
I've now duplicated the oops on two different boxes. The other is VIA chipset
with PATA (SIL680) and two disk arrays set up for md (swap on raid0, fs on raid1) 

top of trace is off screen

security_compute_av
avc_has_perm_noaudit
security_context_to_sid_core
avc_has_perm
selinux_inode_setxattr
mutex_load_slowpath
debug_mutex_free_waiter
vfs_setxattr
setxattr
trace_hardirq_thunk
poison_obj
kmem_cache_free
trace_hardirqs_on
do_path_lookup
putname
__user_walk_fd
sys_lsetxattr
__fput
trace_hardirq_on_thunk
trace_hardirqs_on
trace_hardirq_on_thunk
selinux_inode_free_security
system_call

Comment 2 Alan Cox 2006-09-18 10:26:34 EDT
Disabling selinux gives me hangs - on both boxes. One commonaility is the use of md

At this point there's not much more I can to debug further, but I can test new
boot iso images if a specific fix is made (I don't have time to try them all)
Comment 3 Alan Cox 2006-09-18 10:36:48 EDT
Final note I should make I suppose - the second box ran test2 reliably and also
2.6.18-rc6-mm kernels on a regular basis.
Comment 4 Dave Jones 2006-09-20 16:26:27 EDT
Sounds like fallout from the squashfs memory corruptor. Jeremy, do we have
updated boot.iso's with the workaround yet ?
Comment 5 Jeremy Katz 2006-09-20 17:08:55 EDT
Today's rawhide has the workaround in place
Comment 6 Alan Cox 2006-10-02 07:02:19 EDT
Seems to be ok in FC6Pre.

Note You need to log in before you can comment on or make changes to this bug.