Bug 206958 - rpc.statd not obeying -o switch
rpc.statd not obeying -o switch
Status: CLOSED DUPLICATE of bug 210283
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: nfs-utils (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 10:29 EDT by Richard Cunningham
Modified: 2007-11-16 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 20:52:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix statd -o option (705 bytes, patch)
2006-10-25 05:12 EDT, Howard Johnson
no flags Details | Diff

  None (edit)
Description Richard Cunningham 2006-09-18 10:29:40 EDT
Description of problem:
when rpc.statd is started with a -o option it is ignored and random port is used
instead

Version-Release number of selected component (if applicable):
# rpm -q nfs-utils
nfs-utils-1.0.6-70.EL4

How reproducible:
Start rpc.statd with a -o option and argument, look at netstat to see what
really happened

Steps to Reproduce:
1. pkill statd
2. rpc.statd -p 31002 -o 31003
  
Actual results:
# netstat -lep --numeric-ports |grep statd
tcp        0      0 *:31002                     *:*                        
LISTEN      root       861353     11065/rpc.statd
udp        0      0 *:641                       *:*                            
        root       861342     11065/rpc.statd
udp        0      0 *:31002


Expected results:
# netstat -lep --numeric-ports |grep statd
tcp        0      0 *:31002                     *:*                        
LISTEN      rpcuser    861567     11078/rpc.statd
udp        0      0 *:31002                     *:*                            
        rpcuser    861564     11078/rpc.statd
udp        0      0 *:31003                     *:*                            
        root       861556     11078/rpc.statd

Additional info:
This seems to work ok when using rpc.netstat from nfs-utils 1.0.9 
(http://prdownloads.sourceforge.net/nfs/nfs-utils-1.0.9.tar.gz)
Comment 1 Howard Johnson 2006-10-25 05:10:42 EDT
I've come across this too. Looks like upstream fixed it with this patch:

http://marc.theaimsgroup.com/?l=linux-nfs&m=110891787507544&w=2

This doesn't apply to the RHEL4 source. I'll attach a patch that works for me.
Comment 2 Howard Johnson 2006-10-25 05:12:14 EDT
Created attachment 139317 [details]
Patch to fix statd -o option
Comment 3 Steve Dickson 2006-10-30 20:52:43 EST

*** This bug has been marked as a duplicate of 210283 ***

Note You need to log in before you can comment on or make changes to this bug.