Bug 207031 - [x86_64] Floating point exception when starting 32bit C++ binaries (libstdc++-4.1.1-13)
Summary: [x86_64] Floating point exception when starting 32bit C++ binaries (libstdc++...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-18 20:43 UTC by Ben Konrath
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-23 10:42:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
oowriter strace (30.22 KB, text/plain)
2006-09-22 19:26 UTC, Ben Konrath
no flags Details
32bit c++ hello world (4.98 KB, application/octet-stream)
2006-09-23 10:18 UTC, Caolan McNamara
no flags Details

Description Ben Konrath 2006-09-18 20:43:30 UTC
Description of problem:

I get this error when I try to start any openoffice.org program:

% oowriter /usr/lib/openoffice.org2.0/program/soffice: line 140: 23872 Floating
point exception(core dumped) "${sd_prog}"/pagein -L"${sd_prog}"
${sd_pagein_args} /usr/lib/openoffice.org2.0/program/soffice: line 151: 23873
Floating point exception(core dumped) "$sd_prog/$sd_binary" "$@"

% oocalc /usr/lib/openoffice.org2.0/program/soffice: line 140: 23885 Floating
point exception(core dumped) "${sd_prog}"/pagein -L"${sd_prog}"
${sd_pagein_args} /usr/lib/openoffice.org2.0/program/soffice: line 151: 23886
Floating point exception(core dumped) "$sd_prog/$sd_binary" "$@"

Version-Release number of selected component (if applicable):

% rpm -qa | grep openoffice.org
openoffice.org-draw-2.0.2-5.17.2
openoffice.org-calc-2.0.2-5.17.2
openoffice.org-math-2.0.2-5.17.2
openoffice.org-core-2.0.2-5.17.2
openoffice.org-xsltfilter-2.0.2-5.17.2
openoffice.org-impress-2.0.2-5.17.2
openoffice.org-writer-2.0.2-5.17.2
openoffice.org-graphicfilter-2.0.2-5.17.2

How reproducible:

Always.

Comment 1 Caolan McNamara 2006-09-19 07:38:13 UTC
Well, FC-5 OOo is 32bit on 64bit platforms. But otherwise there simply isn't
enough information here to make a guess as to what is wrong.

No crash reporter window ? So must have crashed very early in bootstrapping. Do
you have any other (large) 32bit apps, e.g. 32bit firefox ? Otherwise some
strace or gdb traces might help.

Comment 2 Caolan McNamara 2006-09-22 12:21:03 UTC
I'd need something to work on, it's not reproducable for me, and normally on a
fc-5 crasher like this I'd have a horde of similiar bug reports

Comment 3 Ben Konrath 2006-09-22 19:26:43 UTC
Created attachment 136966 [details]
oowriter strace

I've attached an strace. I don't have a lot of time to debug this right now but
your welcome to log into toast.toronto.redhat.com to debug if you have time.
Thanks.

Comment 4 Caolan McNamara 2006-09-23 10:18:40 UTC
Created attachment 136995 [details]
32bit c++ hello world

Checking on your machine, it seems that any 32bit c++ binary blows up with the
same FPE error, e.g. the attached a.out was created with...

g++ test.c on FC-5 where test.c is just...

#include <stdio.h>

int main(void)
{
	printf("hello world\n");
	return 0;
}

and blows up with the same SIGFPE

Comment 5 Caolan McNamara 2006-09-23 10:23:02 UTC
and gcc test.c -lstdc++ is sufficient to reproduce this, so looks like your
32bit libstdc++.so.6 is hosed somehow.

Not OOo specific, moving to gcc/libstdc++

Comment 6 Jakub Jelinek 2006-09-23 10:42:00 UTC
That's just user error, you must have used --nodeps to force installing of
FC6 package (libstdc++-4.1.1-13) on FC5.  That of course can't work,
FC6 packages need DT_GNU_HASH support in the dynamic linker, which is only
available in FC6 glibc.  libstdc++-4.1.1-13 has rtld(GNU_HASH) among Requires
and only FC6+ glibc provides rtld(GNU_HASH).

Comment 7 Ben Konrath 2006-09-23 18:54:36 UTC
I don't actually remember messing with the system in this way, but I guess I
must have. Thanks Caolan and Jakub for tracking this down. 


Note You need to log in before you can comment on or make changes to this bug.