Bug 207046 - bad call to restorecon in rc.sysinit
Summary: bad call to restorecon in rc.sysinit
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-18 22:58 UTC by Garrett Mitchener
Modified: 2014-03-17 03:02 UTC (History)
1 user (show)

Fixed In Version: 8.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 01:48:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Garrett Mitchener 2006-09-18 22:58:39 UTC
Description of problem:

I have no idea if this is serious or not, but I get a segfault from the
restorecon command at line 678 in /etc/rc.d/rc.sysinit every time I boot up.
This is from initscripts-8.39-1.

The problem seems to be that /etc/blkid.tab does not exist.  I changed mine to
pass in /etc/blkid/blkid.tab and that at least doesn't segfault.

Here's the output of diff:

diff /etc/rc.d/rc.sysinit /etc/rc.d/rc.sysinit~

678c678
<    restorecon /etc/mtab /etc/ld.so.cache /etc/blkid/blkid.tab /etc/resolv.conf
>/dev/null 2>&1
---
>    restorecon /etc/mtab /etc/ld.so.cache /etc/blkid.tab /etc/resolv.conf
>/dev/null 2>&1

Comment 1 Bill Nottingham 2006-09-19 01:48:25 UTC
Well, restorecon obviously shouldn't be segfaulting (already filed); aside from
that, path fixed in CVS, will be in 8.41-1. Thanks!


Note You need to log in before you can comment on or make changes to this bug.