Bug 207067 - Traceback from system-install-packages
Traceback from system-install-packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 207219 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-18 23:12 EDT by Luke Macken
Modified: 2016-09-19 22:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 10:38:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Macken 2006-09-18 23:12:31 EDT
Description of problem:
The following traceback occurs when trying to install an RPM using
system-install-packages.

Component: Software Installer

Summary: TBdff70d31 system-install-packages:82:get_pkg_info:AttributeError:
YumLocalPackage instance has no attribute 'returnNevraPrintable'



Traceback (most recent call last):

  File "/usr/sbin/system-install-packages", line 82, in get_pkg_info

    nevra = pkg.returnNevraPrintable()

AttributeError: YumLocalPackage instance has no attribute 'returnNevraPrintable'



Local variables in innermost frame:

i: <GtkTreeIter at 0xbfb2feb4>

self: <__main__.SinglePackageInstaller object at 0x93d02ac>

cell: <gtk.CellRendererText object (GtkCellRendererText) at 0x93cd824>

pkg: opera - 2:9.01-20060728.6.i386

model: <gtk.ListStore object (GtkListStore) at 0x93cd7ac>

col: <gtk.TreeViewColumn object (GtkTreeViewColumn) at 0x93cd7fc>

Version-Release number of selected component (if applicable):
pirut-1.1.15-1
yum-2.9.6-1
Comment 1 Jeremy Katz 2006-09-19 10:38:59 EDT
Fixed
Comment 2 Jeremy Katz 2006-09-20 10:54:50 EDT
*** Bug 207219 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.