Bug 207137 - init.ipv6-global either consumes all cpu & half of system memory or segfaults with ipv6 enabled.
Summary: init.ipv6-global either consumes all cpu & half of system memory or segfaults...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 207133 207145 207156 207178 207813 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-19 17:25 UTC by Mike Gahagan
Modified: 2014-03-17 03:02 UTC (History)
6 users (show)

Fixed In Version: 8.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 17:48:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Gahagan 2006-09-19 17:25:40 UTC
Description of problem:
init.ipv6-global either consumes all cpu & half of system memory or segfaults
with ipv6 enabled.

Version-Release number of selected component (if applicable):
initscripts-8.40-1

How reproducible:
always

Steps to Reproduce:
1.If system is already running with networking enabled, /etc/init.d/network stop
will cause init.ipv6-global to use all of a CPU and roughly 200MB of RAM until
killed.
2. This usually results in a hang then segfault during boot.
3.
  
Actual results:
Network doesn't go down or system hangs.

Expected results:
Network starts/stops/restarts normally.

Additional info:

setting NETWORKING_IPV6=no in /etc/sysconfig/network gets around the problem and
makes the system usable.

Comment 1 Mike Gahagan 2006-09-19 17:36:25 UTC
It looks like that when we call 'init.ipv6-global stop pre' from
/etc/init.d/network we get stuck in an infinite loop. you can also duplicate the
same behavior by calling init.ipv6-global from the command line. 


+ ACTION=stop
+ POSITION=pre
+ '[' yes = yes ']'
+ '[' -f /etc/sysconfig/network-scripts/network-functions-ipv6 ']'
+ . /etc/sysconfig/network-scripts/network-functions-ipv6
++ . ./network-functions-ipv6
+++ . ./network-functions-ipv6
++++ . ./network-functions-ipv6


Comment 2 Bill Nottingham 2006-09-19 17:44:06 UTC
*** Bug 207133 has been marked as a duplicate of this bug. ***

Comment 3 Bill Nottingham 2006-09-19 17:48:32 UTC
Sed script gone wrong. Fixed in CVS, will be in 8.41-1.

Comment 4 Bill Nottingham 2006-09-19 18:25:19 UTC
*** Bug 207145 has been marked as a duplicate of this bug. ***

Comment 5 Bill Nottingham 2006-09-19 19:07:11 UTC
*** Bug 207156 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2006-09-19 20:30:53 UTC
*** Bug 207178 has been marked as a duplicate of this bug. ***

Comment 7 Bill Nottingham 2006-09-25 16:47:25 UTC
*** Bug 207813 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.