This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 207145 - recursive include of network-functions-ipv6
recursive include of network-functions-ipv6
Status: CLOSED DUPLICATE of bug 207137
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 13:58 EDT by Valdis Kletnieks
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 14:24:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
One-line fix. (289 bytes, application/octet-stream)
2006-09-19 13:58 EDT, Valdis Kletnieks
no flags Details

  None (edit)
Description Valdis Kletnieks 2006-09-19 13:58:42 EDT
Description of problem:
% head /etc/sysconfig/network-scripts/network-functions-ipv6
#!/bin/sh
#
. ./network-functions-ipv6
#
# Taken from: network-functions-ipv6
# (P) & (C) 1997-2005 by Peter Bieringer <pb@bieringer.de>

So when init.ipv6-global includes it, it will include itself, then include
itself, then include itself, till it SIGSEGVs.

Version-Release number of selected component (if applicable):
initscripts-8.40-1

How reproducible:
Start up IPv6 networking


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Looks like somebody hit '.' in vi at an inopportune time and inserted a line
from elsewhere.... Whoops.,
Comment 1 Valdis Kletnieks 2006-09-19 13:58:42 EDT
Created attachment 136662 [details]
One-line fix.
Comment 2 Bill Nottingham 2006-09-19 14:24:43 EDT

*** This bug has been marked as a duplicate of 207133 ***
Comment 3 Bill Nottingham 2006-09-19 14:25:03 EDT
*** This bug has been marked as a duplicate of 207137 ***

*** This bug has been marked as a duplicate of 207137 ***

Note You need to log in before you can comment on or make changes to this bug.