Bug 207248 - ide-scsi module is not loaded automatically for ide tape device
ide-scsi module is not loaded automatically for ide tape device
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Alan Cox
Brian Brock
: Reopened
Depends On:
Blocks: 200812 219113
  Show dependency treegraph
 
Reported: 2006-09-20 03:23 EDT by Shyam kumar Iyer
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 19:21:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The udev rule file that fixes the issue. (194 bytes, patch)
2006-09-20 03:25 EDT, Shyam kumar Iyer
no flags Details | Diff
sysfs tree (114.33 KB, text/plain)
2006-10-16 06:15 EDT, Shyam kumar Iyer
no flags Details

  None (edit)
Description Shyam kumar Iyer 2006-09-20 03:23:22 EDT
Description of problem:
RHEL-5-beta2 installed on the PE800.which has an onboard IDE ATAPI tape device.
To access the tape device an st* or nst* had not been formed.Only on  modprobe
ide-scsi manually,st* and nst* are being enumerated for the tape device. 

Version-Release number of selected component (if applicable):
RHEL-5-beta-2

How reproducible:
Always

Steps to Reproduce:
1.Insert tape device to the tape drive.
2.Install RHEL5-beta2
3.Search for a dev node entry for the tape device which has not been created
since the ide-scsi module is not loaded 
  
Actual results:


Expected results:


Additional info:
Comment 1 Shyam kumar Iyer 2006-09-20 03:25:41 EDT
Created attachment 136710 [details]
The udev rule file that fixes the issue.

Udev rule file to be placed in the /etc/udev/rules.d/ directory.
Comment 2 Jeff Needle 2006-09-20 11:51:47 EDT
We don't have a RHEL5 beta2 yet.  Setting version to rhel5-beta1.
Comment 4 Harald Hoyer 2006-09-25 07:44:41 EDT
Would this work?
KERNEL=="*ht[0-9]*", BUS=="ide", SYSFS{device/media}=="tape", \
        SYMLINK+="tape tape-%k", MODE="0660"
Comment 5 Shyam kumar Iyer 2006-09-25 08:47:38 EDT
Do you want to put this in any specific rule file or I can test with the rule 
file "86-tape.rules" file that I have in the attachment? 
Comment 6 Harald Hoyer 2006-09-25 10:13:51 EDT
86-tape.rules should be fine..
Comment 7 Shyam kumar Iyer 2006-09-25 11:17:20 EDT
This does not work. Looks like the rule is not matched.
Comment 8 Harald Hoyer 2006-10-12 04:46:09 EDT
ide-scsi should not be loaded, because it converts all ide devices in SCSI
devices, like CDROMs, which is normally discouraged.

Normally ide device nodes should be created.

 37 char        IDE tape
                  0 = /dev/ht0          First IDE tape
                  1 = /dev/ht1          Second IDE tape
                    ...
                128 = /dev/nht0         First IDE tape, no rewind-on-close
                129 = /dev/nht1         Second IDE tape, no rewind-on-close
Comment 9 Shyam kumar Iyer 2006-10-13 09:33:41 EDT
The naming of the rule file is such that ide-scsi module will be loaded after 
the modules for the CDROM devices are loaded. So the CDROMs will not become 
SCSI devices.
Comment 10 Harald Hoyer 2006-10-13 10:17:46 EDT
modules are loaded in a rather random order. depends on the /sys fs layout, in
which order the uevents are triggered by udevstart.
Comment 11 Harald Hoyer 2006-10-13 10:20:19 EDT
could you please attach 
# tree /sys
Comment 12 Shyam kumar Iyer 2006-10-16 06:15:45 EDT
Created attachment 138564 [details]
sysfs tree
Comment 13 Harald Hoyer 2006-10-16 07:55:37 EDT
Question for the kernel: Are IDE tapes supported?
Comment 14 Chip Coldwell 2006-10-17 11:20:35 EDT
Date: Mon, 16 Oct 2006 15:44:40 -0400 (EDT)
From: Chip Coldwell <coldwell@redhat.com>
To: Alan Cox <alan@redhat.com>
Subject: ide-scsi/IDE tape


Hi Alan,

This is apropos BZ#207248.  The question is whether or not RHEL-5
should automatically load ide-scsi for IDE tape drives.  Tom Coughlan
said you had given the subject a lot of thought, but he didn't
remember your conclusion.  I haven't had much luck searching in
bugzilla.

Thanks,

Chip
Comment 15 Chip Coldwell 2006-10-17 11:21:00 EDT
Date: Mon, 16 Oct 2006 18:46:51 -0400
From: Alan Cox <alan@redhat.com>
To: Chip Coldwell <coldwell@redhat.com>
Cc: Alan Cox <alan@redhat.com>
Subject: Re: ide-scsi/IDE tape

On Mon, Oct 16, 2006 at 03:44:40PM -0400, Chip Coldwell wrote:
> This is apropos BZ#207248.  The question is whether or not RHEL-5
> should automatically load ide-scsi for IDE tape drives.  Tom Coughlan
> said you had given the subject a lot of thought, but he didn't
> remember your conclusion.  I haven't had much luck searching in
> bugzilla.

For all but old old tape drivers ide-scsi is preferred. Some ancient drives
need ide-tape, some newer drives need ide-scsi.
Comment 16 Chip Coldwell 2006-10-17 11:21:33 EDT
Date: Tue, 17 Oct 2006 10:16:23 -0400 (EDT)
From: Chip Coldwell <coldwell@redhat.com>
To: Alan Cox <alan@redhat.com>
Subject: Re: ide-scsi/IDE tape

On Mon, 16 Oct 2006, Alan Cox wrote:

> On Mon, Oct 16, 2006 at 03:44:40PM -0400, Chip Coldwell wrote:
> > This is apropos BZ#207248.  The question is whether or not RHEL-5
> > should automatically load ide-scsi for IDE tape drives.  Tom Coughlan
> > said you had given the subject a lot of thought, but he didn't
> > remember your conclusion.  I haven't had much luck searching in
> > bugzilla.
> 
> For all but old old tape drivers ide-scsi is preferred. Some ancient
> drives
> need ide-tape, some newer drives need ide-scsi.

How do you feel about automatically loading ide-scsi when an IDE tape
drive is detected?  It has the side effect of changing the nature of
any attached IDE CD-ROMs, etc.

Chip
Comment 17 Chip Coldwell 2006-10-17 11:22:14 EDT
Date: Tue, 17 Oct 2006 10:34:20 -0400
From: Alan Cox <alan@redhat.com>
To: Chip Coldwell <coldwell@redhat.com>
Cc: Alan Cox <alan@redhat.com>
Subject: Re: ide-scsi/IDE tape

On Tue, Oct 17, 2006 at 10:16:23AM -0400, Chip Coldwell wrote:
> How do you feel about automatically loading ide-scsi when an IDE tape
> drive is detected?  It has the side effect of changing the nature of
> any attached IDE CD-ROMs, etc.

That depends on what you load and set. If you add a fake dependancy for
ide-scsi on ide-cd it'll load the CD driver first in all those cases.

Not sure what happens if we then add a pcmcia cd drive. I think CD will get
it.

It's also possible (in fact quite simple) to push a small change so that
you can have a "no_cd" option for ide-scsi. In fact that seems to be so
trivial I'll kick it upstream anyway.
Comment 18 Chip Coldwell 2006-10-17 11:23:39 EDT
(In reply to comment #13)
> Question for the kernel: Are IDE tapes supported?

Judging from the correspondence with Alan Cox above, I would say that the
answer is "yes", and he provides some ideas for how to proceed without
interfering with ATAPI CD-ROMs.

Bouncing the bug back to you, Harald.

Chip
Comment 19 Harald Hoyer 2006-10-18 03:24:06 EDT
> It's also possible (in fact quite simple) to push a small change so that
> you can have a "no_cd" option for ide-scsi. In fact that seems to be so
> trivial I'll kick it upstream anyway.

Until we have this option, I would not recommend this.
Comment 20 RHEL Product and Program Management 2006-10-26 16:03:09 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 21 RHEL Product and Program Management 2006-11-04 06:20:49 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 
Comment 22 Samuel Benjamin 2006-11-15 16:48:34 EST
Dell is going to add justification to REOPEN this bug.
Comment 23 Shyam kumar Iyer 2006-11-22 10:08:33 EST
Dell is still shipping a lot of PowerEdge systems with ide-tape devices.
Autoloading ide-scsi module is required for all such sytems. Since we have not
reproduced a scenario where the ide-scsi module is loading the cdrom devices and
do not see the udev rule affecting any of our systems one of the following
things will work for us. 
1) Incorporate the rule.
2) Come up with a new rule that doesn't break the scenario as articulated in
comment#8.
3) Implement the kernel fix as articulated in comment#17.

PS: Other vendors like Novell have already incorporated the udev rule that we
are proposing.
Comment 24 Amit Bhutani 2006-11-28 18:57:26 EST
> You may appeal this decision by reopening this request.
We can't because of our mini-subset bugzilla powers. Can someone from RH, please
reopen ?
Comment 25 Larry Troan 2006-11-28 22:57:42 EST
Per comment #24, REOPENING AT DELL'S REQUEST. WE NEED A SOLUTION FOR GA.
Comment 26 Harald Hoyer 2006-11-29 05:33:21 EST
Alan, could we integrate the patch mentioned in comment #17 ? 
And btw, how are IDE tapes accessed without ide-scsi? Isn't there an ide-tape
module, and can the devices created by those be used for the tape utilities?
Comment 27 Alan Cox 2006-11-29 07:15:05 EST
I'll submit the upstream diff see what people think
Comment 28 Alan Cox 2006-11-29 09:24:17 EST
Re: #26 - ide-tape has some additional support for certain old old tapes but
does not support a lot of modern stuff. ide-tape shouldn't be needed by current
systems, just ide-scsi, osst, st
Comment 30 Alan Cox 2006-12-06 17:32:53 EST
Patch for idescsi to skip CD devices as an option is now in -mm, but that won't
deal with the fact we need to load ide-scsi for tapes. Someone needs to fix that
in user space (udev ?)

Can push the ide-scsi diff tomorrow if desired.
Comment 31 Amit Bhutani 2006-12-07 01:28:22 EST
> Can push the ide-scsi diff tomorrow if desired.
Speaking for Dell, that would be great and *much* desired ;-) Thanks for all
your work on this so far!! Now, if we can only get the udev folks on board ;-) 
Comment 34 Amit Bhutani 2006-12-13 09:31:34 EST
Can we please change status of issue to more accurately reflect POST if the
patch has been posted for review internally ?
Comment 35 Don Zickus 2006-12-13 20:09:27 EST
in 2.6.18-1.2876.el5
Comment 36 Shyam kumar Iyer 2006-12-21 08:27:26 EST
Checked with 2.6.8-1.2910.el5 in conjunction with udev-095-14.3.el5 since udev-
095-14.4.el5 was not available. Edited the typo specified in BZ219113 and the 
issue gets resolved.
Comment 37 RHEL Product and Program Management 2006-12-22 19:21:33 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.