Bug 207263 - workspace switching is strange
workspace switching is strange
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
: Reopened
: 207128 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 05:47 EDT by Bill Nottingham
Modified: 2014-03-16 23:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 19:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-09-20 05:47:24 EDT
With compiz-0.0.13-0.27.20060817git.fc6, workspace switching has become strange.

Examples:
1. Workspaces get lost - I can cycle through workspaces seeing some two or three
times before one pops up.
2. When moving windows between workspaces, sometimes the window jumps to the top
or the bottom of the screen.
Comment 1 Bill Nottingham 2006-09-20 05:50:38 EDT
Upon further playing... it may not be that the workspaces are 'lost'; just that
the windows on them disappear.
Comment 2 Søren Sandmann Pedersen 2006-09-20 15:54:15 EDT
Are you using the cube plugin? Ie., do you have "Workspaces on a cube" checked
in the desktop effects dialog?
Comment 3 Bill Nottingham 2006-09-20 16:43:49 EDT
Yes.
Comment 4 Søren Sandmann Pedersen 2006-09-22 18:06:58 EDT
My current understanding of what's going on:

The code in moveScreenViewports() that tries to keep windows on the virtual
screen and move them around to maintain the continuousness of the cube, is
triggering in the Y direction for windows that are close to the edges of the
screen. It is also triggering in the X direction, but usually people have more
than one column, so the windows stay on screen.

The reason the code triggers is that compiz windows have an extra 'output' area
containing the shadow etc.

I'm not yet sure how to fix this.
Comment 5 Søren Sandmann Pedersen 2006-09-25 19:03:05 EDT
Fixed in the build that is currently underway (-28).
Comment 6 Søren Sandmann Pedersen 2006-09-25 19:21:42 EDT
which failed, but fortunately a new identical build finished successfully.
Comment 7 Thorsten Leemhuis 2006-09-26 07:59:58 EDT
*** Bug 207128 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.