This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 207280 - Anaconda lockup on HTTP/FTP install on Toshiba Laptop
Anaconda lockup on HTTP/FTP install on Toshiba Laptop
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 09:24 EDT by Jay Lee
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-12 16:24:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci output from successful rhel5b1 nfs based install (1.73 KB, text/plain)
2006-09-20 10:27 EDT, Jay Lee
no flags Details
lspci -vv output from successful nfs based rhel5b1 install (12.69 KB, text/plain)
2006-09-20 10:29 EDT, Jay Lee
no flags Details
lsmod output from successful nfs based install of rhel5b1 (2.96 KB, text/plain)
2006-09-20 10:30 EDT, Jay Lee
no flags Details
anaconda cfg file from successful rhel5b1 nfs based install (1.15 KB, application/octet-stream)
2006-09-20 10:31 EDT, Jay Lee
no flags Details
install.log from successful nfs based rhel5b1 install (35.74 KB, application/octet-stream)
2006-09-20 10:32 EDT, Jay Lee
no flags Details
install.log.syslog from successful nfs based install of rhel5b1 (5.51 KB, application/octet-stream)
2006-09-20 10:33 EDT, Jay Lee
no flags Details

  None (edit)
Description Jay Lee 2006-09-20 09:24:15 EDT
Description of problem:
  -RHEL5b1 install started via PXELINUX
  -Toshiba Satellite M55-S135 Laptop
  -Marvell NIC properly detected and given IP Address (sky2 driver used)
  -When using HTTP or FTP install, after entering server info, system locks up
just before "Retreiving stage2" message, cannot switch VTs to see error messages
  -HTTP/FTP Server logs do not indicate any connection from client machine
  -When using NFS to install, process continues w/o error
  -FTP/HTTP installs to another machine proceeds w/o error.
  -FTP/HTTP/NFS Server is a RHEL3u8 box

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.  PXEBOOT Satellite Laptop
2.  Attempt FTP or HTTP based install
3.  Complete lockup immediately after FTP/HTTP Server and Path are entered
  
Actual results:

Complete Lockup

Expected results:

Stage2 retreival begins

Additional info:

-RHEL4u4 and FC5 can do PXE+HTTP/FTP installs on this laptop w/o issue, older
versions did not have a sky2 or sk98lin driver that supported the laptops
particular revision of the Marvell chip.
-NFS based install did fail to autodetect Hard Drive, had to manually select
Intel PIIX controller kernel module in order for install to find HD.
-I realize I've not provided much debugging info but Anaconda freezes before I
can get any log information, is there a kernel boot option that will put
Anaconda into a verbose/debugging mode?
Comment 1 Jay Lee 2006-09-20 10:27:47 EDT
Created attachment 136737 [details]
lspci output from successful rhel5b1 nfs based install
Comment 2 Jay Lee 2006-09-20 10:29:13 EDT
Created attachment 136738 [details]
lspci -vv output from successful nfs based rhel5b1 install
Comment 3 Jay Lee 2006-09-20 10:30:24 EDT
Created attachment 136739 [details]
lsmod output from successful nfs based install of rhel5b1
Comment 4 Jay Lee 2006-09-20 10:31:27 EDT
Created attachment 136740 [details]
anaconda cfg file from successful rhel5b1 nfs based install
Comment 5 Jay Lee 2006-09-20 10:32:19 EDT
Created attachment 136741 [details]
install.log from successful nfs based rhel5b1 install
Comment 6 Jay Lee 2006-09-20 10:33:28 EDT
Created attachment 136742 [details]
install.log.syslog from successful nfs based install of rhel5b1
Comment 7 Jeremy Katz 2006-09-20 13:16:52 EDT
Can you try switching VTs quick right before it starts retrieving stage2?  Since
this is a laptop, I'm guessing there aren't keyboard LEDs to be blinking...
Comment 8 Jay Lee 2006-09-20 13:39:03 EDT
The lockup is to immediate (tried a few times).  Sorry no standard keyboard
LEDs.  Additionally, we are a ipv4 network currently, I tried with and without
IPv6 support enabled but it did not make a difference, the lockup occurs on both.
Comment 9 Jeremy Katz 2006-09-20 13:51:06 EDT
Can you boot with 'linux ip=dhcp method=nfs:server:/path/to/repo lang=en
keymap=us' and then you should be able to switch ttys once the installer starts
coming up and not have to answer questions
Comment 10 Jay Lee 2006-09-20 14:45:25 EDT
Ahoy! (oops wrong day)

Anaconda supports a telnet interface from text mode, all I have to do is add
"telnet" to the boot command line.  With that, I can control Anaconda across the
network and switch the physical console to VT 3 or 4.

the only message printed out on VT3 after I hit enter (having entered the ftp
server info) is:

INFO   : trying to mount CD device hdc

It seems Anaconda tries to find stage2 on a CD before trying to retrieve it
across the network (doesn't seem to logical to me since we booted from the
network).  Accessing the cdrom drive is causing the lockup.

I have now found that FTP/HTTP installs will complete if I use a boot command
line of:

linux hdc=none

The cdrom is in good working condition AFAIK, I've installed other operating
systems with it recently (OK, Vista RC1 if you must know).  Initial testing of
the cdrom drive (copying a few files of different data CDs) has not resulted in
any errors.

Comment 11 Jay Lee 2006-09-20 15:04:53 EDT
Additionally, booting with "linux noprobe", manually specifying the sky2 network
driver and ata_piix controller and then continuing with a FTP install does not
result in the lockup.  It would seem that the lockup is being caused by Anaconda
autoloading the ahci driver and then attempting to access the cdrom drive.  For
whatever reason, NFS based installations do not search for stage2 on a cd like
HTTP/FTP installs do so the lockup does not occur.

The ahci driver does not seem to be appropriate for this system (the hard drive
can't be found until ata_piix is loaded either).
Comment 13 RHEL Product and Program Management 2006-10-26 16:00:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 14 Peter Martuccelli 2006-12-01 10:19:40 EST
This looks like an anaconda issue.  
Comment 15 Daniel Riek 2007-01-03 21:49:06 EST
Does the problem still exist with Beta2?
Comment 16 Jay Lee 2007-01-05 15:33:56 EST
After further testing I found other odd issues with the CD/DVD drive.  I have
replaced the drive and do not get install lockups any longer with Beta 2.

I had tested for cdrom drive errors before but couldn't reproduce them when
reading a full CD/DVD in Linux (MD5 checks would pass).  The only reproducible
errors were during Anaconda install (and only with RHEL5 beta oddly enough).

I am fairly sure this was a hardware error so this issue can be resolved.

Thanks,

Jay Lee

Note You need to log in before you can comment on or make changes to this bug.