Bug 207327 - system-config-soundcard does nothing
system-config-soundcard does nothing
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 13:59 EDT by Garrett Mitchener
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 15:09:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Garrett Mitchener 2006-09-20 13:59:15 EDT
Version-Release number of selected component (if applicable):
system-config-soundcard-2.0.3-2.fc6

Steps to Reproduce:

run system-config-soundcard.  It exits without doing anything that I can tell.

This is on a dell precision 690 workstation.  When I run lspci I get the
following info about my sound card:

0c:02.0 Multimedia audio controller: Creative Labs SB X-Fi

and from lspci -v:

0c:02.0 Multimedia audio controller: Creative Labs SB X-Fi
        Subsystem: Creative Labs X-Fi XtremeMusic
        Flags: bus master, medium devsel, latency 64, IRQ 5
        I/O ports at bce0 [size=32]
        Memory at df400000 (64-bit, non-prefetchable) [size=2M]
        Memory at d8000000 (64-bit, non-prefetchable) [size=64M]
        Capabilities: [40] Power Management version 2
        Capabilities: [50] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-

My sound card doesn't seem to be working at all.
Comment 1 Martin Stransky 2006-09-20 15:07:41 EDT
could you please attach /root/scs*.log? (if you have it)
Comment 2 Martin Stransky 2006-09-20 15:09:54 EDT
I'm afraid your card isn't supported under linux. see this page:

http://www.alsa-project.org/alsa-doc/index.php?vendor=vendor-Creative_Labs#matrix
Comment 3 Garrett Mitchener 2006-09-21 15:23:07 EDT
The problem seems to be that it tries to open a file that doesn't exist.  I
assume it doesn't exist because my card isn't supported, but it would be nice
for the config program to say that rather than crashing.

[root@grograman ~]# cat /root/scsrun.log 
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46,
in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 95, in __init__
    self.soundcardBackend = soundcardBackend.soundcardBackend()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 397, in
__init__
    self.detectCards()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 414, in
detectCards
    self.probeCards(DETECTION_PROC))
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 441, in
probeCards
    default_device, card_list, card_max)
  File "/usr/share/system-config-soundcard/soundcardBackendProc.py", line 69, in
probeCards
    fd = open('/proc/asound/cards', 'r')
IOError: [Errno 2] No such file or directory: '/proc/asound/cards'
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46,
in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 95, in __init__
    self.soundcardBackend = soundcardBackend.soundcardBackend()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 397, in
__init__
    self.detectCards()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 414, in
detectCards
    self.probeCards(DETECTION_PROC))
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 441, in
probeCards
    default_device, card_list, card_max)
  File "/usr/share/system-config-soundcard/soundcardBackendProc.py", line 69, in
probeCards
    fd = open('/proc/asound/cards', 'r')
IOError: [Errno 2] No such file or directory: '/proc/asound/cards'
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46,
in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 95, in __init__
    self.soundcardBackend = soundcardBackend.soundcardBackend()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 397, in
__init__
    self.detectCards()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 414, in
detectCards
    self.probeCards(DETECTION_PROC))
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 441, in
probeCards
    default_device, card_list, card_max)
  File "/usr/share/system-config-soundcard/soundcardBackendProc.py", line 69, in
probeCards
    fd = open('/proc/asound/cards', 'r')
IOError: [Errno 2] No such file or directory: '/proc/asound/cards'
Comment 4 Martin Stransky 2006-09-22 06:13:11 EDT
You're right, there should be some kind of check...

Note You need to log in before you can comment on or make changes to this bug.