Bug 207377 - piranha-gui: initscript stop action does not work
piranha-gui: initscript stop action does not work
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: piranha (Show other bugs)
4
All Linux
medium Severity low
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 17:16 EDT by Tomas Hoger
Modified: 2009-04-16 16:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0794
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-25 15:08:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2006-09-20 17:16:06 EDT
Description of problem:
Action stop for piranha-gui init.d script does not work as expected.

Version-Release number of selected component (if applicable):
0.8.2

How reproducible:

Steps to Reproduce:
1./etc/init.d/piranha-gui start
2./etc/init.d/piranha-gui stop
3.ps -ef | grep piranha_gui
  

Additional info:
Managed to track issue down to source of problem.  stop function calls killproc
function from /etc/init.d/functions.  Somewhere in the body of killproc, you can
find:

kill $killlevel $pid >/dev/null 2>&1

This fails with error:

kill: SIGTERM: invalid signal specification

Issue is caused by bash(3), which no longer accepts SIG<signal name> as argument
when started as sh.  Only <signal name> without SIG prefix is ok.

Changing sh in sha-bang line of init script to bash or calling killproc as:

killproc piranha_gui -TERM

should do the trick.
Comment 1 Stanko Kupcevic 2006-11-15 17:25:20 EST
Fixed in HEAD and RHEL5
Comment 6 errata-xmlrpc 2008-07-25 15:08:44 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0794.html

Note You need to log in before you can comment on or make changes to this bug.