Bug 207465 - sane-backends-1.0.18-2.fc5 (still) conflicts with sane-backends-1.0.17-5.fc5.9
sane-backends-1.0.18-2.fc5 (still) conflicts with sane-backends-1.0.17-5.fc5.9
Status: CLOSED DUPLICATE of bug 205881
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 05:23 EDT by Thomas Antony
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 05:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 205881 None None None Never

  None (edit)
Description Thomas Antony 2006-09-21 05:23:13 EDT
Description of problem:

The last update of sane-backends-1.0.18-2.fc5 conflicts with the installed
sane-backends-1.0.17-5.fc5.9
I knew there are already filed 2 bugs with this problem where one was a
duplicate and the other was closed as not a bug, but i think it is a bug an so i
reopen it.
As already mentioned in the other bug it seems to be a x86_64 problem only,
because Anaconda installed the i386 and x86_64 version and now conflicts with
the updated version. Both version are also in the FC Core repo. I think this bug
even concerns everyone who has installed FC5 x86_64 and sane.
I can't remove sane-backends-1.0.17-5.fc5.9.i386 because wine from the extras
repo depend on it.
It looks like yum doesn't recognizes that it must update the i386 version also,
because it only download the x86_64 vserion and try to update it.



Version-Release number of selected component (if applicable):
sane-backends-1.0.17-5.fc5.9

How reproducible:
Update FC5

Steps to Reproduce:
1. Install FC5 with gnome and include sane.
2. After a frsh install upgrade FC5.
  
Actual results:
sane-backends break yum update

Expected results:
sane-backends should get updated
Comment 1 Kapoios Kanenas 2006-09-21 06:32:55 EDT
The problem is that sane-backends-1.0.18-2.fc5.i386.rpm for FC5 x86_64 doesn't
contain any i386 libraries just sane executables, config files and man pages
like it's x86_64 counterpart.

Suggestion :
remove sane-backends-1.0.18-2.fc5.i386.rpm from x86_64 repo and add 
sane-backends-libs-1.0.18-2.fc5.i386.rpm

In short sane-backends-1.0.18-2.fc5 i386 conflicts with
sane-backends-1.0.18-2.fc5 x86_64

rpmquery -lp sane-backends-1.0.18-2.fc5.i386.rpm 
/etc/sane.d
/etc/sane.d/abaton.conf
/etc/sane.d/agfafocus.conf
/etc/sane.d/apple.conf
/etc/sane.d/artec.conf
/etc/sane.d/artec_eplus48u.conf
/etc/sane.d/avision.conf
/etc/sane.d/bh.conf
/etc/sane.d/canon.conf
/etc/sane.d/canon630u.conf
/etc/sane.d/canon_pp.conf
/etc/sane.d/coolscan.conf
/etc/sane.d/coolscan2.conf
/etc/sane.d/dc210.conf
/etc/sane.d/dc240.conf
/etc/sane.d/dc25.conf
/etc/sane.d/dll.conf
/etc/sane.d/dmc.conf
/etc/sane.d/epson.conf
/etc/sane.d/fujitsu.conf
/etc/sane.d/genesys.conf
/etc/sane.d/gphoto2.conf
/etc/sane.d/gt68xx.conf
/etc/sane.d/hp.conf
/etc/sane.d/hp4200.conf
/etc/sane.d/hp5400.conf
/etc/sane.d/hpsj5s.conf
/etc/sane.d/ibm.conf
/etc/sane.d/leo.conf
/etc/sane.d/lexmark.conf
/etc/sane.d/ma1509.conf
/etc/sane.d/matsushita.conf
/etc/sane.d/microtek.conf
/etc/sane.d/microtek2.conf
/etc/sane.d/mustek.conf
/etc/sane.d/mustek_pp.conf
/etc/sane.d/mustek_usb.conf
/etc/sane.d/nec.conf
/etc/sane.d/net.conf
/etc/sane.d/pie.conf
/etc/sane.d/plustek.conf
/etc/sane.d/plustek_pp.conf
/etc/sane.d/qcam.conf
/etc/sane.d/ricoh.conf
/etc/sane.d/s9036.conf
/etc/sane.d/saned.conf
/etc/sane.d/sceptre.conf
/etc/sane.d/sharp.conf
/etc/sane.d/sm3840.conf
/etc/sane.d/snapscan.conf
/etc/sane.d/sp15c.conf
/etc/sane.d/st400.conf
/etc/sane.d/stv680.conf
/etc/sane.d/tamarack.conf
/etc/sane.d/teco1.conf
/etc/sane.d/teco2.conf
/etc/sane.d/teco3.conf
/etc/sane.d/test.conf
/etc/sane.d/u12.conf
/etc/sane.d/umax.conf
/etc/sane.d/umax1220u.conf
/etc/sane.d/umax_pp.conf
/etc/sane.d/v4l.conf
/etc/udev/rules.d/60-libsane.rules
/usr/bin/sane-find-scanner
/usr/bin/scanimage
/usr/sbin/saned
/usr/share/doc/sane-backends-1.0.18
/usr/share/doc/sane-backends-1.0.18/AUTHORS
/usr/share/doc/sane-backends-1.0.18/COPYING
/usr/share/doc/sane-backends-1.0.18/ChangeLog
/usr/share/doc/sane-backends-1.0.18/LICENSE
/usr/share/doc/sane-backends-1.0.18/NEWS
/usr/share/doc/sane-backends-1.0.18/PROBLEMS
/usr/share/doc/sane-backends-1.0.18/PROJECTS
/usr/share/doc/sane-backends-1.0.18/README
/usr/share/doc/sane-backends-1.0.18/README.aix
/usr/share/doc/sane-backends-1.0.18/README.beos
/usr/share/doc/sane-backends-1.0.18/README.darwin
/usr/share/doc/sane-backends-1.0.18/README.djpeg
/usr/share/doc/sane-backends-1.0.18/README.freebsd
/usr/share/doc/sane-backends-1.0.18/README.hp-ux
/usr/share/doc/sane-backends-1.0.18/README.linux
/usr/share/doc/sane-backends-1.0.18/README.netbsd
/usr/share/doc/sane-backends-1.0.18/README.openbsd
/usr/share/doc/sane-backends-1.0.18/README.os2
/usr/share/doc/sane-backends-1.0.18/README.solaris
/usr/share/doc/sane-backends-1.0.18/README.unixware2
/usr/share/doc/sane-backends-1.0.18/README.unixware7
/usr/share/doc/sane-backends-1.0.18/README.windows
/usr/share/doc/sane-backends-1.0.18/README.zeta
/usr/share/doc/sane-backends-1.0.18/backend-writing.txt
/usr/share/doc/sane-backends-1.0.18/canon
/usr/share/doc/sane-backends-1.0.18/canon/canon.changes
/usr/share/doc/sane-backends-1.0.18/canon/canon.install2700F.txt
/usr/share/doc/sane-backends-1.0.18/gt68xx
/usr/share/doc/sane-backends-1.0.18/gt68xx/gt68xx.CHANGES
/usr/share/doc/sane-backends-1.0.18/gt68xx/gt68xx.TODO
/usr/share/doc/sane-backends-1.0.18/leo
/usr/share/doc/sane-backends-1.0.18/leo/leo.txt
/usr/share/doc/sane-backends-1.0.18/matsushita
/usr/share/doc/sane-backends-1.0.18/matsushita/matsushita.txt
/usr/share/doc/sane-backends-1.0.18/mustek
/usr/share/doc/sane-backends-1.0.18/mustek/mustek.CHANGES
/usr/share/doc/sane-backends-1.0.18/mustek_usb
/usr/share/doc/sane-backends-1.0.18/mustek_usb/mustek_usb.CHANGES
/usr/share/doc/sane-backends-1.0.18/mustek_usb/mustek_usb.TODO
/usr/share/doc/sane-backends-1.0.18/mustek_usb2
/usr/share/doc/sane-backends-1.0.18/mustek_usb2/mustek_usb2.CHANGES
/usr/share/doc/sane-backends-1.0.18/mustek_usb2/mustek_usb2.TODO
/usr/share/doc/sane-backends-1.0.18/niash
/usr/share/doc/sane-backends-1.0.18/niash/niash.TODO
/usr/share/doc/sane-backends-1.0.18/plustek
/usr/share/doc/sane-backends-1.0.18/plustek/FAQ
/usr/share/doc/sane-backends-1.0.18/plustek/MakeModule.sh
/usr/share/doc/sane-backends-1.0.18/plustek/Makefile.kernel24
/usr/share/doc/sane-backends-1.0.18/plustek/Makefile.kernel26
/usr/share/doc/sane-backends-1.0.18/plustek/Plustek-PARPORT-TODO.txt
/usr/share/doc/sane-backends-1.0.18/plustek/Plustek-PARPORT.changes
/usr/share/doc/sane-backends-1.0.18/plustek/Plustek-PARPORT.txt
/usr/share/doc/sane-backends-1.0.18/plustek/Plustek-USB-TODO.txt
/usr/share/doc/sane-backends-1.0.18/plustek/Plustek-USB.changes
/usr/share/doc/sane-backends-1.0.18/plustek/Plustek-USB.txt
/usr/share/doc/sane-backends-1.0.18/sceptre
/usr/share/doc/sane-backends-1.0.18/sceptre/s1200.txt
/usr/share/doc/sane-backends-1.0.18/teco
/usr/share/doc/sane-backends-1.0.18/teco/teco1.txt
/usr/share/doc/sane-backends-1.0.18/teco/teco2.txt
/usr/share/doc/sane-backends-1.0.18/teco/teco3.txt
/usr/share/doc/sane-backends-1.0.18/u12
/usr/share/doc/sane-backends-1.0.18/u12/U12.changes
/usr/share/doc/sane-backends-1.0.18/u12/U12.todo
/usr/share/doc/sane-backends-1.0.18/umax
/usr/share/doc/sane-backends-1.0.18/umax/negative-types.txt
/usr/share/doc/sane-backends-1.0.18/umax/sane-logo.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-advanced-options-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-advanced.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-astra-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-config-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-histogram.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-mirage-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-not-listed-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-others-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-parport-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-powerlook-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-scanner-clones-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-speed-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-standard-options-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-standard.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-text.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-text2.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-text4.jpg
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-uc-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax-vista-doc.html
/usr/share/doc/sane-backends-1.0.18/umax/sane-umax.jpg
/usr/share/doc/sane-backends-1.0.18/umax/umax.BUGS
/usr/share/doc/sane-backends-1.0.18/umax/umax.CHANGES
/usr/share/doc/sane-backends-1.0.18/umax/umax.FAQ
/usr/share/doc/sane-backends-1.0.18/umax/umax.TODO
/usr/share/locale/bg/LC_MESSAGES/sane-backends.mo
/usr/share/locale/cs/LC_MESSAGES/sane-backends.mo
/usr/share/locale/da/LC_MESSAGES/sane-backends.mo
/usr/share/locale/de/LC_MESSAGES/sane-backends.mo
/usr/share/locale/es/LC_MESSAGES/sane-backends.mo
/usr/share/locale/fi/LC_MESSAGES/sane-backends.mo
/usr/share/locale/fr/LC_MESSAGES/sane-backends.mo
/usr/share/locale/it/LC_MESSAGES/sane-backends.mo
/usr/share/locale/nl/LC_MESSAGES/sane-backends.mo
/usr/share/locale/no/LC_MESSAGES/sane-backends.mo
/usr/share/locale/pl/LC_MESSAGES/sane-backends.mo
/usr/share/locale/pt/LC_MESSAGES/sane-backends.mo
/usr/share/locale/ru/LC_MESSAGES/sane-backends.mo
/usr/share/locale/sv/LC_MESSAGES/sane-backends.mo
/usr/share/man/man1/sane-config.1.gz
/usr/share/man/man1/sane-find-scanner.1.gz
/usr/share/man/man1/scanimage.1.gz
/usr/share/man/man5/sane-abaton.5.gz
/usr/share/man/man5/sane-agfafocus.5.gz
/usr/share/man/man5/sane-apple.5.gz
/usr/share/man/man5/sane-artec.5.gz
/usr/share/man/man5/sane-artec_eplus48u.5.gz
/usr/share/man/man5/sane-as6e.5.gz
/usr/share/man/man5/sane-avision.5.gz
/usr/share/man/man5/sane-bh.5.gz
/usr/share/man/man5/sane-canon.5.gz
/usr/share/man/man5/sane-canon630u.5.gz
/usr/share/man/man5/sane-canon_pp.5.gz
/usr/share/man/man5/sane-coolscan.5.gz
/usr/share/man/man5/sane-coolscan2.5.gz
/usr/share/man/man5/sane-dc210.5.gz
/usr/share/man/man5/sane-dc240.5.gz
/usr/share/man/man5/sane-dc25.5.gz
/usr/share/man/man5/sane-dll.5.gz
/usr/share/man/man5/sane-dmc.5.gz
/usr/share/man/man5/sane-epson.5.gz
/usr/share/man/man5/sane-fujitsu.5.gz
/usr/share/man/man5/sane-genesys.5.gz
/usr/share/man/man5/sane-gphoto2.5.gz
/usr/share/man/man5/sane-gt68xx.5.gz
/usr/share/man/man5/sane-hp.5.gz
/usr/share/man/man5/sane-hp3500.5.gz
/usr/share/man/man5/sane-hp4200.5.gz
/usr/share/man/man5/sane-hp5400.5.gz
/usr/share/man/man5/sane-hpsj5s.5.gz
/usr/share/man/man5/sane-ibm.5.gz
/usr/share/man/man5/sane-leo.5.gz
/usr/share/man/man5/sane-lexmark.5.gz
/usr/share/man/man5/sane-ma1509.5.gz
/usr/share/man/man5/sane-matsushita.5.gz
/usr/share/man/man5/sane-microtek.5.gz
/usr/share/man/man5/sane-microtek2.5.gz
/usr/share/man/man5/sane-mustek.5.gz
/usr/share/man/man5/sane-mustek_pp.5.gz
/usr/share/man/man5/sane-mustek_usb.5.gz
/usr/share/man/man5/sane-mustek_usb2.5.gz
/usr/share/man/man5/sane-nec.5.gz
/usr/share/man/man5/sane-net.5.gz
/usr/share/man/man5/sane-niash.5.gz
/usr/share/man/man5/sane-pie.5.gz
/usr/share/man/man5/sane-pint.5.gz
/usr/share/man/man5/sane-pixma.5.gz
/usr/share/man/man5/sane-plustek.5.gz
/usr/share/man/man5/sane-plustek_pp.5.gz
/usr/share/man/man5/sane-pnm.5.gz
/usr/share/man/man5/sane-qcam.5.gz
/usr/share/man/man5/sane-ricoh.5.gz
/usr/share/man/man5/sane-s9036.5.gz
/usr/share/man/man5/sane-sceptre.5.gz
/usr/share/man/man5/sane-scsi.5.gz
/usr/share/man/man5/sane-sharp.5.gz
/usr/share/man/man5/sane-sm3600.5.gz
/usr/share/man/man5/sane-sm3840.5.gz
/usr/share/man/man5/sane-snapscan.5.gz
/usr/share/man/man5/sane-sp15c.5.gz
/usr/share/man/man5/sane-st400.5.gz
/usr/share/man/man5/sane-stv680.5.gz
/usr/share/man/man5/sane-tamarack.5.gz
/usr/share/man/man5/sane-teco1.5.gz
/usr/share/man/man5/sane-teco2.5.gz
/usr/share/man/man5/sane-teco3.5.gz
/usr/share/man/man5/sane-test.5.gz
/usr/share/man/man5/sane-u12.5.gz
/usr/share/man/man5/sane-umax.5.gz
/usr/share/man/man5/sane-umax1220u.5.gz
/usr/share/man/man5/sane-umax_pp.5.gz
/usr/share/man/man5/sane-usb.5.gz
/usr/share/man/man5/sane-v4l.5.gz
/usr/share/man/man7/sane.7.gz
/usr/share/man/man8/saned.8.gz
/usr/share/pixmaps/sane.png



Comment 2 Kapoios Kanenas 2006-09-21 08:57:59 EDT
Workaround :

1. rpm -e --nodeps sane-backends.i386

2. yum update (it should update x86_64 sane packages).

3. download sane-backends-libs-1.0.18-2.fc5.i386.rpm from FC5 i386 updates.

4. rpm -Uvh sane-backends-libs-1.0.18-2.fc5.i386.rpm

it worked for me.
Comment 3 Tom Horsley 2006-09-21 10:12:12 EDT
I'm seeing the same thing for the last few days. Here is some of the info
I see in yumex when I try to update:

Two days now, yum has wanted to update both the x86_64 and i386
version of sane-backends (1.0.18-2.fc5), but only update the
x86_64 version of sane-backends-libs (1.0.18-2.fc5). The summary
I get from the yumex window is very strange when I try to
update, it says:

Installing

   sane-backends-libs x86_64 1.0.18-2.fc5
      replacing sane-backends.i386 1.0.17-5.fc5.9

Updating for dependencies

   sane-backends x86_64 1.0.18-2.fc5

So its installing the x86_64 libs to replace the i386 libs? I
thought multi-arch libs were supposed to co-exist?

In any case I wind up with an endless transaction error (which I
will truncate here):

Transaction Check Error:
  file /etc/sane.d/artec_eplus48u.conf from install of
     sane-backends-1.0.18-2.fc5 conflicts with file from
     package sane-backends-1.0.17-5.fc5.9
  file /etc/sane.d/avision.conf from install of
     sane-backends-1.0.18-2.fc5 conflicts with file from
     package sane-backends-1.0.17-5.fc5.9
  ...
  file /usr/share/man/man1/sane-config.1.gz from install of
     sane-backends-1.0.18-2.fc5 conflicts with file from
     package sane-backends-1.0.17-5.fc5.9
  file /usr/share/man/man1/sane-find-scanner.1.gz from install of
     sane-backends-1.0.18-2.fc5 conflicts with file from
     package sane-backends-1.0.17-5.fc5.9
  ...

Why do I have both i386 and x86_64 sane libs installed? In this
case it actually makes sense - I have wine installed and the
wine-core stuff depends on the i386 sane stuff.

I'll give the work around in comment #2 a try and see what happens.
Comment 4 Tom Horsley 2006-09-21 10:19:17 EDT
I guess the workaround worked. I didn't get any complaints from anything
and no more strange errors in yumex.
Comment 5 Thomas Antony 2006-09-21 12:41:59 EDT
Why was the package renamed from sane-backends to sane-backends-libs anyway?
Comment 6 Nils Philippsen 2006-09-22 05:06:52 EDT
I'll close this as duplicate of the original bug which I will reopen to provide
an explanation in it.

*** This bug has been marked as a duplicate of 205881 ***

Note You need to log in before you can comment on or make changes to this bug.