Bug 20751 - kernel problems
kernel problems
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alan Cox
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-13 07:37 EST by Taavi Tuisk
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-26 06:49:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Taavi Tuisk 2000-11-13 07:37:23 EST
Hi all

This helpcry is about compiling 2.4.0-testx kernels on 7.0 systems.
I'm using kgcc as noted, compiling goes fine... etc, but things are still
nasty.
Module depencies just don't work... it was ok with 6.2 systems.
What am i doing wrong, can you give me a clue? some documentation?
Or some cluestick beating, if im doing something very obivous things 
wrong.

depmod -a outputs:
[root@dwarf /root]# depmod -a
depmod: *** Unresolved symbols in
/lib/modules/2.4.0-test11/kernel/drivers/block/rd.o
depmod: *** Unresolved symbols in
/lib/modules/2.4.0-test11/kernel/drivers/char/drm/mga.o
depmod: *** Unresolved symbols in
/lib/modules/2.4.0-test11/kernel/drivers/ide/ide-floppy.o

and so on...

inserting a module:
[root@dwarf sound]# modprobe es1371
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol kmalloc
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol unregister_chrdev
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol register_chrdev
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol vfree
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol try_inc_mod_count
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol sys_close
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol request_module
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol kfree
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol sprintf
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol __vmalloc
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: unresolved
symbol printk
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o: insmod
/lib/modules/2.4.0-test11/kernel/drivers/sound/soundcore.o
failed            

and so on...

i can post more information, if needed.
Please help, modules just don't work :(
david
Comment 1 Alan Cox 2000-11-26 06:48:46 EST
7.0 certainly can build valid 2.4test kernels. As to what is going on - the dump
you give looks like you have MODVERSIONS mangled somehow. Save your .config; do
a make mrproper; put it back
make oldconfig and try that
Comment 2 Taavi Tuisk 2000-11-26 07:58:06 EST
Well, it seems to be resolved now, i used make install instead make bzlilo now,
and everything works ... thnx. But i think, more documentation would help.. i 
could volunteer, if needed.

Note You need to log in before you can comment on or make changes to this bug.