This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 207537 - Eclipse cannot start with error locking file.
Eclipse cannot start with error locking file.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 10:49 EDT by Nurdin Premji
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-08 14:47:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
workspace/metadata/log (25.14 KB, text/plain)
2006-09-21 10:49 EDT, Nurdin Premji
no flags Details
Log file (9.45 KB, text/plain)
2006-09-21 17:09 EDT, Nurdin Premji
no flags Details
Log file for October 10, 2006 (9.71 KB, text/plain)
2006-10-10 14:58 EDT, Nurdin Premji
no flags Details
Update log for October 16, 2006 (6.71 KB, text/plain)
2006-10-16 10:27 EDT, Nurdin Premji
no flags Details
Yet another update log, leads me to believe this is a kernel issue. (2.98 KB, application/octet-stream)
2006-10-17 10:28 EDT, Nurdin Premji
no flags Details
update log for November 8, 2006 (19.89 KB, application/octet-stream)
2006-11-08 13:47 EST, Nurdin Premji
no flags Details
update log for November 7, 2006 (8.85 KB, application/octet-stream)
2006-11-08 13:49 EST, Nurdin Premji
no flags Details
update log for November 6, 2006 (3.24 KB, application/octet-stream)
2006-11-08 13:49 EST, Nurdin Premji
no flags Details
update log for November 3, 2006 (2.91 KB, application/octet-stream)
2006-11-08 13:50 EST, Nurdin Premji
no flags Details
update log for November 2, 2006 (4.03 KB, application/octet-stream)
2006-11-08 13:50 EST, Nurdin Premji
no flags Details

  None (edit)
Description Nurdin Premji 2006-09-21 10:49:14 EDT
Description of problem:
Eclipse doesn't start with this error in the log.
!ENTRY org.eclipse.osgi 4 0 2006-09-21 10:37:19.848
!MESSAGE Error reading configuration: An error occurred while locking file
"/home/npremji/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.osgi/
.manager/.fileTableLock": "No locks available". A common reason is that the file
system or Runtime Environment does not support file locking for that locatio
n. Please choose a different location, or disable file locking passing
"-Dosgi.locking=none" as a VM argument.
!STACK 0

the .fileTableLock file is empty.

Version-Release number of selected component (if applicable):
3.2

How reproducible:
Every time.

Steps to Reproduce:
1. Remove .eclipse and workspace directories.
2. Start eclipse
3.
  
Actual results:

Errors out.

Expected results:
Eclipse should start.

Additional info:
Attached is the log file
Comment 1 Nurdin Premji 2006-09-21 10:49:14 EDT
Created attachment 136861 [details]
workspace/metadata/log
Comment 2 Ben Konrath 2006-09-21 10:53:42 EDT
I'm sure out this problem but I also see the problem described in bug # 207442.
Can you try the recommended solution there?
Comment 3 Ben Konrath 2006-09-21 11:05:43 EDT
That should say "I *not* sure about this problem ..."
Comment 4 Nurdin Premji 2006-09-21 17:09:45 EDT
Created attachment 136908 [details]
Log file

Another log from the workspace/.metadata/.log file
Comment 5 Nurdin Premji 2006-09-21 17:10:49 EDT
Installing eclipse-sdk did not work for me btw. I thought this comment would be
added when I added the log.
Comment 6 Ben Konrath 2006-09-21 17:15:47 EDT
Can you try starting eclipse with a new workspace?
Comment 7 Nurdin Premji 2006-09-21 17:44:20 EDT
I've been removing my workspace every time I start eclipse.
Also removing the .eclipse directory as well.
Comment 8 Andrew Overholt 2006-10-05 16:00:17 EDT
Nurdin:  is this still broken for you?
Comment 9 Nurdin Premji 2006-10-05 16:29:33 EDT
nope it was fixed on an update. Or at least I updated and the problem went away.
Comment 10 Andrew Overholt 2006-10-05 16:44:02 EDT
(In reply to comment #9)
> nope it was fixed on an update. Or at least I updated and the problem went away.

Thanks, closing.
Comment 11 Nurdin Premji 2006-10-10 14:58:45 EDT
Created attachment 138177 [details]
Log file for October 10, 2006

And it's broken again with this log.

I tried a complete wipeout and reinstall of eclipse, no dice.

[npremji@tow npremji]$ grep eclipse.product
/usr/share/eclipse/configuration/config.ini 
eclipse.product=org.eclipse.sdk.ide
# the identified eclipse.product defines the default application to run.
[npremji@tow npremji]$ rpm -qa | grep eclipse
eclipse-ecj-3.2.1-4.fc6
eclipse-subclipse-1.1.5-2.fc6
eclipse-jdt-sdk-3.2.1-4.fc6
eclipse-cdt-3.1.1-1.fc6
eclipse-gef-sdk-3.2.0-2
eclipse-gef-3.2.0-2
eclipse-platform-sdk-3.2.1-4.fc6
eclipse-subclipse-book-1.1.5-2.fc6
eclipse-pde-3.2.1-4.fc6
eclipse-rcp-3.2.1-4.fc6
eclipse-bugzilla-0.2.4-3.fc6
eclipse-changelog-2.3.2-1.fc6
eclipse-pde-runtime-3.2.1-4.fc6
eclipse-pde-sdk-3.2.1-4.fc6
eclipse-platform-3.2.1-4.fc6
eclipse-cdt-sdk-3.1.1-1.fc6
eclipse-sdk-3.2.1-4.fc6
eclipse-rcp-sdk-3.2.1-4.fc6
eclipse-jdt-3.2.1-4.fc6
eclipse-gef-examples-3.2.0-2
Comment 12 Ben Konrath 2006-10-10 15:02:33 EDT
Remove ~/.eclipse and try running again with a new workspace. Thanks.
Comment 13 Nurdin Premji 2006-10-10 15:29:35 EDT
Uh I did that as well, sorry I didn't mention.
Comment 14 Ben Konrath 2006-10-10 15:31:55 EDT
What architecture are you using?
Comment 15 Ben Konrath 2006-10-10 15:35:44 EDT
Also, what version of gcj are you using?
Comment 16 Nurdin Premji 2006-10-10 15:46:18 EDT
Architecture is i386, dell optiplex gx280.

gcj version is:
 gcj --version
gcj (GCC) 4.1.1 20060928 (Red Hat 4.1.1-28)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

libgcj-4.1.1-28
java-1.4.2-gcj-compat-1.4.2.0-40jpp.109
libgcj-devel-4.1.1-28
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp.109
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp.109
Comment 17 Ben Konrath 2006-10-10 16:00:52 EDT
I have an i386 box with the same software [1] and I can't reproduce your problem.

[1] % rpm -q gcc-java libgcj eclipse-sdk java-1.4.2-gcj-compat
gcc-java-4.1.1-28
libgcj-4.1.1-28
eclipse-sdk-3.2.1-4.fc6
java-1.4.2-gcj-compat-1.4.2.0-40jpp.109
Comment 18 Nurdin Premji 2006-10-11 10:55:53 EDT
As of this morning's yum update which updated the filesystem package eclipse is
working again. (Not entirely sure if that was the specific package that fixed it
but I think it might be as eclipse used to complain the filesystem couldn't
handle locking.)

I guess the thing to do is make sure filesystem guys run eclipse to test locking :)
Comment 19 Ben Konrath 2006-10-11 16:17:29 EDT
Ok, let's close the bug for now. Feel free to re-open it if you hit it again.
Comment 20 Nurdin Premji 2006-10-16 10:27:42 EDT
Created attachment 138577 [details]
Update log for October 16, 2006

So it broke again, I don't think its an eclipse bug but here is the update log
of what I just updated, please help me find which of these packages is messing
with eclipse. Thank you.
Comment 21 Nurdin Premji 2006-10-17 10:28:44 EDT
Created attachment 138683 [details]
Yet another update log, leads me to believe this is a kernel issue.

So on my update today things have started working again, the only things that
were successfully updated were the kernel, so I assume this is a kernel issue.
Comment 22 Ben Konrath 2006-10-18 14:02:16 EDT
I still can't reproduce this bug so I'm closing it again. Please re-open this
bug if this crops up again.
Comment 23 Nurdin Premji 2006-11-08 13:47:14 EST
Created attachment 140688 [details]
update log for November 8, 2006

I've installed fc6 official rather than going with devel and as of today
something is broken which gives back the same locking error message. This is
the most recent update I'll post more going back to Nov 2, when I reinstalled.
Comment 24 Nurdin Premji 2006-11-08 13:49:18 EST
Created attachment 140689 [details]
update log for November 7, 2006
Comment 25 Nurdin Premji 2006-11-08 13:49:50 EST
Created attachment 140690 [details]
update log for November 6, 2006
Comment 26 Nurdin Premji 2006-11-08 13:50:07 EST
Created attachment 140691 [details]
update log for November 3, 2006
Comment 27 Nurdin Premji 2006-11-08 13:50:28 EST
Created attachment 140692 [details]
update log for November 2, 2006
Comment 28 Ben Konrath 2006-11-08 13:51:20 EST
Since you're the only person that is having this problem and I can't reproduce
it, there's not much I can do to help here. Sorry.
Comment 29 Ben Konrath 2006-11-08 14:33:22 EST
Just archiving more information about this issue that Andrew found:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=44735#c51
https://bugs.eclipse.org/bugs/show_bug.cgi?id=59780
Comment 30 Ben Konrath 2006-11-08 14:43:52 EST
Starting statd with '/etc/init.d/nfslock start' fixed the problem.
Comment 31 Ben Konrath 2006-11-08 14:47:14 EST
Closing bug since it's not an eclips bug.

Note You need to log in before you can comment on or make changes to this bug.