Bug 207585 - "--biospart" option not recognized in RHEL5 Beta1
"--biospart" option not recognized in RHEL5 Beta1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pykickstart (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
: 207584 (view as bug list)
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-09-21 14:36 EDT by Rezwanul Kabir
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.35-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-03 09:52:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rezwanul Kabir 2006-09-21 14:36:30 EDT
Description of problem:

The "doMethod" handler for "hardrive" command in ks.cfg defined 
in "pykickstart" module does not recognize "biospart" option.
For example, 
                   harddrive --biospart=80p2 --dir=/
 
   in ks.cfg will cause parsing error. 


Version-Release number of selected component (if applicable):

anaconda-11.1.0.77

How reproducible:

Always

Steps to Reproduce:

1. Use the attached ks.cfg for installation
2. 
3.
  
Actual results:

The following Kickstart Error Message is printed out:

"Error Parsing Kickstart config
 The following error was found while parsing your kickstart configuration:
 The following problem occurred on line 18 of the kickstart file.
 No such option: --biospart "

 

Expected results:

Install should go on without any error

Additional info:
Comment 1 Jeremy Katz 2006-09-21 14:42:08 EDT
*** Bug 207584 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2006-09-25 10:35:46 EDT
This will be fixed in the next build of pykickstart.
Comment 3 Rezwanul Kabir 2006-09-25 12:37:36 EDT
While you are at it, pls make sure "driverdisk" command in ks.cfg also 
recognize "--biospart" option...
Comment 4 Rezwanul Kabir 2006-10-03 14:12:08 EDT
What RedHat weekly build will have this fix? The fix was not included in the 
build of 09/22..
Comment 5 Chris Lumens 2006-10-03 15:13:42 EDT
The 10/04 tree should have the fix.  You're looking for a tree with
pykickstart-0.35-1 in it.
Comment 6 RHEL Product and Program Management 2006-10-26 15:52:16 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Amit Bhutani 2006-11-03 00:09:29 EST
Verified fixed. Please close. Thanks!

Note You need to log in before you can comment on or make changes to this bug.