Bug 207594 - traceback in flags.py
traceback in flags.py
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: James Antill
Mike McLean
bzcl34nup
:
: 207720 208969 208977 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 15:30 EDT by Brian Brock
Modified: 2008-04-22 22:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-22 22:08:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2006-09-21 15:30:06 EDT
anaconda traceback

rawhide-20060921 i386 and x86_64

Running anaconda, the Fedora Core system installer - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 613, in ?
    iutil.writeRpmPlatform()
  File "/usr/lib/anadonda/iutil.py", line 402, in writeRpmPlatform
    if flags["targetarch"] != None:
  File "/usr/lib/anaconda/flags.py", line 25 in __getattr__
    raise AttributeError, attr
AttributeError: __getitem__
install exited abnormally [1/1]
Comment 1 Brian Brock 2006-09-21 15:31:42 EDT
seems to be between stages 1 and 2

occurs with every pxe / ks.cfg over nfs install that I've attempted.
Comment 2 Jeremy Katz 2006-09-21 15:56:44 EDT
Not sure how I wasn't hitting this when I was testing it yesterday, but fixed
Comment 3 Steve Fox 2006-09-22 12:38:19 EDT
I hit this error today when trying to boot the rescue CD.
Comment 4 Jeremy Katz 2006-09-22 14:29:56 EDT
*** Bug 207720 has been marked as a duplicate of this bug. ***
Comment 5 John Reiser 2006-09-22 16:42:42 EDT
Not fixed.  I agree with Comment #3: booting today's i386 rescue CD (sha1sum
156dcb34b37a2a554e32e980f1dd3609d49dbdfa) I still see the same error.  Rescue
fails to work at all.
Comment 6 Jeremy Katz 2006-10-02 16:18:45 EDT
*** Bug 208969 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2006-10-02 16:26:54 EDT
*** Bug 208977 has been marked as a duplicate of this bug. ***
Comment 8 Bug Zapper 2008-04-03 14:17:20 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 John Reiser 2008-04-04 23:07:43 EDT
The Rescue CDs (now called 'netinst') have worked for me for all of the Fedora 9
alpha and beta systems (i686, x86_64, PowerPC).
Comment 10 John Poelstra 2008-04-22 22:08:03 EDT
thanks for your update. closing

Note You need to log in before you can comment on or make changes to this bug.