Bug 20760 - problem with makefiles causes incorrct build
problem with makefiles causes incorrct build
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: imap (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-13 13:53 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-19 19:24:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-13 13:53:34 EST
There seems to be a problem with
map-2000/Makefile
The settings
EXTRACFLAGS= -DDISABLE_POP_PROXY=1  -DIGNORE_LOCK_EACCES_ERRORS=1
do not propagate when doing a build.
Probably a keyword "export" must be added somewhere in make
so files like imap-2000/src/osdep/unix/Makefile
catch the value in the line 
CFLAGS=$(BASECFLAGS) $(EXTRACFLAGS)
Comment 1 Need Real Name 2000-11-13 17:29:07 EST
The problem is with imap.spec
It 
1. patches imap-2000/Makefile
2. Sets the environment variable EXTRACFLAGS
which makes it ignoring the value set in Makefile for sub-makes.

The right solution is not to patch Makefile,
but put directly into imap.spec

%build
EXTRACFLAGS="-DDISABLE_POP_PROXY=1  -DIGNORE_LOCK_EACCES_ERRORS=1"
....
This the options will be propagate across the Makefile(s).
Comment 2 Need Real Name 2000-11-13 19:02:59 EST
Also, the same problem exists
with imap srom RedHat 7.0 updates.
One need to add EXTRACFLAGS to imap.spec
as I recommended in the previod message to compile it correctly.
Comment 3 Mike A. Harris 2001-03-17 17:41:43 EST
Fixed in Rawhide a while back.. forgot to update the bug.. sorry..

Note You need to log in before you can comment on or make changes to this bug.