Bug 207645 - kview crashes when log out with a opened picuture
kview crashes when log out with a opened picuture
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdegraphics (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
: Desktop
Depends On:
Blocks: 211966
  Show dependency treegraph
 
Reported: 2006-09-22 03:18 EDT by Nicole Dai
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: FC6-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 06:00:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicole Dai 2006-09-22 03:18:02 EDT
Description of problem:
kview crashes when log out with a opened picuture

Version-Release number of selected component (if applicable):
kdegraphics-3.5.4-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.Open a picuture by kview.
2.Log out.
3.
  
Actual results:
kview crashes with the following information:
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208207664 (LWP 5677)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6  0x035a3e4e in typeinfo name for QObject ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#7  0x084f6370 in ?? ()
#8  0x003bfd3e in KView::eventFilter () from /usr/lib/libkdeinit_kview.so
#9  0x0312b46c in QObject::activate_filters ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#10 0x0312b4eb in QObject::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#11 0x03168f3c in QWidget::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#12 0x03236922 in QMainWindow::event () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#13 0x030c30fb in QApplication::internalNotify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#14 0x030c4579 in QApplication::notify ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#15 0x038a8922 in KApplication::notify () from /usr/lib/libkdecore.so.4
#16 0x0312ca2f in QObject::removeChild ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#17 0x0312dc1b in QObject::~QObject$base ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#18 0x002dd29f in KParts::Part::~Part$base () from /usr/lib/libkparts.so.2
#19 0x002e8f65 in KParts::ReadOnlyPart::~ReadOnlyPart$base ()
   from /usr/lib/libkparts.so.2
#20 0x002e90a1 in KParts::ReadWritePart::~ReadWritePart$base ()
   from /usr/lib/libkparts.so.2
#21 0x003cbd21 in KImageViewer::Viewer::~Viewer$base ()
   from /usr/lib/libkimageviewer.so.0
#22 0x00f4016b in KViewViewer::~KViewViewer$delete ()
   from /usr/lib/kde3/libkviewviewer.so
#23 0x002dfca4 in KParts::Part::slotWidgetDestroyed ()
   from /usr/lib/libkparts.so.2
#24 0x002dfd12 in KParts::Part::qt_invoke () from /usr/lib/libkparts.so.2
#25 0x002e5066 in KParts::ReadOnlyPart::qt_invoke ()
   from /usr/lib/libkparts.so.2
#26 0x002e5129 in KParts::ReadWritePart::qt_invoke ()
   from /usr/lib/libkparts.so.2
#27 0x003cbe46 in KImageViewer::Viewer::qt_invoke ()
   from /usr/lib/libkimageviewer.so.0
#28 0x00f3d8a3 in KViewViewer::qt_invoke ()
   from /usr/lib/kde3/libkviewviewer.so
#29 0x0312bd91 in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#30 0x0312c95d in QObject::activate_signal ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#31 0x034b6329 in QObject::destroyed () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#32 0x0312dbc4 in QObject::~QObject$base ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#33 0x0316b7c6 in QWidget::~QWidget$base ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#34 0x0325bbf8 in QScrollView::~QScrollView$base ()
   from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#35 0x0055cf90 in KImageCanvas::~KImageCanvas$delete ()
   from /usr/lib/kde3/libkviewcanvas.so
#36 0x03eb004e in QPtrList<QObject>::deleteItem () from /usr/lib/libkdeui.so.4
#37 0x0342c5ed in QGList::clear () from /usr/lib/qt-3.3/lib/libqt-mt.so.3
#38 0x03808bd4 in KLibrary::~KLibrary$delete () from /usr/lib/libkdecore.so.4
#39 0x038081ff in KLibLoader::close_pending () from /usr/lib/libkdecore.so.4
#40 0x0381dc35 in KLibLoader::~KLibLoader$delete ()
   from /usr/lib/libkdecore.so.4
#41 0x037a8b8b in KLibLoader::cleanUp () from /usr/lib/libkdecore.so.4
#42 0x0383fa67 in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#43 0x003c42f9 in kdemain () from /usr/lib/libkdeinit_kview.so
#44 0x08048472 in ?? ()
#45 0x0098bf2c in __libc_start_main () from /lib/libc.so.6
#46 0x080483c1 in ?? ()

Expected results:


Additional info:
Comment 1 Ngo Than 2006-10-31 06:00:55 EST
i cannot reproduce this issue with KDE-3.5.5 release in FC6-update.

Note You need to log in before you can comment on or make changes to this bug.