Bug 207651 - buildinstall fails to build stage2.img
buildinstall fails to build stage2.img
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 05:37 EDT by Edouard Bourguignon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 09:48:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edouard Bourguignon 2006-09-22 05:37:28 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

static

Steps to Reproduce:
1.run buildinstall
2.get some errors about not finding some important binaries (semodule, anaconda)
3.stage2.img is not created or modified
  
Actual results:

Running buildinstall...
/DEVEL/Masters/2007/Anaconda/fedora/i386/buildinstall.tree.14933
/DEVEL/Masters/2007/Anaconda/fedora
/DEVEL/Masters/2007/Anaconda/fedora
Going to run buildinstall again
Building images...
Assembling package list...
Expanding text packages...
Expanding graphical packages...
retrieving timezones
Building locale archive
Building locale archive
Creating nsswitch.conf
Fixing up /etc/man.config to point into /mnt/sysimage
Running mkfontdir...
Creating SELinux policy...
/usr/sbin/chroot: cannot run command `/usr/sbin/semodule': No such file or directory
Getting pango modules
/usr/sbin/chroot: cannot run command `/usr/bin/pango-querymodules': No such file
or directory
Getting gtk2 input method modules
/usr/sbin/chroot: cannot run command `/usr/bin/gtk-query-immodules-2.0': No such
file or directory
Getting gtk2 gdk-pixbuf loaders
/usr/sbin/chroot: cannot run command `/usr/bin/gdk-pixbuf-query-loaders': No
such file or directory
Scrubbing trees... /tmp/treedir.14946/image-template
/usr/sbin/chroot: cannot run command `usr/sbin/ldconfig': No such file or directory
Scrubbing trees... /tmp/treedir.14946/instimage
/usr/sbin/chroot: cannot run command `usr/sbin/ldconfig': No such file or directory
Compressing .mo files in stage2 images...
Creating fontconfig cache
/usr/sbin/chroot: cannot run command `/usr/bin/fc-cache': No such file or directory

Expected results:

no errors, finds all the binaries and creates or updates the stage2.img


Additional info:

perhaps i miss something, or do it wrong, but i works well on RHEL AS4
Comment 1 Jeremy Katz 2006-09-22 11:29:38 EDT
Have you changed the package set?
Comment 2 Edouard Bourguignon 2006-09-22 11:32:18 EDT
which one? I have read upd-instroot to find what packages are required, am i
missing some packages?
Comment 3 Edouard Bourguignon 2006-09-22 11:41:47 EDT
i've just copy all the FC5 disc1 and my errors disappear, but i get new ones

Running buildinstall...
/DEVEL/Masters/2007/Anaconda/fedora/i386/buildinstall.tree.31503
/DEVEL/Masters/2007/Anaconda/fedora
/DEVEL/Masters/2007/Anaconda/fedora
Going to run buildinstall again
Building images...
Assembling package list...
Expanding text packages...
Expanding graphical packages...
retrieving timezones
cat: /tmp/treedir.31516/instimage/usr/lib/anaconda/lang-table*: No such file or
directory
Building locale archive
Building locale archive
ln: creating symbolic link `/tmp/treedir.31516/instimage/etc/joe/picorc' to
`jpicorc': No such file or directory
ln: creating symbolic link `/tmp/treedir.31516/instimage/etc/joe/jnanorc' to
`jpicorc': No such file or directory
ln: creating symbolic link `/tmp/treedir.31516/instimage/etc/joe/nanorc' to
`jpicorc': No such file or directory
ln: creating symbolic link `/tmp/treedir.31516/instimage/etc/joe/emacsrc' to
`jmacsrc': No such file or directory
Creating nsswitch.conf
Fixing up /etc/man.config to point into /mnt/sysimage
Running mkfontdir...
Creating SELinux policy...
Getting pango modules
Getting gtk2 input method modules
Getting gtk2 gdk-pixbuf loaders
Scrubbing trees... /tmp/treedir.31516/image-template
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/raidstart-stub': No such
file or directory
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/raidstop-stub': No such file
or directory
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/losetup-stub': No such file
or directory
cp: cannot stat `/tmp/treedir.31516/image-template/usr/lib/anaconda/pump-stub':
No such file or directory
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/list-harddrives-stub': No
such file or directory
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/kudzu-probe-stub': No such
file or directory
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/loadkeys-stub': No such file
or directory
cp: cannot stat `/tmp/treedir.31516/image-template/usr/lib/anaconda/mknod-stub':
No such file or directory
cp: cannot stat
`/tmp/treedir.31516/image-template/usr/lib/anaconda/rescue-startx-stub': No such
file or directory
mv: cannot stat `/tmp/treedir.31516/image-template/usr/sbin/anaconda': No such
file or directory
Scrubbing trees... /tmp/treedir.31516/instimage
cp: cannot stat `/tmp/treedir.31516/instimage/usr/lib/anaconda/raidstart-stub':
No such file or directory
cp: cannot stat `/tmp/treedir.31516/instimage/usr/lib/anaconda/raidstop-stub':
No such file or directory
cp: cannot stat `/tmp/treedir.31516/instimage/usr/lib/anaconda/losetup-stub': No
such file or directory
cp: cannot stat `/tmp/treedir.31516/instimage/usr/lib/anaconda/pump-stub': No
such file or directory
cp: cannot stat
`/tmp/treedir.31516/instimage/usr/lib/anaconda/list-harddrives-stub': No such
file or directory
cp: cannot stat
`/tmp/treedir.31516/instimage/usr/lib/anaconda/kudzu-probe-stub': No such file
or directory
cp: cannot stat `/tmp/treedir.31516/instimage/usr/lib/anaconda/loadkeys-stub':
No such file or directory
cp: cannot stat `/tmp/treedir.31516/instimage/usr/lib/anaconda/mknod-stub': No
such file or directory
cp: cannot stat
`/tmp/treedir.31516/instimage/usr/lib/anaconda/rescue-startx-stub': No such file
or directory
mv: cannot stat `/tmp/treedir.31516/instimage/usr/sbin/anaconda': No such file
or directory
cp: cannot stat `/tmp/treedir.31516/instimage/boot/memtest*': No such file or
directory
Compressing .mo files in stage2 images...
Creating fontconfig cache
Creating debug dir
Patching python library...
/DEVEL/Masters/2007/Anaconda/fedora
Removing unused python files in hdimage... /usr/sbin/chroot: cannot run command
`/usr/bin/anaconda': No such file or directory
find: usr/lib/anaconda: No such file or directory
find: usr/lib/booty: No such file or directory
done.
Cleaning ramdisk install images...
Creating repository metadata...
Getting package order...
PYTHONPATH=/tmp/treedir.31516/instimage/usr/lib/anaconda
/tmp/treedir.31516/instimage/usr/lib/anaconda-runtime/pkgorder
/DEVEL/Masters/2007/Anaconda/fedora/i386 i386 Fedora
Making images...
/tmp/treedir.31516/instimage/usr/lib/anaconda/lang-table doesn't exist
Writing .discinfo file
timestamp not specified; using the current time
Comment 4 Edouard Bourguignon 2006-09-25 09:15:41 EDT
well now that all the CDs are copied, buildinstall seems to work better. But it
seems that it doesn't update the .buidstamp inside the stage2.img

so .discinfo and .buildstamp have not the same values and disagree about the
product name of the CD. Therefore (maybe i'm wrong) during the install Anaconda
complains that it can't detect the good CD

my .discinfo:
1159189502.274288
Custom CD v0.01
i386
1,2,3
Fedora/base
Fedora/RPMS
Fedora/pixmaps

my .buildstamp in stage2.img:
200603142328.i386
Fedora Core
5
Fedora
your distribution provided bug reporting tool.

my buildinstall command line:
/usr/lib/anaconda-runtime/buildinstall \
        --comp "Test-0.01" \
        --pkgorder ./i386/pkgorder \
        --version 0.01 \
        --product "Custom CD" \
        --release "Custom CD v0.01" \
        --prodpath Fedora \
        --bugurl http://server/bugzilla/ \
        ./i386

Is it normal? On RHEL the .buildstamp has the correct values, values given as
buildinstall parameters. Here it seems that it doesn't care about those parameters.

Here is the .buildstamp i get in the stage2.img:
200603142328.i386
Fedora Core
5
Fedora
your distribution provided bug reporting tool.

I miss something?
Comment 5 Edouard Bourguignon 2006-09-25 11:26:26 EDT
During the install i've got this error just before anaconda says it can't detect
the cdrom:

Unable to load NLS charset utf8
ISO 9660 Extensions: RRIP_1991A
Unable to identify CD-ROM format.
VFS: Can't find an ext2 filesystem on dev loop0.

And dev loop0 seems to be the mount point of stage2.img. Stage2.img is a
squashfs but maybe anaconda tries first to load it in ext2 and then in squashfs.
So i'm not sure if it's a problem
Comment 6 Edouard Bourguignon 2006-09-26 06:14:43 EDT
ok netpbm-progs need to be installed before runing buildinstall

thanks for you help

Note You need to log in before you can comment on or make changes to this bug.