Bug 207683 - unsatisfied dependencies for redhat-lsb
unsatisfied dependencies for redhat-lsb
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lawrence Lim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 11:11 EDT by Need Real Name
Modified: 2014-03-25 20:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: 3.1-10.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-24 01:46:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2006-09-22 11:11:16 EDT
rpm -Va says, that redhat-lsb has unsatisfied dependencies on:
 /usr/bin/ar
 /usr/bin/m4
 /usr/bin/patch
 /usr/bin/strip
Comment 1 Lawrence Lim 2006-09-24 21:05:53 EDT
Are these installed on your system?? These is a list mandate by LSB Spec as must
have in the system if you want the system to be LSB compliance.
Comment 2 Need Real Name 2006-09-25 02:40:52 EDT
A new check says that:
 /usr/bin/ar <- INSTALLED
 /usr/bin/m4 <- NOT INSTALLED
 /usr/bin/patch <- NOT INSTALLED
 /usr/bin/strip <- INSTALLED

Try it yourself - rpm -V lsb-release

This was a fresh install clicking all the default options.
Comment 3 Need Real Name 2006-09-25 04:19:30 EDT
re-confirmed with fresh-install - all four dependencies are missing.
Comment 4 Need Real Name 2006-09-27 06:34:26 EDT
This is a blocker for FC6, isn't it?
Comment 5 Need Real Name 2006-09-29 18:16:48 EDT
Was this fixed?
Comment 6 Kevin Fenzi 2007-03-24 01:46:07 EDT
It sure looks like it was fixed here... 
I can't duplicate the problem on a fc6 system at least. 

The changelog in the redhat-lsb package just has: 

* Thu Sep 21 2006 Lawrence Lim <llim@redhat.com> - 3.1-10.3
- Fix upgrade issue; Bug 202548

But that bug is not accessable, so it's hard to say if it's related to this one. 

I am going to go ahead and close this bug now, but if you can spot any issues 
with the fc6 redhat-lsb, please feel free to re-open or file a new bug.

Note You need to log in before you can comment on or make changes to this bug.