This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 207692 - please add aliases for Ricoh fonts
please add aliases for Ricoh fonts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: fonts-japanese-ricoh (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
: i18n, Reopened
Depends On: 206131
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 12:16 EDT by Akira TAGOH
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 04:58:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2006-09-22 12:16:52 EDT
Description of problem:
We're going to ship the commercial Ricoh fonts in the supplementary CD to get
better rendering for Japanese. it would be good if fontconfig chooses Ricoh
fonts as default when it gets installed.

I'd propose to add aliases like

serif: HGMinchoL
sans-serif: HGGothicB
monospace: HGGothicB
Comment 1 Behdad Esfahbod 2006-09-22 17:00:47 EDT
You should them as a config file to the package shipping the fonts.  Check out
how this is done in dejavu-lgc-fonts for example.  I will be more than happy to
help you write the configuration file and choose a number for it.
Comment 2 Behdad Esfahbod 2006-09-22 17:39:38 EDT
oops.

Is there a component for this Ricoh fonts?
Comment 3 Akira TAGOH 2006-09-23 09:52:10 EDT
(In reply to comment #1)
> You should them as a config file to the package shipping the fonts.  Check out
> how this is done in dejavu-lgc-fonts for example.  I will be more than happy to
> help you write the configuration file and choose a number for it.

Yes, if it's possible, it would be ideal. but even if Ricoh fonts is installed,
will any chinese fonts be used when the desktop or the applications runs under
zh* locale in that case? we do for our default fonts so that it's likely to get
all the fonts installed at the same time. and for Ricoh fonts, it shouldn't be
an exception IMHO.

(In reply to comment #2)
> oops.
> 
> Is there a component for this Ricoh fonts?

No, not yet it seems.
Comment 4 Akira TAGOH 2006-09-27 10:39:29 EDT
ok, it looks good with the separate fontconfig conf file.
Comment 5 Lawrence Lim 2006-10-02 00:51:58 EDT
Reference to Release Criteria:
Section 7.C.3

7. I18N-> C. Fonts -> 3. Ricoh commercial font for ja_JP included

<http://intranet.corp.redhat.com/ic/intranet/RHEL500Beta2ReleaseCriteria.html#i18n>
Comment 6 Matthias Clasen 2006-10-11 17:18:29 EDT
Akira, is this fixed in fonts-japanese-ricoh-0.20060908-5.el5 ?
And if it isn't, can you tell me what bugzilla product/component
is the right one for that package ?
Comment 7 Akira TAGOH 2006-10-12 07:28:54 EDT
No, I was about to fix this in -6.el5 though, all the process is stalled due to
the legal issue. so there are no components in bugzilla yet. if keeping this in
fontconfig is bothering you, please feel free to reassign this to
fonts-japanese. I'll reassign to the proper components after we passed it.
Comment 8 Matthias Clasen 2006-10-12 07:33:02 EDT
ok, thanks for the update
Comment 9 Leon Ho 2006-10-16 03:31:00 EDT
devel_ack+
Comment 10 RHEL Product and Program Management 2006-10-26 15:51:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 11 Akira TAGOH 2006-12-11 22:18:04 EST
fixed in fonts-japanese-ricoh-0.20060908-6.el5.
Comment 13 RHEL Product and Program Management 2006-12-22 19:23:56 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.
Comment 14 Lawrence Lim 2007-01-19 02:53:58 EST
[root@phantom ~]# rpm -Uvh fonts-japanese-ricoh-0.20060908-6.el5.noarch.rpm
Preparing...                ########################################### [100%]
   1:fonts-japanese-ricoh   ########################################### [100%]
[root@phantom ~]# LANG=ja_JP.UTF-8 fc-match
kochi-gothic-subst.ttf: "Sazanami Gothic" "Gothic-Regular"
Comment 15 Akira TAGOH 2007-01-19 08:20:52 EST
Fixed a fontconfig conf file though, fc-match still shows me as not Ricoh font.
however I confirm on gucharmap that Ricoh font works as default font now. so it
should be sufficient for this issue at this moment.

20060908-7.el5 was built into brew.
Comment 16 Xiaohong Wang 2007-01-30 04:04:40 EST
Verified on fonts-japanese-ricoh-0.20060908-7.el5, there is
/etc/fonts/conf.d/59-fonts-japanese-ricoh.conf. Now resolve this bug, you may
reopen it if the solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.