Bug 207718 - vim: no highlighted syntax + no tag support in help
vim: no highlighted syntax + no tag support in help
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 13:42 EDT by German Monroy
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 05:18:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description German Monroy 2006-09-22 13:42:25 EDT
Description of problem:
I haven't been able to use the highlighted syntax feature in vim.  Also when I
go to the help the key I traditionally use to enter a tag ^] doesn't work
(reports E434: Can't find tag pattern and then shows garbage)

Version-Release number of selected component (if applicable):
I updated with yum to
vim-enhanced-7.0.100-1
vim-minimal-7.0.100-1
vim-common-7.0.100-1
I got the same problem with the vim rpms shipping in FC6 Test3

How reproducible:
always

Steps to Reproduce:
1. open vi 
2. :h
3. press ^] in any tag help

Trying to enable highlighted syntax.  
1. vi ~/.vimrc
2. :r $VIMRUNTIME/vimrc_example.vim
3. :w
4. open any file with should be recognized by highlighted syntax (e.g.
/boot/grub/menu.lst)

 
Actual results:
^] reports "E434: Can't find tag pattern"
highlighted syntax doesn't work: text is black

Expected results:
^] should jump to the corresponding help page
highlighed syntax should work for the default file types.

Additional info:
Comment 1 Karsten Hopp 2006-09-26 05:18:25 EDT
You're using /bin/vi, the vim binary with the 'tiny' featureset which can't
handle the compressed help files and can't do syntax highlighting. Only
/usr/bin/vim and gvim can handle those. 
I intended to write up a minimal help file and point /bin/vi to that one, but
got distracted by other tasks.
In the meantime please use 'vim' instead of 'vi' or set an alias (which isn't
set for uids < 100, so I'm assuming your trying to edit files as root)
Comment 2 German Monroy 2006-09-26 12:44:06 EDT
Thanks a lot for letting me know this, Karsten.  A small help file as you 
mention describing the vi/vim situation would be great to have.  Best regards.

Note You need to log in before you can comment on or make changes to this bug.