Bug 207751 - rpmbuild -ta broken by incompatible change in tar 1.15.91
rpmbuild -ta broken by incompatible change in tar 1.15.91
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Panu Matilainen
http://lists.gnu.org/archive/html/bug...
:
Depends On: 207689
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 16:40 EDT by Dave Malcolm
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 07:38:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2006-09-22 16:40:25 EDT
+++ This bug was initially created as a clone of Bug #207689 +++

+++ This bug was initially created as a clone of Bug #206841 +++

Description of problem:
The -t option of rpmbuild (e.g. rpmbuild -ta mytarball.tar.bz2) doesn't work 
anymore since the latest tar upgrade to FC5. The cause is an incompatible 
change in tar's handling of wildcards passed on the command line. See:
http://lists.gnu.org/archive/html/bug-tar/2006-06/msg00001.html
You now have to pass the --wildcards parameter when looking for '*.spec'.

Version-Release number of selected component (if applicable):
rpm-build-4.4.2-15.2
tar-1.15.91-1.FC5

How reproducible:
Always.

Steps to Reproduce:
1. Create a tarball with a specfile in it.
2. rpmbuild -ta mytarball.tar.bz2

Actual results:
Spurious errors due to the specfile not being found, i.e.:
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)

Expected results:
The package builds.

Additional info:
Workaround:
TAR_OPTIONS=--wildcards rpmbuild -ta mytarball.tar.bz2

-- Additional comment from kevin.kofler@chello.at on 2006-09-17 02:38 EST --
Adding tar maintainer to CC.

-- Additional comment from pnasrat@redhat.com on 2006-09-20 03:27 EST --
*** Bug 207239 has been marked as a duplicate of this bug. ***

-- Additional comment from dmalcolm@redhat.com on 2006-09-20 20:10 EST --
Me too on Rawhide: I end up with an empty file in rpmbuild/SPECS called:
"tar: Pattern matching characters used in file names. Please," which it tries to
interpret as the specfile, leading to the failure messages above.

Appears to prevent all of the -t options of rpmbuild from working in Rawhide
(ouch); this feels like a blocker to me.


-- Additional comment from dmalcolm@redhat.com on 2006-09-20 20:14 EST --
Sorry, versions in rawhide exhibiting the bug are:
rpm-build-4.4.2-32
tar-1.15.91-1


-- Additional comment from dmalcolm@redhat.com on 2006-09-21 12:52 EST --
I've written a reproducer for this here:
https://testing.108.redhat.com/source/browse/*checkout*/testing/trunk/rhts/tests/sandbox/rpm/rpm-build/run-rpmbuild-on-tarball.sh?content-type=text%2Fplain&rev=70

fails on one machine with:
tar-1.15.91-1
rpm-build-4.4.2-32

passes on another machine with:
tar-1.15.90-2
rpm-build-4.4.2-31

-- Additional comment from pvrabec@redhat.com on 2006-09-22 12:57 EST --
This problem depends on bz #206979. It's still not clear whether we use 
tar-1.15.91 or tar-1.15.1 in RHEL-5.

Apparently also seen on RHEL4
Comment 1 Panu Matilainen 2007-08-20 07:38:50 EDT
RHEL 4 has tar 1.14 so not affected AFAICT.

Note You need to log in before you can comment on or make changes to this bug.