Bug 207756 - Screensaver locks up the GUI and you cannot recover
Screensaver locks up the GUI and you cannot recover
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 17:07 EDT by Ian Laurie
Modified: 2008-03-18 14:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:34:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Laurie 2006-09-22 17:07:11 EDT
Description of problem:
When the screensaver is activated in a root session, you cannot recover the
session by using the mouse of the keyboard.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.3-3.fc5

How reproducible:
Not certain.  The problem seems to happen always after a fresh boot but after
stuffing about with the settings it seems to fix itself until the next boot. 
However I cannot be certain about this.

Steps to Reproduce:
1. Log in as root.
2. Leave the system alone and allow the screensaver to activate.
3.
  
Actual results:
Screensaver will lock up a root session.

Expected results:
I always thought the screensaver never activated for root ????
However if it does, it should free up on a keyboard or mouse event.

Additional info:
If you ssh in you can free up the GUI on the console by killing the screensaver
process remotely.

Also, this problem started happening only recently.  The original CD set did not
exhibit this behavior (at least I never noticed it).

I don't know [yet] if this problem happens to non-root users.

If the screensaver should not be working for root anyway, then this bug has
security implications, because the screensaver **is** trying to work for root.
Comment 1 clifford snow 2006-10-16 18:21:25 EDT
I occasionnally see similar problems.  They screensaver locks up and the only
way around is to turn off the laptop.  However, this occurs when logged in as a
normal user.  I'm going to allow ssh in to see if I can kill it remotely next
time it happens.
Comment 2 clifford snow 2006-11-02 14:09:18 EST
It turns out that my lockups are not the result of the screensaver.  From the
last entry of /var/log/messages, just before the lockup, I'm getting an error
related to module bcm43xxx, a wireless driver for broadcom wifi devices.

BTW - you can not ssh in, the entire system is locked.
Comment 3 Ray Strode [halfline] 2008-03-18 14:34:01 EDT
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.