Bug 207765 - system-config-services exits with No suche file or directory '/etc/init.d/4'
system-config-services exits with No suche file or directory '/etc/init.d/4'
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-services (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 18:43 EDT by Andy Howell
Modified: 2008-08-22 06:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-22 06:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Howell 2006-09-22 18:43:36 EDT
Description of problem:

system-config-services exits with:

/usr/sbin/system-config-services:197: DeprecationWarning:
  self.btnStart = self.tbrSave.append_item(_("Start"), _("Start"), None, icon,
self.on_btnStart_clicked, None)
/usr/sbin/system-config-services:201: DeprecationWarning:
  self.btnStop = self.tbrSave.append_item(_("Stop"), _("Stop"), None, icon,
self.on_btnStop_clicked, None)
/usr/sbin/system-config-services:205: DeprecationWarning:
  self.btnRestart = self.tbrSave.append_item(_("Restart"), _("Restart"), None,
icon, self.on_btnRestart_clicked, None)
/usr/sbin/system-config-services:207: DeprecationWarning:
  self.tbrSave.insert_space(3)
/usr/sbin/system-config-services:211: DeprecationWarning:
  self.btnSave = self.tbrSave.append_item(_("_Save"), _("Save"), None, icon,
self.on_mnuSave_clicked, None)
/usr/sbin/system-config-services:216: DeprecationWarning:
  self.btnRevert = self.tbrSave.append_item(_("_Revert"), _("Revert"), None,
icon, self.on_mnuRevert_clicked, None)
/etc/init.d/4 [Errno 2] No such file or directory: '/etc/init.d/4'
Traceback (most recent call last):
  File "/usr/sbin/system-config-services", line 683, in ?
    main()
  File "/usr/sbin/system-config-services", line 667, in main
    Gui()
  File "/usr/sbin/system-config-services", line 254, in __init__
    self.populateList()
  File "/usr/sbin/system-config-services", line 324, in populateList
    self.clstServices.append_row((servicename, ""),
int(self.dict_services[servicename][0][int(self.editing_runlevel)]))
IndexError: list index out of range


Version-Release number of selected component (if applicable):

system-config-services-0.8.15

How reproducible:

start from command line to see errors.

I ran rpm -V system-config-service. No errors.

Tried strace to see what fils it was using, but that didn't help. Too many
files. Can't see there its getting the /etc/init.d/4 from. There is no such file.
Comment 3 Phil Knirsch 2008-08-22 06:35:26 EDT
This request was evaluated by Red Hat Engineering for inclusion in a Red
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat Enterprise
Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in
response to customer and partner requirements, Red Hat takes a conservative
approach when evaluating enhancements for inclusion in maintenance updates
for currently deployed products. The primary objectives of update releases
are to enable new hardware platform support and to resolve critical
defects.

However, Red Hat will further review this request for potential inclusion
in future major releases of Red Hat Enterprise Linux.

Note You need to log in before you can comment on or make changes to this bug.