Bug 207767 - PATCH: link libOSMesa against -lselinux
PATCH: link libOSMesa against -lselinux
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 19:00 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 18:16:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2006-09-22 19:00:55 EDT
Description of problem:

I believe this needs to be added to the selinux-awareness patch in mesa:

Index: mesa-6.5.1-selinux-awareness.patch
===================================================================
RCS file: /cvs/dist/rpms/mesa/devel/mesa-6.5.1-selinux-awareness.patch,v
retrieving revision 1.3
diff -r1.3 mesa-6.5.1-selinux-awareness.patch
251a252,281
> --- Mesa-6.5.1/configs/linux-osmesa.selinux-awareness 2006-09-22
16:44:20.000000000 -0600
> +++ Mesa-6.5.1/configs/linux-osmesa   2006-09-22 16:56:48.000000000 -0600
> @@ -20,6 +20,6 @@
>
>
>  # Dependencies
> -OSMESA_LIB_DEPS = -lm -lpthread
> +OSMESA_LIB_DEPS = -lm -lpthread -lselinux
>  GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
>  APP_LIB_DEPS = -lOSMesa -lGLU
> --- Mesa-6.5.1/configs/linux-osmesa16.selinux-awareness       2006-09-22
16:44:20.000000000 -0600
> +++ Mesa-6.5.1/configs/linux-osmesa16 2006-09-22 16:57:06.000000000 -0600
> @@ -23,6 +23,6 @@
>
>
>  # Dependencies
> -OSMESA_LIB_DEPS = -lm -lpthread
> +OSMESA_LIB_DEPS = -lm -lpthread -lselinux
>  GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
>  APP_LIB_DEPS = -lOSMesa16
> --- Mesa-6.5.1/configs/linux-osmesa32.selinux-awareness       2006-09-22
16:44:20.000000000 -0600
> +++ Mesa-6.5.1/configs/linux-osmesa32 2006-09-22 16:57:11.000000000 -0600
> @@ -23,6 +23,6 @@
>
>
>  # Dependencies
> -OSMESA_LIB_DEPS = -lm -lpthread
> +OSMESA_LIB_DEPS = -lm -lpthread -lselinux
>  GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
>  APP_LIB_DEPS = -lOSMesa32

Have not tested this, but I get:

usr/lib64/libOSMesa.so: undefined reference to `is_selinux_enabled'
/usr/lib64/libOSMesa.so: undefined reference to `security_get_boolean_active'
/usr/lib64/libOSMesa.so: undefined reference to `security_get_boolean_pending'

when linking again libOSMesa.so, and it looks like you added -lselinux to the
dri library.
Comment 1 Adam Jackson 2006-09-25 18:16:24 EDT
fixed in 6.5.1-4, thanks!

Note You need to log in before you can comment on or make changes to this bug.