Bug 207840 - Xen guest's networking default mtu size is 0
Xen guest's networking default mtu size is 0
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dhcp (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Cantrell
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-24 08:05 EDT by Chris Evich
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-13 13:50:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test results (4.67 KB, text/plain)
2006-09-27 12:07 EDT, Chris Evich
no flags Details
strace from first run with mtu set to 0 beforehand (398.62 KB, text/plain)
2006-09-27 12:08 EDT, Chris Evich
no flags Details
strace from first run with mtu set to 1500 beforehand (524.21 KB, text/plain)
2006-09-27 12:09 EDT, Chris Evich
no flags Details

  None (edit)
Description Chris Evich 2006-09-24 08:05:44 EDT
Version-Release number of selected component (if applicable):
RHEL5 B1

How reproducible:
Easy

Steps to Reproduce:
1. Create guest
2. Start guest's networking
  
Actual results:
Repeated "printk: 2 messages suppressed" on console and "kernel: Received packet
too big for MTU (180 > 0)" in /var/log/messages.  ifconfig eth0 shows the problem:
eth0      Link encap:Ethernet  HWaddr 00:16:3E:0E:CE:3A
          UP BROADCAST RUNNING MULTICAST  MTU:0  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000


Expected results:
eth0      Link encap:Ethernet  HWaddr 00:16:3E:0E:CE:3A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000


Additional info:
running 'ifconfig eth0 mtu 1500' works around the problem until you restart
networking or reboot the guest.
Comment 1 Chris Evich 2006-09-25 21:35:01 EDT
note:  This seems to only affect interfaces brought up with dhcp.  Static
addresses work fine
Comment 2 Herbert Xu 2006-09-27 06:28:56 EDT
Please run strace on the DHCP client to find out what causes it to set the MTU
to zero.
Comment 3 Chris Evich 2006-09-27 12:06:32 EDT
Attaching results and traces from two runs.  One with setting mtu 0 before the
test and one with setting mtu 1500 before the test.
Comment 4 Chris Evich 2006-09-27 12:07:19 EDT
Created attachment 137226 [details]
test results
Comment 5 Chris Evich 2006-09-27 12:08:17 EDT
Created attachment 137227 [details]
strace from first run with mtu set to 0 beforehand
Comment 6 Chris Evich 2006-09-27 12:09:02 EDT
Created attachment 137228 [details]
strace from first run with mtu set to 1500 beforehand
Comment 7 Herbert Xu 2006-09-28 04:58:31 EDT
The 2nd strace clearly shows that the DHCP client reckons the server is
requesting for a zero MTU and it therefore sets the MTU to it.  So the problem
is either with your client or your server.  Please double-check your configuration.
Comment 8 Chris Evich 2006-09-28 09:24:36 EDT
The DHCP "server" is a little netgear wireless router (though the host system
for this guest is connected via cat5).  The host system (and all other systems)
sucessfully gets an IP from this DHCP "server" and doesn't have this problem. 
Only the xen guests have this problem.  Could it have anything to do with
bridging do you think?  The host has 3 NIC's, all on the same network, and each
has it's own bridge.  Xen guests are tied to the second bridge.  

# brctl show
bridge name     bridge id               STP enabled     interfaces
xenbr0          8000.feffffffffff       no              peth0
                                                        vif0.0
xenbr1          8000.feffffffffff       no              vif5.0
                                                        vif4.0
                                                        vif3.0
                                                        peth1
                                                        vif0.1
xenbr2          8000.feffffffffff       no              peth2
                                                        vif0.2

# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:BA:3F:FD:CC
          inet addr:192.168.0.16  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::250:baff:fe3f:fdcc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:216695 errors:0 dropped:0 overruns:0 frame:0
          TX packets:117393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:21873163 (20.8 MiB)  TX bytes:255196671 (243.3 MiB)

eth1      Link encap:Ethernet  HWaddr 00:0D:88:1D:55:B9
          inet addr:192.168.0.17  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::20d:88ff:fe1d:55b9/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:117650 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1027 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11174319 (10.6 MiB)  TX bytes:43350 (42.3 KiB)

eth2      Link encap:Ethernet  HWaddr 00:90:27:CA:27:87
          inet addr:192.168.0.18  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::290:27ff:feca:2787/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:92861 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1026 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11455061 (10.9 MiB)  TX bytes:43308 (42.2 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:68 errors:0 dropped:0 overruns:0 frame:0
          TX packets:68 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5708 (5.5 KiB)  TX bytes:5708 (5.5 KiB)

peth0     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:217587 errors:0 dropped:0 overruns:0 frame:0
          TX packets:246370 errors:0 dropped:0 overruns:20 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21952665 (20.9 MiB)  TX bytes:263784453 (251.5 MiB)
          Interrupt:17 Base address:0x6000

peth1     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:326212 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136546 errors:0 dropped:0 overruns:2 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:269921358 (257.4 MiB)  TX bytes:16043649 (15.3 MiB)
          Interrupt:18 Base address:0xa000

peth2     Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:94848 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11637424 (11.0 MiB)  TX bytes:44668 (43.6 KiB)

vif0.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:117455 errors:0 dropped:0 overruns:0 frame:0
          TX packets:216755 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:255203883 (243.3 MiB)  TX bytes:21877123 (20.8 MiB)

vif0.1    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:1027 errors:0 dropped:0 overruns:0 frame:0
          TX packets:117650 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:43350 (42.3 KiB)  TX bytes:11174319 (10.6 MiB)

vif0.2    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:1026 errors:0 dropped:0 overruns:0 frame:0
          TX packets:92861 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:43308 (42.2 KiB)  TX bytes:11455061 (10.9 MiB)

vif3.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:40173 errors:0 dropped:0 overruns:0 frame:0
          TX packets:148795 errors:0 dropped:19 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4317973 (4.1 MiB)  TX bytes:88043483 (83.9 MiB)

vif4.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:51115 errors:0 dropped:0 overruns:0 frame:0
          TX packets:142475 errors:0 dropped:39 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:5495923 (5.2 MiB)  TX bytes:83973543 (80.0 MiB)

vif5.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:73601 errors:0 dropped:0 overruns:0 frame:0
          TX packets:168238 errors:0 dropped:2357 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:8568204 (8.1 MiB)  TX bytes:109287501 (104.2 MiB)

xenbr0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:83317 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6587793 (6.2 MiB)  TX bytes:0 (0.0 b)

xenbr1    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:83310 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6580921 (6.2 MiB)  TX bytes:0 (0.0 b)

xenbr2    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING NOARP  MTU:1500  Metric:1
          RX packets:83301 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6590879 (6.2 MiB)  TX bytes:0 (0.0 b)

Comment 9 Herbert Xu 2006-09-29 00:58:03 EDT
Nobody else is having this MTU problem with the Xen bridge setup.  So I suggest
that you try a different DHCP server to eliminate it from the enquiry.
Comment 10 Chris Evich 2006-09-29 10:13:09 EDT
The bizarre thing I just realized, is the guest gets an IP from DHCP no-problem,
when it's doing the install.  It's only after the install when it boots up
normally that it has trouble.   I can try setting up a real DHCP server though
and see what happens.
Comment 11 Chris Evich 2006-10-04 09:03:32 EDT
Confirmed, this appears to somehow be a problem caused by my netgear router's
built-in DHCP server.  I set up a DHCP server as another Xen guest on the box
and everything works fine now.  

However, the discovery of the original problem beggs asking: Should dhclient
_ever _ have reason to set the MTU size to 0?  If not, then can we move this bug
over to the dhclient component? If not, please go ahead and close this.  Thanks.
Comment 12 Herbert Xu 2006-10-04 09:31:20 EDT
Yes, the dhcp client should probably flag this as an error rather than setting
the MTU to 0.  But this is more of a quality of implementation issue rather than
an outright bug.  Thanks for checking.
Comment 13 David Cantrell 2007-09-13 13:50:31 EDT
This kind of improvement should be addressed in Fedora rather than RHEL.  Given
that it's caused by external factor (netgear's dhcp server), I don't think it's
suitable to fix this in a RHEL 5 update release.

Note You need to log in before you can comment on or make changes to this bug.