Bug 207841 - Icon "dx.xpm" needs transparent background
Icon "dx.xpm" needs transparent background
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dx (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-24 09:14 EDT by Joachim Frieben
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-07 12:48:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Icon "dx.xpm" with transparent background (7.79 KB, text/plain)
2006-09-24 09:15 EDT, Joachim Frieben
no flags Details
Patch to set background of "icon50.xpm" to transparent (486 bytes, text/plain)
2006-09-28 09:27 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2006-09-24 09:14:18 EDT
Description of problem:
The "OpenDX" icon "dx.xpm" [/usr/share/pixmaps/dx.xpm] used in the
"GNOME" panel has an opaque gray background which does not fit the
default "Fedora" color scheme well, not even to speak about other
"GTK" themes.

Version-Release number of selected component (if applicable):
dx-4.4.4-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. Login to "GNOME" session.
2. Open "Graphics" menu.
  
Actual results:
There an entry for "OpenDX" but the icon is detached from the
menu button as a grey square containing the logo.

Expected results:
The "OpenDX" icon should have a transparent background.

Additional info:
The wanted modification is obtained by changing the last color
entry in the pixmap file to "none". I have attached the icon with
a transparent background instead of a grey one.
Comment 1 Joachim Frieben 2006-09-24 09:15:37 EDT
Created attachment 137016 [details]
Icon "dx.xpm" with transparent background
Comment 2 Dominik 'Rathann' Mierzejewski 2006-09-27 14:23:16 EDT
Thanks for the report. I've forwarded it to opendx2-dev mailing list. I'll
include the transparent icon when upstream ships it.
Comment 3 Joachim Frieben 2006-09-28 08:47:12 EDT
It's not an upstream issue since it's "Fedora Extras" specific. Look at
the spec file "dx.spec". Here you install "icon50.xpm" as "dx.xpm" in
the "pixmaps" directory:

  "install -Dp -m644 src/uipp/ui/icon50.xpm \
   $RPM_BUILD_ROOT%{_datadir}/pixmaps/dx.xpm"

So, "dx.xpm" is not part of the upstream package. The first idea that
comes one's mind is to make the background of "icon50.xpm" transparent
which is then inherited by "dx.xpm". However, "icon50.xpm" is also used
by the window manager and in the window list, and here, the transparent
background is displayed as a black one which is even worse than grey.
For this reason, upstream "icon50.xpm" will certainly not be modified
to have a transparent background. Icon "dx.xpm" which I had submitted
in comment #1 should be included as an extra source file and be
installed instead of "icon50.xpm" in the "pixmaps" directory.
Comment 4 Joachim Frieben 2006-09-28 09:27:42 EDT
Created attachment 137312 [details]
Patch to set background of "icon50.xpm" to transparent
Comment 5 Joachim Frieben 2006-09-28 09:30:50 EDT
Submitted bug 208406 to deal with background issue when an "XPM" icon
has transparent background (color "none") but is rendered with a black
background in certain "GTK2" widgets.
Comment 6 Dominik 'Rathann' Mierzejewski 2006-11-01 09:59:35 EST
(In reply to comment #3)
> It's not an upstream issue since it's "Fedora Extras" specific. Look at
> the spec file "dx.spec". Here you install "icon50.xpm" as "dx.xpm" in
> the "pixmaps" directory:
> 
>   "install -Dp -m644 src/uipp/ui/icon50.xpm \
>    $RPM_BUILD_ROOT%{_datadir}/pixmaps/dx.xpm"
> 
> So, "dx.xpm" is not part of the upstream package.

On the contrary, it is. I'm just copying it from the unpacked tarball to a
proper Fedora location. Anyway, I think it's too trivial a problem to make a new
release of the package. If upstream doesn't ship a transparent icon with the
next release, I'll fix this myself.
Comment 7 Joachim Frieben 2006-11-01 10:35:44 EST
(In reply to comment #6)
> On the contrary, it is. I'm just copying it from the unpacked tarball to a
> proper Fedora location. Anyway, I think it's too trivial a problem to make a new
> release of the package. If upstream doesn't ship a transparent icon with the
> next release, I'll fix this myself.

There seems to be a misunderstanding here. There is -no- "dx.xpm" icon included
in the "OpenDX" source distribution. No other desktop icon is included in the
source distribution either. There a two and only two "xpm" pixmaps in the
source tree:

  ./src/uipp/ui/icon50.xpm
  ./src/uipp/ui/logo.xpm

The statement of comment #6 is thus invalid. I repeat that patching "icon50.xpm"
is not a valid approach, because the way how it is loaded makes its background
appear black in some "GTK" widgets used in the window list or the "metacity"
application icon, see:

  http://www.opendx.org/bugs/view.php?id=227

I suggest to add a suitably modified "dx.xpm" pixmap [obtained by extracting
"icon50.xpm" from the source package, renaming it to "dx.xpm", and setting
the background color to "none"] as a separate package source until the issue
is settled upstream. Given the slow release cycle of the "OpenDX" package,
waiting for the next upstream release is not a viable approach. This is an
easy fix which takes 5 minutes to accomplish.
Comment 8 Dominik 'Rathann' Mierzejewski 2006-11-01 12:42:00 EST
(In reply to comment #7)
> (In reply to comment #6)
> > On the contrary, it is. I'm just copying it from the unpacked tarball to
> > a proper Fedora location. Anyway, I think it's too trivial a problem to
> > make a new release of the package. If upstream doesn't ship a transparent
> > icon with the next release, I'll fix this myself.
> 
> There seems to be a misunderstanding here.

Obviously.

> There is -no- "dx.xpm" icon included in the "OpenDX" source distribution.
> No other desktop icon is included in the source distribution either.
> There a two and only two "xpm" pixmaps in the source tree:
> 
>   ./src/uipp/ui/icon50.xpm
>   ./src/uipp/ui/logo.xpm
> 
> The statement of comment #6 is thus invalid.

No. Let me repeat: I am _copying_ ./src/uipp/ui/icon50.xpm as dx.xpm.

[...]
> I suggest to add a suitably modified "dx.xpm" pixmap [obtained by extracting
> "icon50.xpm" from the source package, renaming it to "dx.xpm", and setting
> the background color to "none"] as a separate package source until the issue
> is settled upstream. Given the slow release cycle of the "OpenDX" package,
> waiting for the next upstream release is not a viable approach. This is an
> easy fix which takes 5 minutes to accomplish.

And that is what I will do if there is a new release or a non-trivial bug to be
fixed. It's unreasonable to ask users to download ~12.7MB package just for this. 
Comment 9 Joachim Frieben 2006-11-02 08:44:37 EST
(In reply to comment #8)
>No. Let me repeat: I am _copying_ ./src/uipp/ui/icon50.xpm as dx.xpm.

Ah, this sounds quite different now and corresponds exactly to my
comment #3. I do agree that there is no need to push an internal
"FE" update only to fix this issue. However, you wrote:

> If upstream doesn't ship a transparent icon with the
> next release, I'll fix this myself
  ^^^^

which sugessted that you planned to wait for the next *upstream*
release. Please try to be more precise in your comments. Thanks.
Comment 10 Fedora Update System 2007-07-05 15:13:16 EDT
dx-4.4.4-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2007-07-16 12:58:03 EDT
dx-4.4.4-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.