Bug 207859 - Alsa sound not detecting external jacks
Alsa sound not detecting external jacks
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-24 18:04 EDT by paulp
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 12:16:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of system-config-soundcard (7.63 KB, text/plain)
2006-10-15 23:02 EDT, paulp
no flags Details

  None (edit)
Description paulp 2006-09-24 18:04:56 EDT
Description of problem:
Alsa driver compiles to provide sound through system speaker but the speaker
does not turn off when headphones are plugged into the jack port or the external
speaker ports...

Version-Release number of selected component (if applicable):
kernel-2.6.17-1.2187_FC5
alsa-lib-devel-1.0.11-4.rc2
alsa-lib-1.0.11-4.rc2
alsa-utils-1.0.11-4.rc2
and 
alsa-driver-1.0.12rc1.tar.bz2

How reproducible:
constant

Steps to Reproduce:
1.Sytem -> Preferences -> Sound -> play one of the system sounds though the
system speaker
2. Plug in headphones or external speakers and play te sound again - still comes
out system speakers only (NOT also...)
3.
  
Actual results:


Expected results:
Jack sensing to disable system speaker when an external device is plugged in

Additional info:
The pc is an HP 7600dc with a Intel 945G motherboard with
integrated Realtek ALC260 sound chip.
Running Sytem -> Administration -> Soundcard Detection, brings up the Audio
Devices screen. This shows:
Vendor: Intel
Model: Corporation 82801G (IHC7 Family) High Definition Audio Controller
Module: snd-hda-intel
Default PCM device: ALC260 Analog
Comment 1 Martin Stransky 2006-10-03 07:08:27 EDT
Could you check the latest drivers/packages? from
http://people.redhat.com/stransky/alsa/
Comment 2 paulp 2006-10-03 20:37:57 EDT
installed alsa-driver-1.0.13.tar.bz2 without problem and rebooted machine but no
change to issue...

downloaded alsa-lib-1.0.13-1.src.rpm and alsa-utils-1.0.13-1.src.rpm
ran 'rpmbuild --rebuild alsa-lib-1.0.13-1.src.rpm' which appeared to complete OK.
Tried to run 'rpmbuild --rebuild alsa-utils-1.0.13-1.src.rpm' but is complained
that it needed alsa-lib-devel >= 1.0.13-1

Found the rpm packages created by alsa-lib in /usr/src/redhat/RPMS/i386/, but
when I try to install them I get the following errors:

#rpm -Uvh /usr/src/redhat/RPMS/i386/alsa-lib-1.0.13-1.i386.rpm
error: Failed dependencies:
        alsa-lib = 1.0.11 is needed by (installed) alsa-lib-devel-1.0.11-4.rc2.i386

#rpm -Uvh /usr/src/redhat/RPMS/i386/alsa-lib-devel-1.0.13-1.i386.rpm
error: Failed dependencies:
        alsa-lib = 1.0.13 is needed by alsa-lib-devel-1.0.13-1.i386

# rpm -Uvh /usr/src/redhat/RPMS/i386/alsa-lib-debuginfo-1.0.13-1.i386.rpm
Preparing...                ########################################### [100%]
   1:alsa-lib-debuginfo     ########################################### [100%]


Sorry - not sure what to do next...
Comment 3 Martin Stransky 2006-10-13 11:38:41 EDT
Could you please run system-config-soundcard and attach an updated
/root/scsound.log?
Comment 4 paulp 2006-10-15 23:02:22 EDT
Created attachment 138544 [details]
Output of system-config-soundcard
Comment 5 paulp 2006-10-15 23:04:07 EDT
Here is the scsound.log file as requested.
Comment 6 paulp 2006-11-19 19:33:42 EST
After re-reading the above bug, I notice that I didn't mention that there is no
sound coming out of the headphones when they are plugged in either...
So the issue is with the driver not detecting/enabling/supporting the jacks
rather than just sensing when something has been plugged into them and disabling
the system speaker....
Comment 7 paulp 2007-02-20 21:23:46 EST
I have abandoned that pc now and installed fc6 on an AMD chipset pc - all 
working fine - SO LONG INTEL !!
Comment 8 Martin Stransky 2007-08-15 12:16:37 EDT
haha, okay :)

Note You need to log in before you can comment on or make changes to this bug.