Bug 207883 - kernel-xen 2.6.18-1.2689.fc6 - X fails to start completely.
kernel-xen 2.6.18-1.2689.fc6 - X fails to start completely.
Status: CLOSED DUPLICATE of bug 207432
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 01:18 EDT by Naoki
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 08:05:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Naoki 2006-09-25 01:18:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-GB; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Description of problem:
kernel-xen-2.6.18-1.2689.fc6 boots but X fails.
I get graphical boot ok, I get "Starting firstboot..".   Then it flips to what should be gnome starting up but I only see the cursor for probably half
a second then the screen goes blank and I can't break out of X and need to
cycle the box.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Boot to kernel-xen
2. Wait for graphical boot to compete.
3. The cursor is displayed for a very short time, less thana second, then nothing.

Actual Results:
Screen goes blank, monitor reports "no signal".  I then need to power cycle the box.

Expected Results:
Gnome start up followed by normal use.

Additional info:
From fedora-devel list :

"I had the same problem. I assumed it was my CPU (Centrino) or my
graphics card (R300)."
Comment 1 Stephen Tweedie 2006-09-25 04:28:39 EDT
Just to check, does the non-xen kernel work OK?
Comment 2 Naoki 2006-09-25 04:47:15 EDT
Sorry Stephen I forgot to add that.  Yes the non-xen kernel works as expected
and is stable. 

I fear this may duplicate a bug I have already opened with similar symptoms :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207432

Could this also be related I wonder? :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207254
Comment 3 Stephen Tweedie 2006-09-25 06:50:54 EDT
I've no idea if #207432 is related.  There is a change_page_attr() bug being
worked on, but there's no information in this report to give us any idea if it's
the same problem.

Is there any extra information you can provide?  /var/log/xorg* logs, kernel
messages from /var/log/messages etc. after X dies?  As long as it's only X, not
the whole kernel, dying, then the log messages should all persist until reboot.
 (You may want to reboot into runlevel 3 to avoid the new boot overwriting the X
logs.)

Thanks!
Comment 4 Naoki 2006-09-25 07:07:54 EDT
About the best I can offer right now this from 'messages' :

Sep 25 11:06:13 localhost kernel: [drm] Initialized drm 1.0.1 20051102 
Sep 25 11:06:13 localhost kernel: ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16
(level, low) -> IRQ 16
Sep 25 11:06:13 localhost kernel: [drm] Initialized i915 1.5.0 20060119 on minor 0
Sep 25 11:06:15 localhost gdm[2833]: GDM restarting ...
Sep 25 11:06:15 localhost kernel: Unable to handle kernel paging request at
ffff880001225c60 RIP:
Sep 25 11:06:15 localhost kernel:  [<ffffffff80250c4d>]
__change_page_attr+0xa1e/0xa8e
Sep 25 11:06:15 localhost kernel: PGD 1023067 PUD 1024067 PMD 102e067 PTE 759ac065
Sep 25 11:06:15 localhost kernel: Oops: 0003 [1] SMP
Sep 25 11:06:15 localhost kernel: last sysfs file: /class/drm/card0/dev
Sep 25 11:06:15 localhost kernel: CPU 1
Sep 25 11:06:15 localhost kernel: Modules linked in: i915 drm bridge netloop
netbk blkbk autofs4 sunrpc ip_conntrack_ftp ip_conntrack_netbios_ns ipt_REJECT
xt_state ip_conntrack nfnetlink xt_tcpudp iptable_filter ip_tables x_tables
acpi_cpufreq video sbs i2c_ec button battery asus_acpi ac ipv6 parport_pc lp
parport snd_intel8x0 snd_ac97_codec snd_ac97_bus snd_seq_dummy snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm sg
snd_timer snd soundcore i2c_i801 ide_cd cdrom snd_page_alloc i2c_core pcspkr
intel_rng shpchp tg3 serio_raw dm_snapshot dm_zero dm_mirror dm_mod ata_piix
libata sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
Sep 25 11:06:15 localhost kernel: Pid: 1304, comm: Xorg Not tainted
2.6.18-1.2689.fc6xen #1
Sep 25 11:06:15 localhost kernel: RIP: e030:[<ffffffff80250c4d>] 
[<ffffffff80250c4d>] __change_page_attr+0xa1e/0xa8e
Sep 25 11:06:15 localhost kernel: RSP: e02b:ffff8800724ebb98  EFLAGS: 00010282
Sep 25 11:06:15 localhost kernel: RAX: 80000000718000e3 RBX: ffff8800013b2ff8
RCX: 0000000000000023
Sep 25 11:06:15 localhost kernel: RDX: ffff880001225c60 RSI: 00000000000013b2
RDI: 0000000000000067
Sep 25 11:06:15 localhost kernel: RBP: ffff8800719ff000 R08: ffff880001426ef0
R09: 0000000000000000
Sep 25 11:06:15 localhost kernel: R10: 8000000000000063 R11: 80000000000000e3
R12: 00000000719ff000
Sep 25 11:06:15 localhost kernel: R13: 0000000000000c60 R14: 0000000000000008
R15: ffffffff80201880
Sep 25 11:06:15 localhost kernel: FS:  00002aaaaaac1a80(0000)
GS:ffffffff8059d080(0000) knlGS:0000000000000000
Sep 25 11:06:15 localhost kernel: CS:  e033 DS: 0000 ES: 0000
Sep 25 11:06:15 localhost kernel: Process Xorg (pid: 1304, threadinfo
ffff8800724ea000, task ffff8800747bb820)
Sep 25 11:06:15 localhost kernel: Stack:  0000000000000003  ffff8800719ff000 
ffffffff804c4770  ffffffff80262239
Sep 25 11:06:15 localhost kernel:  ffffffff804c4770  ffffffff80261cd5 
0000000000000000  ffff8800719ff000
Sep 25 11:06:15 localhost kernel:  00000000000719ff  00000000719ff000
Sep 25 11:06:15 localhost kernel: Call Trace:
Sep 25 11:06:15 localhost kernel:  [<ffffffff80262239>] _spin_unlock_irq+0x9/0x10
Sep 25 11:06:15 localhost kernel:  [<ffffffff80261cd5>]
__down_write_nested+0x34/0x96
Sep 25 11:06:15 localhost kernel:  [<ffffffff8027a42a>]
change_page_attr_addr+0x7b/0x12c
Sep 25 11:06:15 localhost kernel:  [<ffffffff803878aa>]
agp_generic_destroy_page+0x4e/0x7a
Sep 25 11:06:15 localhost kernel:  [<ffffffff8038778a>] agp_free_memory+0x65/0x90
Sep 25 11:06:15 localhost kernel:  [<ffffffff803869a1>] agp_release+0x9f/0x18a
Sep 25 11:06:15 localhost kernel:  [<ffffffff8021296e>] __fput+0xbf/0x1aa
Sep 25 11:06:15 localhost kernel:  [<ffffffff80223f43>] filp_close+0x5c/0x64
Sep 25 11:06:15 localhost kernel:  [<ffffffff80239c2e>] put_files_struct+0x6c/0xc4
Sep 25 11:06:15 localhost kernel:  [<ffffffff80215591>] do_exit+0x2d0/0x8a3
Sep 25 11:06:15 localhost kernel:  [<ffffffff80248c6f>] debug_mutex_init+0x0/0xd
Sep 25 11:06:15 localhost kernel:  [<ffffffff8022b4f4>]
get_signal_to_deliver+0x42d/0x45d
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025b687>] do_notify_resume+0x9c/0x7c1
Sep 25 11:06:15 localhost kernel:  [<ffffffff8029948d>]
autoremove_wake_function+0x0/0x2e
Sep 25 11:06:15 localhost kernel:  [<ffffffff80234608>] do_setitimer+0x17f/0x4bd
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025db09>] sysret_signal+0x38/0x43
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025dde9>] ptregscall_common+0x3d/0x64
Sep 25 11:06:15 localhost kernel:
Sep 25 11:06:15 localhost kernel:

Sep 25 11:06:15 localhost kernel:
Sep 25 11:06:15 localhost kernel: Code: 48 89 02 31 c0 eb 5a 48 89 da 48 b8 ff
ff ff 7f ff ff ff ff
Sep 25 11:06:15 localhost kernel: RIP  [<ffffffff80250c4d>]
__change_page_attr+0xa1e/0xa8e
Sep 25 11:06:15 localhost kernel:  RSP <ffff8800724ebb98>
Sep 25 11:06:15 localhost kernel: CR2: ffff880001225c60
Sep 25 11:06:15 localhost kernel:  <3>BUG: sleeping function called from invalid
context at kernel/rwsem.c:20
Sep 25 11:06:15 localhost kernel: in_atomic():0, irqs_disabled():1
Sep 25 11:06:15 localhost kernel:
Sep 25 11:06:15 localhost kernel: Call Trace:
Sep 25 11:06:15 localhost kernel:  [<ffffffff8029b612>] down_read+0x15/0x23
Sep 25 11:06:15 localhost kernel:  [<ffffffff80293bbc>]
blocking_notifier_call_chain+0x13/0x36
Sep 25 11:06:15 localhost kernel:  [<ffffffff802152e0>] do_exit+0x1f/0x8a3
Sep 25 11:06:15 localhost kernel:  [<ffffffff80264def>] do_page_fault+0x1130/0x11dc
Sep 25 11:06:15 localhost kernel:  [<ffffffff80262356>]
_spin_unlock_irqrestore+0x9/0x19
Sep 25 11:06:15 localhost kernel:  [<ffffffff80207138>] kmem_cache_free+0x77/0xca
Sep 25 11:06:15 localhost kernel:  [<ffffffff8032f7f7>]
radix_tree_delete+0x150/0x187
Sep 25 11:06:15 localhost kernel:  [<ffffffff802119ad>] do_select+0x445/0x462
Sep 25 11:06:15 localhost kernel:  [<ffffffff80201880>] init_level4_pgt+0x880/0x1000
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025e0fb>] error_exit+0x0/0x6e
Sep 25 11:06:15 localhost kernel:  [<ffffffff80201880>] init_level4_pgt+0x880/0x1000
Sep 25 11:06:15 localhost kernel:  [<ffffffff80250c4d>]
__change_page_attr+0xa1e/0xa8e
Sep 25 11:06:15 localhost kernel:  [<ffffffff802622d3>] _spin_lock_irqsave+0x1a/0x23
Sep 25 11:06:15 localhost kernel:  [<ffffffff80262239>] _spin_unlock_irq+0x9/0x10
Sep 25 11:06:15 localhost kernel:  [<ffffffff80261cd5>]
__down_write_nested+0x34/0x96
Sep 25 11:06:15 localhost kernel:  [<ffffffff8027a42a>]
change_page_attr_addr+0x7b/0x12c
Sep 25 11:06:15 localhost kernel:  [<ffffffff803878aa>]
agp_generic_destroy_page+0x4e/0x7a
Sep 25 11:06:15 localhost kernel:  [<ffffffff8038778a>] agp_free_memory+0x65/0x90
Sep 25 11:06:15 localhost kernel:  [<ffffffff803869a1>] agp_release+0x9f/0x18a
Sep 25 11:06:15 localhost kernel:  [<ffffffff8021296e>] __fput+0xbf/0x1aa
Sep 25 11:06:15 localhost kernel:  [<ffffffff80223f43>] filp_close+0x5c/0x64
Sep 25 11:06:15 localhost kernel:  [<ffffffff80239c2e>] put_files_struct+0x6c/0xc4
Sep 25 11:06:15 localhost kernel:  [<ffffffff80215591>] do_exit+0x2d0/0x8a3
Sep 25 11:06:15 localhost kernel:  [<ffffffff80248c6f>] debug_mutex_init+0x0/0xd
Sep 25 11:06:15 localhost kernel:  [<ffffffff8022b4f4>]
get_signal_to_deliver+0x42d/0x45d
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025b687>] do_notify_resume+0x9c/0x7c1
Sep 25 11:06:15 localhost kernel:  [<ffffffff8029948d>]
autoremove_wake_function+0x0/0x2e
Sep 25 11:06:15 localhost kernel:  [<ffffffff80234608>] do_setitimer+0x17f/0x4bd
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025db09>] sysret_signal+0x38/0x43
Sep 25 11:06:15 localhost kernel:  [<ffffffff8025dde9>] ptregscall_common+0x3d/0x64
Sep 25 11:06:15 localhost kernel:

Sep 25 11:06:15 localhost kernel:
Sep 25 11:06:15 localhost kernel: Fixing recursive fault but reboot is needed!
Sep 25 11:06:25 localhost gdm[2833]: no suitable security token driver could be
found
Sep 25 11:06:26 localhost gdm[2922]: Display :0 is busy. There is another X
server running already.
Sep 25 11:06:29 localhost gdm[2922]: Display :0 is busy. There is another X
server running already.
Sep 25 11:06:57 localhost shutdown[2950]: shutting down for system halt

Which looks pretty much the same as what I posted into this bug actually :
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207432
Comment 5 Stephen Tweedie 2006-09-25 08:05:20 EDT
Right, I'll close it as a dup.

*** This bug has been marked as a duplicate of 207432 ***

Note You need to log in before you can comment on or make changes to this bug.