Bug 207931 - Evaluation migration assistant [NEEDINFO]
Evaluation migration assistant
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 09:55 EDT by Rahul Sundaram
Modified: 2014-09-04 00:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-04 00:58:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jonstanley: needinfo? (sundaram)


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2006-09-25 09:55:59 EDT
Description of problem:

We need to provide a easy way for users to migrate from Windows to Fedora.
Though Anaconda provides the ability to dual boot systems easily, migrating all
the user data is tedious. 

Expected results:

Users should be offered the ability to migrate all their data as much as
possible automatically during or post installation. 

Additional info:

https://wiki.ubuntu.com/MigrationAssistance
Code is at http://www.evalicious.com/projects/migration-assistant/

It would probably help to read NTFS partitions too but that is yet undecided by
the counsel. We should atleast have the infrastructure in place to read FAT
partitions for now.
Comment 1 Bill Nottingham 2006-09-25 12:49:45 EDT
Start it off in Extras?
Comment 2 Rahul Sundaram 2006-09-25 12:54:08 EDT
It probably requires tight integration with the installer so that the data is
already migrated on first login. Not sure that it can be packaged stand alone in
extras. Someone who can look at the code available would be able to judge that. 

Would be very useful especially on the desktop. 
Comment 3 Jon Stanley 2008-05-12 17:35:23 EDT
Don't we already mount NTFS volumes that we find?  I'm not sure, since I don't
have Windows machines around here :), but I thought we did.

Admittedly, it's a manual process if you want to completely migrate, but ntfs-3g
has gotten us a long ways.
Comment 4 Bill Nottingham 2008-12-01 16:51:54 EST
Assigning to desktop gurus.

Note You need to log in before you can comment on or make changes to this bug.