Bug 20804 - Trio3D unable to switch monitor to powerdown state
Summary: Trio3D unable to switch monitor to powerdown state
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-13 23:54 UTC by Oleg Titov
Modified: 2007-03-27 03:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 00:32:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Oleg Titov 2000-11-13 23:54:40 UTC
screensaver is unable to switch Trio3D card with ViewSonic GA655 monitor to
power down state. The error message on console is:

GetModeLine - scrn: 0 clock: 56300
GetModeLine - hdsp: 800 hbeg: 832 hend: 896 httl: 1048
              vdsp: 600 vbeg: 601 vend: 604 vttl: 631 flags: 5
        Trio3D -- Display is on...turning off
        Trio3D -- S3VNopAllCmdSets: SubsysStats#1 = 0x20007f80
        Trio3D -- S3VNopAllCmdSets: state changed after 0 iterations
        Trio3D -- S3VNopAllCmdSets: SubsysStats#2 = 0x1f815f80
        Trio3D -- GE was on ST#1: 0x20007f80 ST#2: 0x20007f80
        Trio3D -- S3VNopAllCmdSets: SubsysStats#1 = 0x2e007f80
        Trio3D -- S3VNopAllCmdSets: state changed after 0 iterations
        Trio3D -- S3VNopAllCmdSets: SubsysStats#2 = 0x2d815f80
        Trio3D -- S3VNopAllCmdSets: SubsysStats#1 = 0x20007f80
        Trio3D -- S3VNopAllCmdSets: state changed after 0 iterations
        Trio3D -- S3VNopAllCmdSets: SubsysStats#2 = 0x1f815f80

Comment 1 Need Real Name 2000-11-17 01:49:21 UTC
I have this problem too.  I have an NVidia TNT2 and a sceptre dragoneyes D98A
monitor.
xset +dpms
xset dpms force (off|standby|suspend)
all fail to do anything.

It worked with RH 6.2  Perhaps this is an X 4.0 bug?

this looks to be the same bug as bug #20804

Comment 2 Need Real Name 2000-11-17 01:50:54 UTC
I have this problem too.  I have an NVidia TNT2 and a sceptre dragoneyes D98A
monitor.
xset +dpms
xset dpms force (off|standby|suspend)
all fail to do anything.

It worked with RH 6.2  Perhaps this is an X 4.0 bug?

this looks to be the same bug as bug #20804

Comment 3 Need Real Name 2000-11-17 20:56:38 UTC
I fixed this by putting the line:
Option "DPMS"
in the /etc/X11/XF86Config-4 file in the Monitor section.  I have heard that if
that doesn't work, try putting
Option "power_save"

The guys on the X newbie list rule!

Hope that works for you!


Comment 4 Mike A. Harris 2001-03-20 07:45:36 UTC
Powerdown works for me here.


Note You need to log in before you can comment on or make changes to this bug.