This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 208119 - NetLabel interface has changed in the upstream kernels
NetLabel interface has changed in the upstream kernels
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 11:36 EDT by Paul Moore
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 10:57:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Moore 2006-09-26 11:36:00 EDT
Description of problem:
A patchset has been accepted into the net-2.6 git tree for the 2.6.19 kernel
which fixes several critical NetLabel bugs as well changes the kernel-userspace
interface used by NetLabel.  These patches should be backported into the latest
FC6/RHEL5 kernels for compatiability reasons.

 * http://marc.theaimsgroup.com/?t=115920783800009&r=1&w=2

Version-Release number of selected component (if applicable):
N/A

How reproducible:
N/A

Steps to Reproduce:
1. N/A
2.
3.
  
Actual results:
N/A

Expected results:
N/A

Additional info:
This directly effects the LSPP efforts of RH, HP, and IBM.
Comment 1 Eric Paris 2006-09-26 17:22:08 EDT
It appears I also needed the patch sets

http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=a5531a5d852008be40811496029012f4ad3093d1
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=fe4944e59c357f945f81bc67edb7ed1392e875ad

for these fixes.   I'm building a kernel now for testing, should have something
up tomorrow on my people page for others.
Comment 2 Jay Turner 2006-09-28 06:22:56 EDT
Setting the 5.0.0 flag since it wasn't set.
Comment 3 Linda Wang 2006-09-28 09:25:14 EDT
patch posted to rhkernel-list on 9/27.
Comment 4 Don Zickus 2006-09-28 18:31:02 EDT
in kernel-2.6.18-1.2707.el5.bz208456
Comment 5 Jay Turner 2006-09-29 13:53:49 EDT
QE ack for RHEL5B2 according to section 21a of the release criteria.

Note You need to log in before you can comment on or make changes to this bug.