Bug 208131 - service clvmd restart fails with connect fail on local socket
service clvmd restart fails with connect fail on local socket
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: lvm2-cluster (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christine Caulfield
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 12:17 EDT by NetApp filed bugzillas
Modified: 2010-01-11 23:05 EST (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-0046
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-10 17:06:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
init script patch (667 bytes, patch)
2006-09-27 05:07 EDT, Christine Caulfield
no flags Details | Diff

  None (edit)
Description NetApp filed bugzillas 2006-09-26 12:17:50 EDT
Description of problem:
"service clvmd restart" command fails. The error output provided on the screen is
service clvmd restart
Deactivating VG rhclust:                                   [  OK  ]
Stopping clvm:                                             [  OK  ]
Activating VGs:   connect() failed on local socket: Connection refused
  Locking type 2 initialisation failed.
                                                           [FAILED]

when I tried "service clvmd stop" and "service clvmd start"  it worked fine. So
it looks like a timing issue. After adding a sleep of 3 secs in
/etc/init.d/clvmd restart option, the script worked fine.

Here is the patch for the same
--- /etc/init.d/clvmd.orig      2006-09-27 00:09:01.000000000 +0530
+++ /etc/init.d/clvmd   2006-09-27 00:09:15.000000000 +0530
@@ -112,6 +112,7 @@
   restart)
        if stop
        then
+               sleep 3
                start
        fi 
        rtrn=$?



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install redhat cluster and rehdta gfs 4
2. configure redhatcluster and gfs with clvm
3. run "service clvmd restart"
  
Actual results:
[ root@ganga:~/ ]
>service clvmd restart
Deactivating VG rhclust:                                   [  OK  ]
Stopping clvm:                                             [  OK  ]
Activating VGs:   connect() failed on local socket: Connection refused
  Locking type 2 initialisation failed.
                                                           [FAILED]


Expected results:

[ root@ganga:~/ ]
>service clvmd restart
Deactivating VG rhclust:                                   [  OK  ]
Stopping clvm:                                             [  OK  ]
Starting clvmd:                                            [  OK  ]
Activating VGs:                                            [  OK  ]

Additional info:
Comment 1 Christine Caulfield 2006-09-27 03:47:36 EDT
clvmd opens the local socket as soon as it can - well before it starts
processing requests that come into it - to try to alleviate this problem; In
fact it's he first thing it does after forking into the background!

If there are still delays here, they are going to have to be addressed in the
startup script I think.
Comment 2 Christine Caulfield 2006-09-27 05:07:00 EDT
Created attachment 137204 [details]
init script patch

This is a slightly less "sleep"y version of the patch that will try and wait
until clvmd has actually finished before restarting it.
Comment 3 Christine Caulfield 2006-10-04 04:43:02 EDT
OK, I've committed this. Hopefully QE will give it some beating.

Checking in scripts/clvmd_init_rhel4;
/cvs/lvm2/LVM2/scripts/clvmd_init_rhel4,v  <--  clvmd_init_rhel4
new revision: 1.8; previous revision: 1.7
done
Comment 4 Corey Marthaler 2006-12-18 17:33:16 EST
Marking verified in lvm2-cluster-2.02.17-1

Ran looping restarts with 5 cmirror volumes.
Comment 6 Red Hat Bugzilla 2007-05-10 17:06:59 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0046.html

Note You need to log in before you can comment on or make changes to this bug.