Bug 208171 - library search path problem
library search path problem
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 14:56 EDT by Behdad Esfahbod
Modified: 2007-12-20 11:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2006-09-26 14:56:22 EDT
Description of problem:

Firefox doesn't build here for me:

g++ -mcpu=pentium4 -march=pentium4 -mtune=pentium4 -g -O3 -Wall -Wextra 
-Wno-missing-field-initializers -Wsign-compare -Wmissing-include-dirs
-Wstrict-aliasing=2 -Wlarger-than-65500 -Wpointer-arith -Wwrite-strings -Winline
-Wformat=2 -Winit-self -Wswitch-default -Wswitch-enum -Wpacked
-Wunsafe-loop-optimizations -Wmissing-format-attribute -o firefox-bin
-I/home/behdad/.local/include  -Wno-error -Wfatal-errors  -fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -pedantic -I/home/behdad/.local/include -Wno-error
-Wno-unused-parameter -Wfatal-errors -fshort-wchar -pthread -pipe  -DNDEBUG
-DTRIMMED -Os -g -march=i386 -mcpu=i686  nsBrowserApp.o  
-Wl,-rpath,/usr/lib/firefox-1.5.0.7   -L../../dist/bin -L../../dist/lib  
../../dist/lib/libxulapp_s.a -L../../dist/bin -lmozjs -L../../dist/bin -lxpcom
-lxpcom_core  -L/usr/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl
-L/home/behdad/.local/lib   -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0
-lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0
-lgmodule-2.0 -ldl -lglib-2.0     -lX11  -ldl -lm      
/home/behdad/.local/lib/libpangoft2-1.0.so.0: undefined reference to
`pango_font_description_get_gravity'
/home/behdad/.local/lib/libpangoft2-1.0.so.0: undefined reference to
`pango_font_description_set_gravity'
/home/behdad/.local/lib/libpangoft2-1.0.so.0: undefined reference to
`pango_quantize_line_geometry'
/home/behdad/.local/lib/libpangoft2-1.0.so.0: undefined reference to
`pango_gravity_get_type'
/home/behdad/.local/lib/libpangoft2-1.0.so.0: undefined reference to
`pango_font_describe_with_absolute_size'
collect2: ld returned 1 exit status
gmake[3]: *** [firefox-bin] Error 1
gmake[3]: Leaving directory
`/home/behdad/src/redhat/firefox/devel/mozilla/browser/app'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/home/behdad/src/redhat/firefox/devel/mozilla/browser'
gmake[1]: *** [tier_99] Error 2
gmake[1]: Leaving directory `/home/behdad/src/redhat/firefox/devel/mozilla'


This is because of the -L/usr/lib in the bulid command.  That doesn't make sense
and should be removed.  It's coming from config/autoconf.mk around NSS stuff.
Comment 1 Christopher Aillon 2006-09-29 17:05:20 EDT
Are you doing your own local build instead of using the SRPM to rebuild?  Should
be fixed in the SRPM with patches....  The first couple of build patches pertain
to NSS stuff; not sure which this specific issue is but you probably need them
all in order to build.
Comment 2 Behdad Esfahbod 2006-12-19 18:28:58 EST
(In reply to comment #1)
> Are you doing your own local build instead of using the SRPM to rebuild?  Should
> be fixed in the SRPM with patches....  The first couple of build patches pertain
> to NSS stuff; not sure which this specific issue is but you probably need them
> all in order to build.

No, this is happening with make i386 using brew.  Happened again now.
Comment 3 Matěj Cepl 2007-12-20 11:47:03 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.