Bug 208193 - Anaconda dies while trying upgrade boot/grub.conf on existing FC5 installation.
Summary: Anaconda dies while trying upgrade boot/grub.conf on existing FC5 installation.
Status: CLOSED DUPLICATE of bug 208093
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-26 21:34 UTC by Gilboa Davara
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 20:09:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash log (53.52 KB, application/x-gzip)
2006-09-26 21:34 UTC, Gilboa Davara
no flags Details

Description Gilboa Davara 2006-09-26 21:34:24 UTC
Description of problem:
I'm trying upgrade an existing i386 installation of FC5 using 20060927 rawhide.
The upgrade itself seem to proceed just fine, (Though I did encounter BZ 208093
and 208094 during the previous installation attempts) but when it tries to
finalize the installation by upgrading the preexisting grub configuration,
Anaconda throws an exception and dies.

Version-Release number of selected component (if applicable):
Rawhide 27092006.

How reproducible:
Only tried once.

Steps to Reproduce:
1. Install FC5 with boot on a different partition.
2. Full update.
3. Boot using rawhide rescue CD.
4. Manually mount /boot.
5. Try a full upgrade.
  
Actual results:
Anaconda throws an exception while trying to upgrade grub.conf.

Expected results:
Working boot configuration.

Additional info:
Attached crash log.

Comment 1 Gilboa Davara 2006-09-26 21:34:25 UTC
Created attachment 137175 [details]
Anaconda crash log

Comment 2 Jeremy Katz 2006-09-27 18:55:57 UTC
This is happening because we're not mounting your /boot -- is it listed in
/etc/fstab?

Comment 3 Gilboa Davara 2006-09-27 20:04:18 UTC
Yes it is:

$ cat /etc/fstab | grep boot
LABEL=/boot   /boot    ext3    noauto,defaults     1 2

- Gilboa

Comment 4 Gilboa Davara 2006-09-27 20:07:28 UTC
... I should point out that Anaconda failed to mount boot
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=208093) so I mounted it by
hand into /mnt/sysimage/boot

- Gilboa

Comment 5 Jeremy Katz 2006-09-27 20:09:16 UTC
Same root cause at least, so going to consolidate

*** This bug has been marked as a duplicate of 208093 ***


Note You need to log in before you can comment on or make changes to this bug.