Bug 208199 - gnome-screensaver crashes on start
gnome-screensaver crashes on start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-26 18:23 EDT by Kristoffer Gleditsch
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 14:37:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome-screensaver --debug --no-daemon output (4.42 KB, text/plain)
2006-09-26 18:23 EDT, Kristoffer Gleditsch
no flags Details
output from gdb (10.37 KB, text/plain)
2006-09-27 17:13 EDT, Kristoffer Gleditsch
no flags Details
xorg.conf used to reproduce the crashing behaviour (2.51 KB, text/plain)
2006-09-27 17:27 EDT, Kristoffer Gleditsch
no flags Details
output from gdb with debuginfo (17.09 KB, text/plain)
2006-09-30 12:39 EDT, Kristoffer Gleditsch
no flags Details

  None (edit)
Description Kristoffer Gleditsch 2006-09-26 18:23:12 EDT
Description of problem:

When trying to lock/blank the screen, gnome-screensaver dies with an X Window
System Error.  

Seems to happen consistently on updated FC6T3 (with exception of gsf-sharp and
hsqldb, which give me checksum errors from the mirrors.)

System is a Dell Latitude X1 laptop with an "Intel Corporation Mobile
915GM/GMS/910GML Express Graphics Controller".  

Version-Release number of selected component (if applicable):

$ rpm -qf /usr/bin/gnome-screensaver
gnome-screensaver-2.16.0-5.fc6

$ ldd -v /usr/bin/gnome-screensaver | perl -ne 's,^\s*(/.*):$,$1,g && print;' |
xargs rpm -qf | sort | uniq
atk-1.12.2-1.fc6
cairo-1.2.4-1.fc6
dbus-0.93-2.fc6
dbus-glib-0.70-4
expat-1.95.8-8.2.1
fontconfig-2.4.1-2.fc6
freetype-2.2.1-10.fc6
gamin-0.1.7-7.fc6
GConf2-2.14.0-2.1
glib2-2.12.3-2.fc6
glibc-2.4.90-35
gnome-menus-2.16.0-2.fc6
gnome-screensaver-2.16.0-5.fc6
gtk2-2.10.4-2.fc6
libcap-1.10-25
libICE-1.0.1-2.1
libpng-1.2.10-6
libSM-1.0.1-3.1
libX11-1.0.3-3.fc6
libXau-1.0.1-3.1
libXcursor-1.1.7-1.1
libXdmcp-1.0.1-2.1
libXext-1.0.1-2.1
libXfixes-4.0.1-2.1
libXi-1.0.1-3.1
libXinerama-1.0.1-2.1
libXrandr-1.1.1-3.1
libXrender-0.9.1-3.1
libXScrnSaver-1.1.0-3.1
nspr-4.6.3-1
nss-3.11.3-2
ORBit2-2.14.3-3.fc6
pango-1.14.4-1.fc6
zlib-1.2.3-3


How reproducible:

Seems completely reproducible here, by trying to lock the screen using main menu
-> "Lock screen".

Actual results:

Screen turns black briefly, then returns to the Gnome desktop I came from.

Expected results:

A locked screen.

Additional info:

Attached is the output from "gnome-screensaver --debug  --no-daemon" when I try
to lock the screen.
Comment 1 Kristoffer Gleditsch 2006-09-26 18:23:12 EDT
Created attachment 137180 [details]
gnome-screensaver --debug  --no-daemon output
Comment 2 jmccann 2006-09-26 20:17:57 EDT
Can you please attach the output from the following?  That will be a big help. 
Thank you.

gdb --args gnome-screensaver --no-daemon --debug --sync
(gdb) break gdk_x_error
Make breakpoint pending on future shared library load? (y or [n]) y
(gdb) run

(gdb) bt
Comment 3 Kristoffer Gleditsch 2006-09-27 17:13:27 EDT
Created attachment 137252 [details]
output from gdb

(Doesn't look as if the breakpoint found anything to break...?)
Comment 4 Kristoffer Gleditsch 2006-09-27 17:26:03 EDT
I didn't think of checking with the out-of-the-box xorg.conf.  Sorry about that.
I tested it now, and I couldn't reproduce this crash with the original config
file.  I'm attaching my xorg.conf as well, in case anyone wants to look at it.
Comment 5 Kristoffer Gleditsch 2006-09-27 17:27:09 EDT
Created attachment 137253 [details]
xorg.conf used to reproduce the crashing behaviour
Comment 6 jmccann 2006-09-29 10:40:50 EDT
I think you may need to install the debuginfo rpms first.  Can you try that? 
Getting this backtrace will help a lot.  

Some info here:
http://fedoraproject.org/wiki/StackTraces

Particularly: gnome-screensaver, gtk+, gdk, glib

Thanks.
Comment 7 Kristoffer Gleditsch 2006-09-30 12:39:21 EDT
Created attachment 137479 [details]
output from gdb with debuginfo

Thanks for the tip about the debuginfo packages.  Here's the output  from gdb
with debuginfo packages installed.
Comment 8 jmccann 2006-10-02 10:29:33 EDT
Thanks for the info.

Was also reported upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=358963
Comment 9 jmccann 2006-10-02 12:02:37 EDT
Can you please attach a "diff -u" between your non-working xorg.conf and your
working xorg.conf?
Comment 10 jmccann 2006-10-02 13:08:00 EDT
Actually, nevermind.  The reason it didn't work with your posted xorg.conf is
due to having dual heads with different supported visuals.  This should be fixed
in CVS and 2.16.1 (released later this week).  Thanks.
Comment 11 Matthew Miller 2007-04-06 13:32:20 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]
Comment 12 Kristoffer Gleditsch 2007-04-09 14:37:23 EDT
Closing, as this bug went away when the versions with the mentioned fix made it
into Fedora.

Note You need to log in before you can comment on or make changes to this bug.