Bug 208227 - Evolution send/receive window "hangs" at the sending mail part
Evolution send/receive window "hangs" at the sending mail part
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 03:13 EDT by STEPHAN Gael
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: evolution-data-server-2.8.2-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 10:06:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 317213 None None None Never

  None (edit)
Description STEPHAN Gael 2006-09-27 03:13:54 EDT
Description of problem:
When i press send/receive button, evolution often ( 1 time on 5 try) hangs its
send/receive window on the send mail part (the bart doesn't fill). I tested with
local sendmail sending or smtp sending, it does the same

Version-Release number of selected component (if applicable):
evolution-2.8.0-6.fc6

How reproducible:
Setup two imaps accounts, with 5mn checks, and press send/receive quite often.
Dunno how to make it more reproducible

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2006-09-27 07:23:31 EDT
I've seen this too.  And often times when it's hung like that, clicking "Cancel"
or even "Cancel All" doesn't appear to do anything.
Comment 2 Bojan Smojver 2006-11-08 20:34:51 EST
Latest Evo (2.8.1.1-3.fc6) "hangs" on Send/Receive as well, but clicking X
(close window) actually closes the window. I have one IMAP account and one local
account.
Comment 3 Bojan Smojver 2006-11-08 20:44:11 EST
The GNOME bug I linked to this is only somewhat related (i.e. Cancel All doesn't
close the dialog).
Comment 4 David Nielsen 2007-03-12 23:34:06 EDT
With evolution-2.9.92-1.fc7 and evolution-data-server-1.9.92-4.fc7 I'm seeing a
hang everytime I attempt send mail. I'm also using IMAP. This though has only
cropped up in the last few days for me so I'm not sure it's the same bug.
Comment 5 Matthew Barnes 2007-03-12 23:58:48 EDT
David, would you mind posting a backtrace of a hung Evolution process?  I pushed
some experimental password-refactoring work in evolution-data-server sometime in
the last few days.  Could be related.
Comment 6 Matthew Barnes 2007-03-13 00:04:19 EDT
The original bug reported here should've been fixed with
evolution-data-server-2.8.2-2.fc6.
Comment 7 David Nielsen 2007-03-13 00:16:23 EDT
This is what I get when attaching to the evolution-data-server process, I don't
kniw if that is what you are looking for, nothing appears to happen in terms of
getting a backtrace when attaching to the evolution process.

Thread 3 (Thread 1074006336 (LWP 3041)):
#0  0x0000003e1a0c51a6 in *__GI___poll (fds=0x2aaab0002070, nfds=11, 
    timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003abfc2fe7e in g_main_context_iterate (context=0x629540, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2979
#2  0x0000003abfc3033a in IA__g_main_loop_run (loop=0x6147d0) at gmain.c:2881
#3  0x0000003ac3245a00 in link_io_thread_fn (data=<value optimized out>)
    at linc.c:399
#4  0x0000003abfc493a4 in g_thread_create_proxy (data=0x638390)
    at gthread.c:591
#5  0x0000003e1b8061b5 in start_thread (arg=<value optimized out>)
    at pthread_create.c:296
#6  0x0000003e1a0cdd4d in clone () from /lib64/libc.so.6

Thread 2 (Thread 1105475904 (LWP 3074)):
#0  0x0000003e1a0c51a6 in *__GI___poll (fds=0x2aaab0000b40, nfds=1, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003abfc2fe7e in g_main_context_iterate (context=0x655b20, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2979
#2  0x0000003abfc3033a in IA__g_main_loop_run (loop=0x2aaab0000970)
    at gmain.c:2881
#3  0x00000039eee17f4d in startup_mainloop (arg=<value optimized out>)
    at e-book.c:3764
#4  0x0000003abfc493a4 in g_thread_create_proxy (data=0x655a30)
    at gthread.c:591
#5  0x0000003e1b8061b5 in start_thread (arg=<value optimized out>)
    at pthread_create.c:296
#6  0x0000003e1a0cdd4d in clone () from /lib64/libc.so.6

Thread 1 (Thread 46912496309568 (LWP 3040)):
#0  0x0000003e1a0c51a6 in *__GI___poll (fds=0x63f740, nfds=2, timeout=-1)
    at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x0000003abfc2fe7e in g_main_context_iterate (context=0x61c070, block=1, 
    dispatch=1, self=<value optimized out>) at gmain.c:2979
#2  0x0000003abfc3033a in IA__g_main_loop_run (loop=0x63f720) at gmain.c:2881
#3  0x0000003ac522ce06 in bonobo_main () at bonobo-main.c:311
#4  0x00000000004044be in main (argc=3, argv=<value optimized out>)
    at server.c:400
0x0000003e1a0c51a6      87        int result = INLINE_SYSCALL (poll, 3, CHECK_N
(fds, nfds), nfds, timeout);
Comment 8 David Nielsen 2007-03-13 09:04:31 EDT
Ah.. so degree of success, Evolution does not hang if I don't sign my mail and
the mail succesfully is send (and recieved). Want me to open another bug report
for that issue?
Comment 9 Matthew Barnes 2007-03-13 10:06:13 EDT
Yes, please do.  I'm going to close this bug since the original problem has
since been fixed in Fedora Core 6.

Note You need to log in before you can comment on or make changes to this bug.