Bug 208256 - forward port of SCSI blacklist from RHEL4
forward port of SCSI blacklist from RHEL4
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chip Coldwell
Brian Brock
: Reopened
: 206532 (view as bug list)
Depends On:
Blocks: 232074
  Show dependency treegraph
 
Reported: 2006-09-27 09:16 EDT by Chip Coldwell
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-13 16:18:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add RHEL4 blacklist entries to RHEL5 kernel (7.06 KB, patch)
2006-09-29 15:36 EDT, Chip Coldwell
no flags Details | Diff
SCSI blacklist patch (4.04 KB, patch)
2006-10-06 14:02 EDT, Chip Coldwell
no flags Details | Diff

  None (edit)
Description Chip Coldwell 2006-09-27 09:16:23 EDT
We need to bring the SCSI blacklist from RHEL4 into RHEL5.
Comment 1 RHEL Product and Program Management 2006-09-27 13:03:59 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 2 Chip Coldwell 2006-09-27 14:44:42 EDT
Note that (BLIST_SPARSELUN | BLIST_LARGELUN) can be replaced with
BLIST_SPARSELUN iff (starget->scsi_level >= SCSI_3).  Therefore, if the upstream
kernel matches except for this difference, I chose the upstream version.

Chip
Comment 3 Chip Coldwell 2006-09-27 14:55:51 EDT
The comment says "Note that all USB devices should have the BLIST_INQUIRY_36
flag."; however, at least some of the USB devices from RHEL-4 that also appear
in the RHEL5 list do not have this flag set, namely:

	{"AFT PRO", "-IX CF", "0.0>", BLIST_FORCELUN},
	{"Medion", "Flash XL  MMC/SD", "2.6D", BLIST_FORCELUN},
	{"SanDisk", "ImageMate CF-SD1", NULL, BLIST_FORCELUN},

For these cases, I also chose the upstream version.  For all other cases of USB
devices forward ported from RHEL4, I added the BLIST_INQUIRY_36 flag as
suggested by the comment.

Chip
Comment 5 Jay Turner 2006-09-29 12:54:00 EDT
B2 blocker according to section 21 of the release criteria.
Comment 6 Jay Turner 2006-09-29 13:49:49 EDT
Make that section 21a of the release criteria.
Comment 7 Chip Coldwell 2006-09-29 15:36:12 EDT
Created attachment 137431 [details]
add RHEL4 blacklist entries to RHEL5 kernel
Comment 8 Chip Coldwell 2006-09-29 15:37:59 EDT
From coldwell@redhat.com Fri Sep 29 15:35:29 2006
Date: Fri, 29 Sep 2006 15:35:29 -0400 (EDT)
From: Chip Coldwell <coldwell@redhat.com>
To: rhkernel-list@redhat.com
Subject: [PATCH RHEL5.0] BZ#208256: forward port of SCSI blacklist from RHEL4


Here I go again updating deprecated features for RHEL5.  The SCSI
blacklist in RHEL4 represents the accumulated wisdom of years of
trial-and-error and discovering the idiosyncrasies of dozens of
devices that might be attached to a customer's bus.  It would be a
very good thing if this wisdom could be brought into RHEL5.

Since I do not have all of these devices to test, we are going to have
to depend on our partners to test beta-2 and verify that they work.

To generate the entries augmenting the RHEL5 blacklist I used the
following algorithm:

1.  If an entry for the vendor and model exist in both RHEL4 and
    upstream, choose upstream.

2.  If an entry only exists in RHEL4, copy it verbatim unless it is a
    USB device, in which case I added the BLIST_INQUIRY_36 flag as
    suggested by the comment: "Note that all USB devices should have
    the BLIST_INQUIRY_36 flag."  There were some entries for USB
    devices that were in both RHEL4 and upstream which lacked this
    flag; those I left intact.

The patch is inline and attached.

--- a/drivers/scsi/scsi_devinfo.c	2006-09-19 23:42:06.000000000 -0400
+++ b/drivers/scsi/scsi_devinfo.c	2006-09-29 15:00:01.000000000 -0400
@@ -142,6 +142,8 @@ static struct {
 	{"COMPAQ", "MSA1000 VOLUME", NULL, BLIST_SPARSELUN |
BLIST_NOSTARTONADD},
 	{"COMPAQ", "HSV110", NULL, BLIST_REPORTLUN2 | BLIST_NOSTARTONADD},
 	{"DDN", "SAN DataDirector", "*", BLIST_SPARSELUN},
+	{"DDN", "S2A 8400", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"DDN", "S2A 8500", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"DEC", "HSG80", NULL, BLIST_REPORTLUN2 | BLIST_NOSTARTONADD},
 	{"DELL", "PV660F", NULL, BLIST_SPARSELUN},
 	{"DELL", "PV660F   PSEUDO", NULL, BLIST_SPARSELUN},
@@ -150,17 +152,31 @@ static struct {
 	{"DELL", "PERCRAID", NULL, BLIST_FORCELUN},
 	{"DGC", "RAID", NULL, BLIST_SPARSELUN},	/* Dell PV 650F, storage on
LUN 0 */
 	{"DGC", "DISK", NULL, BLIST_SPARSELUN},	/* Dell PV 650F, no storage
on LUN 0 */
+	{"EMC",  "Invista", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"EMC", "SYMMETRIX", NULL, BLIST_SPARSELUN | BLIST_LARGELUN |
BLIST_FORCELUN},
 	{"EMULEX", "MD21/S2     ESDI", NULL, BLIST_SINGLELUN},
+	{"eUSB", "Compact Flash", NULL, BLIST_FORCELUN | BLIST_INQUIRY_36},
 	{"FSC", "CentricStor", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"Generic", "USB SD Reader", "1.00", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"Generic", "USB Storage-SMC", "0090", BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"Generic", "USB Storage-SMC", "0180", BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"Generic", "USB Storage-SMC", "0207", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"generic", "USB Storage-SMC", "0207", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"Hama", "Card Reader   CF", "*", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"Hama", "Card Reader   MS", "*", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"Hama", "CardReaderMMC/SD", "*", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"Hama", "Card Reader   SM", "*", BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"HITACHI", "DF400", "*", BLIST_SPARSELUN},
 	{"HITACHI", "DF500", "*", BLIST_SPARSELUN},
 	{"HITACHI", "DF600", "*", BLIST_SPARSELUN},
 	{"HITACHI", "DISK-SUBSYSTEM", "*", BLIST_ATTACH_PQ3 |
BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"HITACHI", "OPEN-E", "*", BLIST_ATTACH_PQ3 | BLIST_SPARSELUN |
BLIST_LARGELUN},
+	{"HITACHI", "OPEN-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HITACHI", "OP-C-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HITACHI", "3380-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HITACHI", "3390-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HITACHI", "6586-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HITACHI", "6588-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"HP", "A6189A", NULL, BLIST_SPARSELUN | BLIST_LARGELUN},	/*
HP VA7400 */
 	{"HP", "OPEN-", "*", BLIST_REPORTLUN2}, /* HP XP Arrays */
 	{"HP", "NetRAID-4M", NULL, BLIST_FORCELUN},
@@ -168,15 +184,27 @@ static struct {
 	{"HP", "C1557A", NULL, BLIST_FORCELUN},
 	{"HP", "C3323-300", "4269", BLIST_NOTQ},
 	{"HP", "C5713A", NULL, BLIST_NOREPORTLUN},
+	{"HP", "DF400", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "DF500", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "DF600", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "OP-C-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "3380-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "3390-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "6586-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"HP", "6588-", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"IBM", "AuSaV1S2", NULL, BLIST_FORCELUN},
 	{"IBM", "ProFibre 4000R", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
 	{"IBM", "2105", NULL, BLIST_RETRY_HWERROR},
+	{"IC", "USB Storage-CFC", "322E", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"ICSI", "SD Card", "2.7C", BLIST_FORCELUN | BLIST_INQUIRY_36},
+	{"IOI", "Media Bay", "*", BLIST_FORCELUN | BLIST_INQUIRY_36},
 	{"iomega", "jaz 1GB", "J.86", BLIST_NOTQ | BLIST_NOLUN},
 	{"IOMEGA", "Io20S         *F", NULL, BLIST_KEY},
 	{"INSITE", "Floptical   F*8I", NULL, BLIST_KEY},
 	{"INSITE", "I325VM", NULL, BLIST_KEY},
 	{"iRiver", "iFP Mass Driver", NULL, BLIST_NOT_LOCKABLE |
BLIST_INQUIRY_36},
 	{"LASOUND", "CDX7405", "3.10", BLIST_MAX5LUN | BLIST_SINGLELUN},
+	{"Lexar", "Media Inc. SM/xD", "009E", BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"MATSHITA", "PD-1", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
 	{"MATSHITA", "DMC-LC5", NULL, BLIST_NOT_LOCKABLE |
BLIST_INQUIRY_36},
 	{"MATSHITA", "DMC-LC40", NULL, BLIST_NOT_LOCKABLE |
BLIST_INQUIRY_36},
@@ -188,14 +216,17 @@ static struct {
 	{"NAKAMICH", "MJ-4.8S", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
 	{"NAKAMICH", "MJ-5.16S", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
 	{"NEC", "PD-1 ODX654P", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
+	{"NEC", "iStorage", NULL, BLIST_REPORTLUN2},
 	{"NRC", "MBR-7", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
 	{"NRC", "MBR-7.4", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
+	{"OEI-USB2", "CompactFlash", "2.00", BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"PIONEER", "CD-ROM DRM-600", NULL, BLIST_FORCELUN |
BLIST_SINGLELUN},
 	{"PIONEER", "CD-ROM DRM-602X", NULL, BLIST_FORCELUN |
BLIST_SINGLELUN},
 	{"PIONEER", "CD-ROM DRM-604X", NULL, BLIST_FORCELUN |
BLIST_SINGLELUN},
 	{"PIONEER", "CD-ROM DRM-624X", NULL, BLIST_FORCELUN |
BLIST_SINGLELUN},
 	{"REGAL", "CDC-4X", NULL, BLIST_MAX5LUN | BLIST_SINGLELUN},
 	{"SanDisk", "ImageMate CF-SD1", NULL, BLIST_FORCELUN},
+	{"SEAGATE", "DAT DAT72-400", "*", BLIST_FORCELUN},
 	{"SEAGATE", "ST34555N", "0930", BLIST_NOTQ},	/* Chokes on tagged
INQUIRY */
 	{"SEAGATE", "ST3390N", "9546", BLIST_NOTQ},
 	{"SGI", "RAID3", "*", BLIST_SPARSELUN},
@@ -203,6 +234,7 @@ static struct {
 	{"SGI", "TP9100", "*", BLIST_REPORTLUN2},
 	{"SGI", "Universal Xport", "*", BLIST_NO_ULD_ATTACH},
 	{"IBM", "Universal Xport", "*", BLIST_NO_ULD_ATTACH},
+	{"SMSC", "223 U HS-CF", "1.95", BLIST_FORCELUN | BLIST_INQUIRY_36},
 	{"SMSC", "USB 2 HS-CF", NULL, BLIST_SPARSELUN | BLIST_INQUIRY_36},
 	{"SONY", "CD-ROM CDU-8001", NULL, BLIST_BORKEN},
 	{"SONY", "TSL", NULL, BLIST_FORCELUN},		/* DDS3 & DDS4
autoloaders */
@@ -210,14 +242,21 @@ static struct {
 	{"SUN", "T300", "*", BLIST_SPARSELUN},
 	{"SUN", "T4", "*", BLIST_SPARSELUN},
 	{"TEXEL", "CD-ROM", "1.06", BLIST_BORKEN},
+	{"Tornado-", "F4", "*", BLIST_NOREPORTLUN},
 	{"TOSHIBA", "CDROM", NULL, BLIST_ISROM},
 	{"TOSHIBA", "CD-ROM", NULL, BLIST_ISROM},
+	{"TwinMOS", "7-in-1 Card RWCF", "0100", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"USB2.0", "CardReader SM RW", "0814", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"USB2.0", "CardReader CF RW", "0.0>", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"USB2.0", "CF  CardReader", NULL, BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"USB2.0", "SMARTMEDIA/XD", NULL, BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"WangDAT", "Model 2600", "01.7", BLIST_SELECT_NO_ATN},
 	{"WangDAT", "Model 3200", "02.2", BLIST_SELECT_NO_ATN},
 	{"WangDAT", "Model 1300", "02.4", BLIST_SELECT_NO_ATN},
 	{"WDC WD25", "00JB-00FUA0", NULL, BLIST_NOREPORTLUN},
 	{"XYRATEX", "RS", "*", BLIST_SPARSELUN | BLIST_LARGELUN},
+	{"Y-E DATA", "CF Card Reader", "1.03", BLIST_FORCELUN |
BLIST_INQUIRY_36},
+	{"Zynet", "USB Storage-SMC", "I03A", BLIST_FORCELUN |
BLIST_INQUIRY_36},
 	{"Zzyzx", "RocketStor 500S", NULL, BLIST_SPARSELUN},
 	{"Zzyzx", "RocketStor 2000", NULL, BLIST_SPARSELUN},
 	{ NULL, NULL, NULL, 0 },


Chip

-- 
Charles M. "Chip" Coldwell
Senior Software Engineer
Red Hat, Inc
978-392-2426


Comment 9 Chip Coldwell 2006-10-06 14:02:47 EDT
Created attachment 137936 [details]
SCSI blacklist patch
Comment 10 Chip Coldwell 2006-10-06 14:10:03 EDT
*** Bug 206532 has been marked as a duplicate of this bug. ***
Comment 11 Don Zickus 2006-10-09 17:44:05 EDT
in kernel-2.6.18-1.2718.el5
Comment 13 Jay Turner 2006-11-17 13:51:18 EST
Verified with 2.6.18-1.2747.el5.
Comment 14 Chip Coldwell 2007-03-13 16:11:02 EDT
Posted touch-up patch

--- linux-2.6.18.i686/drivers/scsi/scsi_devinfo.c.orig  2007-03-13
16:08:01.929524000 -0400
+++ linux-2.6.18.i686/drivers/scsi/scsi_devinfo.c       2007-03-13
16:08:17.768669000 -0400
@@ -211,7 +211,7 @@ static struct {
        {"PIONEER", "CD-ROM DRM-624X", NULL, BLIST_FORCELUN | BLIST_SINGLELUN},
        {"REGAL", "CDC-4X", NULL, BLIST_MAX5LUN | BLIST_SINGLELUN},
        {"SanDisk", "ImageMate CF-SD1", NULL, BLIST_FORCELUN},
-       {"SEAGATE", "DAT DAT72-400", "*", BLIST_FORCELUN},
+       {"SEAGATE", "DAT    DAT72-400", "*", BLIST_FORCELUN},
        {"SEAGATE", "ST34555N", "0930", BLIST_NOTQ},    /* Chokes on tagged
INQUIRY */
        {"SEAGATE", "ST3390N", "9546", BLIST_NOTQ},
        {"SGI", "RAID3", "*", BLIST_SPARSELUN},

Note You need to log in before you can comment on or make changes to this bug.