Bug 208279 - Regression in new traceroute implementation
Regression in new traceroute implementation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: traceroute (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
ReviewOct20
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 11:57 EDT by Dmitry Butskoy
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:13:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 176587 None None None Never

  None (edit)
Description Dmitry Butskoy 2006-09-27 11:57:21 EDT
RHEL5b1 includes a new traceroute-1.0.4 (epoch 2) implementation.

The main idea of switching to this implementation is to avoid using setuid bit,
i.e. allow to do things even by unprivileged process.

Unfortunately this new implementation has significant regression -- it does not
support tracing using ICMP echo packets (i.e. "traceroute -I").

Tracing of a network using ICMP is very widely used. Absence of such possibility
will create real problems at clients who use RHEL for network infrastructure
(remote servers, routers, firewalls, etc.)

Besides that, the new traceroute's code seems to be a pre-beta stuff, see some
examples in the appropriate Fedora's bug #176587
Comment 1 Martin Bacovsky 2006-10-05 08:42:20 EDT
As is seen in #176587 Dmitry Butskoy developed new traceroute which has all
required features (IPv6 support, ICMP, ICMP6, ...) and same interface as old
traceroute. It uses UDP by default so it does not need suid set. Current version
seems to be stable, but I will do some further testing. I would like to change
to Dmitry's upstream in RHEL5.
Comment 2 RHEL Product and Program Management 2006-10-05 08:47:18 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 6 Dmitry Butskoy 2006-10-07 12:57:37 EDT
There is a discussion started in fedora-devel-list, see
https://www.redhat.com/archives/fedora-devel-list/2006-October/msg00101.html
Comment 7 Jay Turner 2006-10-10 16:00:45 EDT
QE ack for RHEL5B2 according to section 21a of the release criteria.
Comment 8 Dmitry Butskoy 2006-10-11 11:27:43 EDT
The final version (targeted for FC6) is here:
http://dmitry.butskoy.name/traceroute/traceroute-1.9.7-1.src.rpm

I consider this version as 2.0rc . No more new features for a while.
Comment 9 Dmitry Butskoy 2006-10-16 11:27:11 EDT
The final one:
http://dmitry.butskoy.name/traceroute/traceroute-2.0.0-1.src.rpm
Comment 10 Martin Bacovsky 2006-10-20 04:44:45 EDT
Package is now commited in cvs in REHEL-5 branch and was built successfully.
Comment 13 Dmitry Butskoy 2006-10-31 07:34:37 EST
The latest upstream:
http://dmitry.butskoy.name/traceroute/traceroute-2.0.2.tar.gz


Note You need to log in before you can comment on or make changes to this bug.