Bug 20830 - IMAP update breaks Netscape Mail Notification
IMAP update breaks Netscape Mail Notification
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: imap (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-14 09:38 EST by John Dalbec
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 16:42:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This works for me. YMMV. Some of the changes are probably not needed. (1.91 KB, patch)
2001-04-04 12:56 EDT, John Dalbec
no flags Details | Diff

  None (edit)
Description John Dalbec 2000-11-14 09:38:06 EST
The IMAP-2000 packages cause Netscape Mail Notification to repeatedly request the user's password when the
user has selected the IMAP protocol.  This problem does not occur with the POP protocol.
Platform is S/390.
Comment 1 MEGASOFT HACKERS GROUP 2000-11-20 05:01:48 EST
Yes, i found this strange bug. My server - RedHat 6.1 i386, client Win95+Netscape 4.76-En.
Possible this bug in nsnotify (simplified protocol).
POP work correct.

P.S. to jpdalbec@cc.ysu.edu: Netscape available for S/390 ?????
Comment 2 John Dalbec 2000-11-20 08:54:04 EST
Um, no.  Netscape is not available for S/390 AFAIK.  I meant the Linux IMAP server
was running on S/390.  I reported the bug with a platform of "all" because S/390
is not one of the options.
Comment 3 MEGASOFT HACKERS GROUP 2000-11-20 10:22:39 EST
RedHat Linux available for S/390 ?????
Comment 4 John Dalbec 2000-11-20 11:01:02 EST
No, not officially...
The beauty of open source:
rpm -Uvh <SRPM>; rpm -bb <SPEC>; rpm -Uvh <RPM(s)>

As you say, it's probably a bug in nsnotify.
It would have been nice to have some advance warning though.
"Warning: this security update will break nsnotify.exe for IMAP users!"
Shall we NOTABUG this?
Comment 5 Mike A. Harris 2000-11-20 11:45:53 EST
The problem that is occuring for you is not clear wether it is an IMAP
server bug, a Netscape bug, or some combination of both.  Also not clear
is what platform each piece of software is running on.  Red Hat Linux
is not available for S/390, so such a platform is definitely not
supported, and is why no S/390 option exists in bugzilla.

In order to assess the situation properly, we'll need a much clearer
description of the problem, including exactly which OS is running what,
This bug report was initially filed as an IMAP bug report which means imap
running on Red Hat Linux on one of the listed supported architectures. If
imap _is_ running on Red Hat Linux, please indicate which platform
(i386/alpha, etc) that imap is running on.  Also please provide specific
details as to how to replicate the problem if you can.

Take care.
Comment 6 John Dalbec 2000-11-20 13:44:04 EST
Mr./Ms. megasofthg is running on a supported architecture.  Ask him/her.

megasofthg@mail.ru wrote:
>Yes, i found this strange bug. My server - RedHat 6.1 i386, client Win95+Netscape 4.76-En.
Comment 7 MEGASOFT HACKERS GROUP 2000-11-21 07:56:54 EST
Yes, i run my server on RedHat 6.1, Celeron 533, RAM-128Mb. Latest update
aplied, include imap-2000 update.

My client system - Win95 with Netscape 4.76-En, i access my mailbox via IMAP.
And i run small program NSNOTIFY.EXE (like xbiff) from Netscape package 
( periodicaly check my mailbox, and notify when new mail received). After
upgrade imap-4.5 to imap-2000 my NSNOTIFY.EXE ask password, try connect, and
again ask me password. In maillog i see : 'Imap: Login user=???? from host
boss.universal.int'. Maybe NSNOTIFY.EXE broken ? I don't know :) Maybe different
version of IMAP.

When i run Netscape Messanger, all ok and i may access my mail via IMAP.
Comment 8 MEGASOFT HACKERS GROUP 2000-12-05 08:30:18 EST
Hi again. I have trace via telnet old version imap ( from RH 6.1 i386) and "buggy" update imap-2000 for RH 6.x

For old version ( imap-4.5 ):
-----------------------------------
* OK server.universal.int IMAP4rev1 v12.250 server ready
A1 CAPABILITY
* CAPABILITY IMAP4 IMAP4REV1 NAMESPACE IDLE SCAN SORT MAILBOX-REFERRALS LOGIN-RT
A1 OK CAPABILITY completed
A2 LOGIN "boss" "xxxxxxxx"
A2 OK LOGIN completed
A3 EXAMINE INBOX
* 1 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 954329614] UID validity status
* OK [UIDNEXT 1366] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS ()] Permanent flags
* OK [UNSEEN 1] first unseen message in /home/boss/mbox
A3 OK [READ-ONLY] EXAMINE completed
A4 LOGOUT
* BYE server.universal.int IMAP4rev1 server terminating connection
A4 OK LOGOUT completed
--------------------------------------------------------------------------------------

and for imap-2000
--------------------------------------------------------------------------------------
* OK [CAPABILITY IMAP4 IMAP4REV1 STARTTLS LOGIN-REFERRALS AUTH=LOGIN] server.un)
A1 CAPABILITY
* CAPABILITY IMAP4 IMAP4REV1 STARTTLS NAMESPACE IDLE MAILBOX-REFERRALS SCAN SORN
A1 OK CAPABILITY completed
A2 LOGIN "boss" "exalibur"
* CAPABILITY IMAP4 IMAP4REV1 STARTTLS NAMESPACE IDLE MAILBOX-REFERRALS SCAN SORD
A2 OK LOGIN completed
A3 EXAMINE INBOX
* 0 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 976021186] UID validity status
* OK [UIDNEXT 3] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Draft \Seen)
* OK [PERMANENTFLAGS ()] Permanent flags
A3 OK [READ-ONLY] EXAMINE completed
A4 LOGOUT
* BYE server.universal.int IMAP4rev1 server terminating connection
A4 OK LOGOUT completed
----------------------------------------------------------------------------------------

My comments:
I see some diff:        after LOGIN "user" "passwd" imap-2000 output +CAPABILITY ..... and A2 OK LOGIN completed and imap-4.5 - no.
I not have big experience with imap4, and i no may comment this situation :(
But i have some decision - nsnotify use simplified protocol for imap4rev1 ( in some cases nsnotify check mailbox and don't alarm new 
messages ( in traced example :) when new messages exist. I not test more complexed mesaging systems ( Cyrus, Lotus Domino and etc. ).
Second variant - bugs in RH-shiped imap-server :0

!!!Note: i have now unpatched imap-200 update for handling ~/mbox. I think this not important :)
Comment 9 John Dalbec 2000-12-27 08:52:55 EST
I believe that nsnotify is confused by the extra "capability" line that is sent out after login.
On my (unsupported) system, "tcpdump" shows that it's sending 'A<#> LOGIN "<name>" "<pass>"' 
followed immediately by 'A<#+1> LOGOUT'.  Megasofthq:  Did you build this from source rather than 
downloading the binary?
Comment 10 Mike A. Harris 2001-02-26 17:24:58 EST
This is a bug in Netscape, of which we do not have the source.  All I
can suggest is to submit a bug report to Netscape, or try using Mozilla,
or Netscape 6.  Sorry.  ;o(
Comment 11 John Dalbec 2001-04-04 12:56:43 EDT
Created attachment 14649 [details]
This works for me.  YMMV.  Some of the changes are probably not needed.

Note You need to log in before you can comment on or make changes to this bug.