Bug 208303 - kernel - audit name_count array overrun
kernel - audit name_count array overrun
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 15:37 EDT by Steve Grubb
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-17 13:54:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed bug fix patch (1.21 KB, patch)
2006-09-27 15:51 EDT, Steve Grubb
no flags Details | Diff
replacement patch fixing problem (1.14 KB, patch)
2006-09-29 10:52 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2006-09-27 15:37:49 EDT
Description of problem:
Testing of cachefs found a problem with an unbounded array in the audit code of
the kernel.

Version-Release number of selected component (if applicable):
2.6.18
Comment 1 Steve Grubb 2006-09-27 15:51:43 EDT
Created attachment 137243 [details]
proposed bug fix patch

This patch was posted upstream.
Comment 2 Steve Grubb 2006-09-27 16:06:36 EDT
Setting beta2 blocker since this was a beta1 blocker last time (bz #203861).
Comment 3 RHEL Product and Program Management 2006-09-27 16:18:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Steve Grubb 2006-09-29 10:52:19 EDT
Created attachment 137397 [details]
replacement patch fixing problem

Replacement patch attached. This is accepted upstream.
Comment 5 Jay Turner 2006-09-29 12:57:02 EDT
B2 blocker according to section 3b of the release criteria.
Comment 6 Don Zickus 2006-10-11 11:57:10 EDT
in kernel-2.6.18-2725.el5
Comment 7 Jay Turner 2006-11-17 13:54:10 EST
Patch is present in 2.6.18-1.2747.el5.

Note You need to log in before you can comment on or make changes to this bug.