Bug 2083098 - Dell laptop stuck on boot when booting on battery power
Summary: Dell laptop stuck on boot when booting on battery power
Keywords:
Status: NEW
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 36
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Javier Martinez Canillas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-05-09 09:41 UTC by Entodo Ays
Modified: 2022-05-29 11:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)

Description Entodo Ays 2022-05-09 09:41:10 UTC
Description of problem:
My Dell Inspiron 5482 2-in-1 laptop doesn't boot when the charger is not connected. If I press F12 to trigger the boot menu and choose the Windows bootloader it boots fine.

Version-Release number of selected component (if applicable):
Gub version 1:2.06-10.fc35

How reproducible:
Always

Steps to Reproduce:
1. Boot without charger connected.
2. It gets stuck on Dell logo or black screen
3. Only powering off is possible. Keyboard input has no effect

Actual results:
Dell logo or black screen

Expected results:
Grub menu showing

Additional info:
https://ask.fedoraproject.org/t/dell-laptop-remains-stuck-on-dell-logo-unless-connected-to-power-supply/21873?u=entodoays

Comment 1 Entodo Ays 2022-05-11 18:40:24 UTC
I updated to Fedora 36 and the problem persists.

Comment 2 Entodo Ays 2022-05-12 06:32:39 UTC
I just discovered a workaround to boot Fedora on battery power. If I press F12 to get to the boot menu, go into the "Change boot options" entry, press Esc, computer reboots and voila! Grub menu shows and Fedora boots normally.

Could this issue be related to the fact that my /boot folder is on a BTFS partition (root)?

Comment 3 Entodo Ays 2022-05-29 11:17:00 UTC
I entered the BIOS configuration utility and added a 5 second POST delay (intended for reading any messages). The issue has been solved or rather worked around.


Note You need to log in before you can comment on or make changes to this bug.