Bug 208337 - [RHEL5 Beta1] anaconda: multipath device name is reverse order of LUN number.
[RHEL5 Beta1] anaconda: multipath device name is reverse order of LUN number.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
: OtherQA
Depends On:
Blocks: 228988 227613
  Show dependency treegraph
 
Reported: 2006-09-27 17:53 EDT by Kiyoshi Ueda
Modified: 2010-10-22 02:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0644
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:18:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kiyoshi Ueda 2006-09-27 17:53:11 EDT
Description of problem:
Installer names misleading device name for multipath devices.
It seems to be reverse order of LUN number.
(e.g. In 4 LUN environment, LUN#0 is named as "mpath3",
 LUN#1 is named as "mpath2", ..., LUN#3 is name as "mpath0".)


Version-Release number of selected component:
anaconda-11.1.0.99-1


How reproducible:
Always


Steps to Reproduce:


Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2006-10-26 15:45:23 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 4 Peter Jones 2007-06-27 10:15:51 EDT
Is this still a problem?  As far as I know this was fixed long, long ago. 
Please retest.
Comment 5 David Cantrell 2007-06-27 11:20:37 EDT
Bryn Reeves says this is fixed in the 5.1 nightly trees, but is still dependent
on hardware.  Certain systems are forced to initialize devices in a specific
order and that may not coincide with the LUN order.

However, all hardware aside, the software does init devices in LUN order.  As
soon as hardware comes in, that order is changed up.  Not much we can do about that.
Comment 6 Kiyoshi Ueda 2007-06-27 11:52:17 EDT
Yes, I confirmed this is fixed on our storages.
Comment 9 errata-xmlrpc 2007-11-07 12:18:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0644.html

Note You need to log in before you can comment on or make changes to this bug.