This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 208343 - syntax error in /etc/udev/rules.d/60-fuse.rules
syntax error in /etc/udev/rules.d/60-fuse.rules
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fuse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
: 209444 212374 212443 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-27 18:08 EDT by Nalin Dahyabhai
Modified: 2009-06-27 11:45 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 05:33:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2006-09-27 18:08:29 EDT
Description of problem:
The udev rules file for fuse seems to have a syntax error.

Version-Release number of selected component (if applicable):
fuse-2.5.3-3.fc6

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
 Sep 27 18:03:09 rapier udevd[388]: add_to_rules: invalid rule
'/etc/udev/rules.d/60-fuse.rules:1'

Expected results:
 No error message from udev.

Additional info:
It looks like there's a missing comma between the OWNER and GROUP bits:
  KERNEL="fuse", NAME="%k", MODE="0660",OWNER="root" GROUP="fuse"
should be
  KERNEL="fuse", NAME="%k", MODE="0660",OWNER="root", GROUP="fuse"
Comment 1 Peter Lemenkov 2006-10-07 02:39:21 EDT
*** Bug 209444 has been marked as a duplicate of this bug. ***
Comment 2 Torsten Rausche 2006-10-21 06:17:57 EDT
I think udev (at least version 095-14) is more happy with:

  KERNEL=="fuse", NAME=="%k", MODE=="0660", OWNER=="root", GROUP=="fuse"

Note the == instead of the single =.
Comment 3 Dawid Gajownik 2006-10-29 10:03:18 EST
*** Bug 212374 has been marked as a duplicate of this bug. ***
Comment 4 Dawid Gajownik 2006-10-29 10:04:33 EST
*** Bug 212443 has been marked as a duplicate of this bug. ***
Comment 5 Adam Goode 2006-10-29 13:24:46 EST
Comment 2 is wrong, the correct rule should be:

  KERNEL=="fuse", MODE="0660", OWNER="root", GROUP="fuse"


Note the == for KERNEL, but = for everything else. This reads "When KERNEL
equals fuse, assign MODE 0660, OWNER root, GROUP fuse." Comment 2 had only
matches, no assignments, so the rule wouldn't have any effect.

See:
http://www.reactivated.net/writing_udev_rules.html
Comment 6 Peter Lemenkov 2006-10-31 10:30:01 EST
Fixed.
Please update to version fuse-2.5.3-5

Note You need to log in before you can comment on or make changes to this bug.