Bug 208360 - Changing fonts from Kcontrol will enable hinting and make it default. All this information it writes to ~/.fonts.conf
Changing fonts from Kcontrol will enable hinting and make it default. All thi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On: 157930
Blocks: 209587
  Show dependency treegraph
 
Reported: 2006-09-27 20:22 EDT by Lawrence Lim
Modified: 2014-03-25 20:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 13:47:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lawrence Lim 2006-09-27 20:22:10 EDT
+++ This bug was initially created as a clone of Bug #157930 +++

Description of problem:
I have tried to change my appearance (spicifically fonts) from the kcontrol.
After changing the appearance i have logged into the Gnome session. I surprised
to see my hinting is enabled in Gnome, though it was not enabled. I have tried
to change the hintings from the Kcontrol and Gnome's Main menu => preferences =>
Fonts => Details => Hinting. But the result remains the same. After that i have
removed ~/.fonts.conf file, and logged into Gnome again. Then only my hinting is
disabled. 

Version-Release number of selected component (if applicable):
KDE Control Center: 3.3.1-2.1

How reproducible:
Everytime

Steps to Reproduce:
1.Change fonts from kcontrol
2.logout
3.login into Gnome session, you can find enabled hinting.
  
Actual results:
Affect the hinting style.

Expected results:
Don't affect the hinting.

Additional info:

-- Additional comment from llch@redhat.com on 2005-05-17 04:49 EST --
Moving to correct component:
[root@wow ~]# rpm -qf /usr/bin/kcontrol
kdebase-3.4.0-5


-- Additional comment from than@redhat.com on 2005-05-17 05:13 EST --
does it appear in FC4 devel tree?

-- Additional comment from ankit@redhat.com on 2005-05-17 05:59 EST --
Yes it's there on FC4 devel tree also !!!

-- Additional comment from ankit@redhat.com on 2005-05-17 06:02 EST --
Just now i got new thing. Open "kcontrol" (control-center). Click on
"Appearance". Now when you click on "Fonts" in that then only it will create
automatically ~/.fonts.conf automatically. Simply you can say that when you
click on "Fonts" in the "Appearance" tab then "kcontrol" will create
~/.fonts.conf according to the settings in the "Fonts" tab and make it default,
So it may be used in Gnome also.

-- Additional comment from ankit@redhat.com on 2005-05-17 06:20 EST --
(In reply to comment #4)
> Just now i got new thing. Open "kcontrol" (control-center). Click on
> "Appearance". Now when you click on "Fonts" in that then only it will create
> automatically ~/.fonts.conf automatically. Simply you can say that when you
> click on "Fonts" in the "Appearance" tab then "kcontrol" will create
> ~/.fonts.conf according to the 

'configuration' settings of the checkbox "use sub-pixel hinting for your fonts"
in the "Fonts" tab whether it's selected or not and make it default,

> So it may be used in Gnome also.



-- Additional comment from llch@redhat.com on 2005-09-22 01:15 EST --
Than, do you have any updates on this? Should we ask Ankit to post this to
upstream as well?

-- Additional comment from majain@redhat.com on 2006-06-08 08:36 EST --
This problem was found in rawhide too.

-- Additional comment from llim@redhat.com on 2006-09-27 20:19 EST --
Clone to Fedora devel based on Comment #7.
Comment 1 A S Alam 2007-05-03 13:47:19 EDT
Comment from Phil Knirsch
---
As font configuration is done globally and shared between Gnome and KDE using
the ~/.fonts.conf file this is actually expected and intended behaviour.

Read ya, Phil
---

Note You need to log in before you can comment on or make changes to this bug.