Bug 208372 - Graphical installation fails in PowerPc
Graphical installation fails in PowerPc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhpxl (Show other bugs)
5.0
powerpc Linux
medium Severity urgent
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
: Regression
: 208373 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-28 02:20 EDT by Aneesh
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:44:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aneesh 2006-09-28 02:20:33 EDT
Description of problem:Graphical Instalaltion fails in PowerPc,goes to text 
mode and installas the OS.While booting again after complete instalaltion also 
Xserver fails and goes to shell prompt.Never faced any problems like this in 
RHEL4 Enterprise Edition


Version-Release number of selected component (if applicable):


How reproducible:Installs in PowerPC P520


Steps to Reproduce:
1.Boot from the DVD in Power Pc p520
2.Boots up,anaconda installer starts and fails to start Graphical instalaltion
3.
  
Actual results:goes to Graphical mode


Expected results:but goes to text mode


Additional info:Also after complete installation also Xserver fails no GUI 
available.Never seen this problem with RHEL4 version in P520 server
Comment 1 Jeff Needle 2006-09-28 07:28:04 EDT
*** Bug 208373 has been marked as a duplicate of this bug. ***
Comment 2 Jeremy Katz 2006-09-28 10:36:15 EDT
Does X try to start and fail or just never try to start?
Comment 3 Aneesh 2006-10-03 01:24:55 EDT
X-server try to start and fails after the complete instalaltion is over and 
reboots.

During installation it throws an error like the following.

"Running anaconda,the RedHat Enterprise Linux Server System
installer--please wait....
 
 
probing for Video card Matrox Graphics,Inc.MGA G400/G450
attempting to start frame buffer X-server
Waiting for X-server to start--log located in /tmp/rmfs/X.log/
1...2...3....4...5 Xserver started scucessfully
 
_XllTransSocketINETConnect() Can't get address for localhost:60001:Temporarly 
Failure on name resolution
 
(mini-wm:697):Gtk-WARNING** :Cannot open display : :1
 
"

In order to avoid this in the boot prompt if i give
"export DISPALY=localhost:0.0"
it will proceed with the installation in non graphical mode
Comment 4 Jeremy Katz 2006-10-04 11:32:37 EDT
I think this is fixed with newer trees.  
Comment 10 RHEL Product and Program Management 2006-10-05 16:32:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 12 Aneesh 2006-10-10 23:37:09 EDT
I am facing the same problem with the RHEL5 beta new release with kernel 2.6.18

1.In PPC the installation only in textmode
2.After reboot the OS panics

My Platform is

PowerPC server P520,which has 3 Qlogic HBAs QLA210,QLA2342,QLA2462.

Note You need to log in before you can comment on or make changes to this bug.